aboutsummaryrefslogtreecommitdiffstats
path: root/security/wapiti
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-10-04 21:21:39 +0800
committerrafan <rafan@FreeBSD.org>2007-10-04 21:21:39 +0800
commit3cffce75960009eab474968d38f8038ab0fa5b4f (patch)
tree93a84948ad0c00f634961a2c355f0fa26aadde17 /security/wapiti
parente94b166d3dd9be803a2e3263d11f1d4bed6dc3c7 (diff)
downloadfreebsd-ports-gnome-3cffce75960009eab474968d38f8038ab0fa5b4f.tar.gz
freebsd-ports-gnome-3cffce75960009eab474968d38f8038ab0fa5b4f.tar.zst
freebsd-ports-gnome-3cffce75960009eab474968d38f8038ab0fa5b4f.zip
Wapiti allows you to audit the security of your web applications.
It performs "black-box" scans, i.e. it does not study the source code of the application but will scans the webpages of the deployed webapp, looking for scripts and forms where it can inject data. Once it gets this list, Wapiti acts like a fuzzer, injecting payloads to see if a script is vulnerable. WWW: http://wapiti.sourceforge.net/ PR: ports/116873 Submitted by: Philippe Audeoud <jadawin at tuxaco.net>
Diffstat (limited to 'security/wapiti')
-rw-r--r--security/wapiti/Makefile36
-rw-r--r--security/wapiti/distinfo3
-rw-r--r--security/wapiti/pkg-descr8
3 files changed, 47 insertions, 0 deletions
diff --git a/security/wapiti/Makefile b/security/wapiti/Makefile
new file mode 100644
index 000000000000..ecc5d12f0f70
--- /dev/null
+++ b/security/wapiti/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: wapiti
+# Date created: 3 October 2007
+# Whom: Philippe Audeoud <jadawin@tuxaco.net>
+# $FreeBSD$
+
+PORTNAME= wapiti
+PORTVERSION= 1.1.6
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= wapiti
+
+MAINTAINER= jadawin@tuxaco.net
+COMMENT= Wapiti is a vulnerability scanner for web applications
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/tidy:${PORTSDIR}/www/py-utidy
+
+USE_PYTHON= 2.3+
+NO_BUILD= yes
+PORTDOCS= README
+
+PLIST_FILES= bin/wapiti.py \
+ bin/lswww.py \
+ bin/getcookie.py \
+ bin/cookie.py \
+ bin/BeautifulSoup.py
+
+do-install:
+.for i in wapiti.py lswww.py getcookie.py cookie.py BeautifulSoup.py
+ ${INSTALL_SCRIPT} ${WRKSRC}/${i} ${PREFIX}/bin/
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/wapiti/distinfo b/security/wapiti/distinfo
new file mode 100644
index 000000000000..14cdbc12e4ce
--- /dev/null
+++ b/security/wapiti/distinfo
@@ -0,0 +1,3 @@
+MD5 (wapiti-1.1.6.tar.gz) = 8b6067b64c16b575da43aa2dbfaeea23
+SHA256 (wapiti-1.1.6.tar.gz) = cb9fb6b969d01e84e953235f7e7554fee62916aaf3215a1abd4455a0efecbaed
+SIZE (wapiti-1.1.6.tar.gz) = 51200
diff --git a/security/wapiti/pkg-descr b/security/wapiti/pkg-descr
new file mode 100644
index 000000000000..0b4f4b87743f
--- /dev/null
+++ b/security/wapiti/pkg-descr
@@ -0,0 +1,8 @@
+Wapiti allows you to audit the security of your web applications.
+It performs "black-box" scans, i.e. it does not study the source code of
+the application but will scans the webpages of the deployed webapp,
+looking for scripts and forms where it can inject data.
+Once it gets this list, Wapiti acts like a fuzzer, injecting payloads to
+see if a script is vulnerable.
+
+WWW: http://wapiti.sourceforge.net/