aboutsummaryrefslogtreecommitdiffstats
path: root/security/wolfssl
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2015-03-28 17:15:24 +0800
committerjohans <johans@FreeBSD.org>2015-03-28 17:15:24 +0800
commit42c19ad48723e9980023710c182a21d4e7a9df92 (patch)
tree93bdb5aec3e7f3cd10349de881686e06aa94bad1 /security/wolfssl
parentb2f2c442f9aa49d1be8d4258f89a71a2cb3ad9c0 (diff)
downloadfreebsd-ports-gnome-42c19ad48723e9980023710c182a21d4e7a9df92.tar.gz
freebsd-ports-gnome-42c19ad48723e9980023710c182a21d4e7a9df92.tar.zst
freebsd-ports-gnome-42c19ad48723e9980023710c182a21d4e7a9df92.zip
CyaSSL has been renamed WolfSSL upstream
Rename port and update to 3.4.0 http://www.yassl.com/yaSSL/Products-wolfssl.html
Diffstat (limited to 'security/wolfssl')
-rw-r--r--security/wolfssl/Makefile35
-rw-r--r--security/wolfssl/distinfo2
-rw-r--r--security/wolfssl/pkg-descr23
-rw-r--r--security/wolfssl/pkg-plist183
4 files changed, 243 insertions, 0 deletions
diff --git a/security/wolfssl/Makefile b/security/wolfssl/Makefile
new file mode 100644
index 000000000000..5d5b63403f9a
--- /dev/null
+++ b/security/wolfssl/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= wolfssl
+PORTVERSION= 3.4.0
+CATEGORIES= security devel
+MASTER_SITES= http://www.yassl.com/
+
+MAINTAINER= johans@FreeBSD.org
+COMMENT= Embedded SSL C-Library
+
+LICENSE= GPLv2
+
+USES= zip libtool
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-dependency-tracking \
+ --enable-shared --enable-static \
+ --enable-dtls --enable-opensslextra --enable-ipv6 \
+ --enable-dsa --enable-dh --enable-ecc --enable-sni \
+ --enable-ripemd --enable-sha512 \
+ --enable-chacha --enable-poly1305
+
+USE_LDCONFIG= yes
+PORTDOCS= *
+
+post-configure:
+ @${REINPLACE_CMD} \
+ -e 's|$${prefix}/cyassl/include|$${prefix}/include/cyassl|' \
+ -e 's|$${prefix}/cyassl/lib|$${prefix}/lib/cyassl|' \
+ -e '/^pkgconfigdir/s|(libdir)|&data|' \
+ ${WRKSRC}/Makefile
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libwolfssl.so
+
+.include <bsd.port.mk>
diff --git a/security/wolfssl/distinfo b/security/wolfssl/distinfo
new file mode 100644
index 000000000000..cdc7c93f10cb
--- /dev/null
+++ b/security/wolfssl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (wolfssl-3.4.0.zip) = bc49a142c17b1e52a126417e5d7cbadcb7f18f5c81e446c12e214483395159ea
+SIZE (wolfssl-3.4.0.zip) = 1946789
diff --git a/security/wolfssl/pkg-descr b/security/wolfssl/pkg-descr
new file mode 100644
index 000000000000..b19e1f8e0d01
--- /dev/null
+++ b/security/wolfssl/pkg-descr
@@ -0,0 +1,23 @@
+Wolfssl is an embedded SSL Library for programmers building security
+functionality into their applications and devices.
+
+Features
+ SSL version 3 and TLS versions 1, 1.1 and 1.2 (client and server)
+ Minimum size of 60-100kb, depending on build options
+ Runtime memory usage between 5-50kb
+ DTLS support (client and server)
+ OpenSSL compatibility layer
+ zlib compression support
+ integration in MySQL, stunnel, Lighttpd availible.
+ MD2, MD4, MD5, SHA-1, RIPEMD, HMAC, DES, 3DES, AES, ARC4, TWOFISH, BLOWFISH,
+ RSA, DSS, DH, and PKCS#5 PBKDF2
+ ia32 assembly for AES, 3DES, BLOWFISH, TWOFISH, ARC4, MD5, SHA, and RIPEMD
+ SSE2 instructions for Large Integers
+ Simple API
+ Interchangeable crypto and certificate libraries
+ PEM and DER certificate support
+ Very fast
+
+LICENSE: GPL2 with FOSS extension
+
+WWW: http://www.yassl.com/
diff --git a/security/wolfssl/pkg-plist b/security/wolfssl/pkg-plist
new file mode 100644
index 000000000000..0f0d9ef1d61e
--- /dev/null
+++ b/security/wolfssl/pkg-plist
@@ -0,0 +1,183 @@
+bin/wolfssl-config
+include/cyassl/callbacks.h
+include/cyassl/certs_test.h
+include/cyassl/crl.h
+include/cyassl/ctaocrypt/aes.h
+include/cyassl/ctaocrypt/arc4.h
+include/cyassl/ctaocrypt/asn.h
+include/cyassl/ctaocrypt/asn_public.h
+include/cyassl/ctaocrypt/blake2-impl.h
+include/cyassl/ctaocrypt/blake2-int.h
+include/cyassl/ctaocrypt/blake2.h
+include/cyassl/ctaocrypt/camellia.h
+include/cyassl/ctaocrypt/chacha.h
+include/cyassl/ctaocrypt/coding.h
+include/cyassl/ctaocrypt/compress.h
+include/cyassl/ctaocrypt/des3.h
+include/cyassl/ctaocrypt/dh.h
+include/cyassl/ctaocrypt/dsa.h
+include/cyassl/ctaocrypt/ecc.h
+include/cyassl/ctaocrypt/error-crypt.h
+include/cyassl/ctaocrypt/fips_test.h
+include/cyassl/ctaocrypt/hc128.h
+include/cyassl/ctaocrypt/hmac.h
+include/cyassl/ctaocrypt/integer.h
+include/cyassl/ctaocrypt/logging.h
+include/cyassl/ctaocrypt/md2.h
+include/cyassl/ctaocrypt/md4.h
+include/cyassl/ctaocrypt/md5.h
+include/cyassl/ctaocrypt/memory.h
+include/cyassl/ctaocrypt/misc.h
+include/cyassl/ctaocrypt/mpi_class.h
+include/cyassl/ctaocrypt/mpi_superclass.h
+include/cyassl/ctaocrypt/pkcs7.h
+include/cyassl/ctaocrypt/poly1305.h
+include/cyassl/ctaocrypt/pwdbased.h
+include/cyassl/ctaocrypt/rabbit.h
+include/cyassl/ctaocrypt/random.h
+include/cyassl/ctaocrypt/ripemd.h
+include/cyassl/ctaocrypt/rsa.h
+include/cyassl/ctaocrypt/settings.h
+include/cyassl/ctaocrypt/settings_comp.h
+include/cyassl/ctaocrypt/sha.h
+include/cyassl/ctaocrypt/sha256.h
+include/cyassl/ctaocrypt/sha512.h
+include/cyassl/ctaocrypt/tfm.h
+include/cyassl/ctaocrypt/types.h
+include/cyassl/ctaocrypt/visibility.h
+include/cyassl/ctaocrypt/wc_port.h
+include/cyassl/error-ssl.h
+include/cyassl/ocsp.h
+include/cyassl/openssl/asn1.h
+include/cyassl/openssl/bio.h
+include/cyassl/openssl/bn.h
+include/cyassl/openssl/conf.h
+include/cyassl/openssl/crypto.h
+include/cyassl/openssl/des.h
+include/cyassl/openssl/dh.h
+include/cyassl/openssl/dsa.h
+include/cyassl/openssl/ec.h
+include/cyassl/openssl/ecdsa.h
+include/cyassl/openssl/engine.h
+include/cyassl/openssl/err.h
+include/cyassl/openssl/evp.h
+include/cyassl/openssl/hmac.h
+include/cyassl/openssl/lhash.h
+include/cyassl/openssl/md4.h
+include/cyassl/openssl/md5.h
+include/cyassl/openssl/ocsp.h
+include/cyassl/openssl/opensslconf.h
+include/cyassl/openssl/opensslv.h
+include/cyassl/openssl/ossl_typ.h
+include/cyassl/openssl/pem.h
+include/cyassl/openssl/pkcs12.h
+include/cyassl/openssl/rand.h
+include/cyassl/openssl/ripemd.h
+include/cyassl/openssl/rsa.h
+include/cyassl/openssl/sha.h
+include/cyassl/openssl/ssl.h
+include/cyassl/openssl/stack.h
+include/cyassl/openssl/ui.h
+include/cyassl/openssl/x509.h
+include/cyassl/openssl/x509v3.h
+include/cyassl/options.h
+include/cyassl/sniffer.h
+include/cyassl/sniffer_error.h
+include/cyassl/ssl.h
+include/cyassl/test.h
+include/cyassl/version.h
+include/wolfssl/callbacks.h
+include/wolfssl/certs_test.h
+include/wolfssl/crl.h
+include/wolfssl/error-ssl.h
+include/wolfssl/ocsp.h
+include/wolfssl/openssl/asn1.h
+include/wolfssl/openssl/bio.h
+include/wolfssl/openssl/bn.h
+include/wolfssl/openssl/conf.h
+include/wolfssl/openssl/crypto.h
+include/wolfssl/openssl/des.h
+include/wolfssl/openssl/dh.h
+include/wolfssl/openssl/dsa.h
+include/wolfssl/openssl/ec.h
+include/wolfssl/openssl/ecdsa.h
+include/wolfssl/openssl/engine.h
+include/wolfssl/openssl/err.h
+include/wolfssl/openssl/evp.h
+include/wolfssl/openssl/hmac.h
+include/wolfssl/openssl/lhash.h
+include/wolfssl/openssl/md4.h
+include/wolfssl/openssl/md5.h
+include/wolfssl/openssl/ocsp.h
+include/wolfssl/openssl/opensslconf.h
+include/wolfssl/openssl/opensslv.h
+include/wolfssl/openssl/ossl_typ.h
+include/wolfssl/openssl/pem.h
+include/wolfssl/openssl/pkcs12.h
+include/wolfssl/openssl/rand.h
+include/wolfssl/openssl/ripemd.h
+include/wolfssl/openssl/rsa.h
+include/wolfssl/openssl/sha.h
+include/wolfssl/openssl/ssl.h
+include/wolfssl/openssl/stack.h
+include/wolfssl/openssl/ui.h
+include/wolfssl/openssl/x509.h
+include/wolfssl/openssl/x509v3.h
+include/wolfssl/options.h
+include/wolfssl/sniffer.h
+include/wolfssl/sniffer_error.h
+include/wolfssl/ssl.h
+include/wolfssl/test.h
+include/wolfssl/version.h
+include/wolfssl/wolfcrypt/aes.h
+include/wolfssl/wolfcrypt/arc4.h
+include/wolfssl/wolfcrypt/asn.h
+include/wolfssl/wolfcrypt/asn_public.h
+include/wolfssl/wolfcrypt/blake2-impl.h
+include/wolfssl/wolfcrypt/blake2-int.h
+include/wolfssl/wolfcrypt/blake2.h
+include/wolfssl/wolfcrypt/camellia.h
+include/wolfssl/wolfcrypt/chacha.h
+include/wolfssl/wolfcrypt/coding.h
+include/wolfssl/wolfcrypt/compress.h
+include/wolfssl/wolfcrypt/des3.h
+include/wolfssl/wolfcrypt/dh.h
+include/wolfssl/wolfcrypt/dsa.h
+include/wolfssl/wolfcrypt/ecc.h
+include/wolfssl/wolfcrypt/ecc25519.h
+include/wolfssl/wolfcrypt/ecc25519_fe.h
+include/wolfssl/wolfcrypt/ecc25519_montgomery.h
+include/wolfssl/wolfcrypt/ecc25519_pow225521.h
+include/wolfssl/wolfcrypt/error-crypt.h
+include/wolfssl/wolfcrypt/fips_test.h
+include/wolfssl/wolfcrypt/hc128.h
+include/wolfssl/wolfcrypt/hmac.h
+include/wolfssl/wolfcrypt/integer.h
+include/wolfssl/wolfcrypt/logging.h
+include/wolfssl/wolfcrypt/md2.h
+include/wolfssl/wolfcrypt/md4.h
+include/wolfssl/wolfcrypt/md5.h
+include/wolfssl/wolfcrypt/memory.h
+include/wolfssl/wolfcrypt/misc.h
+include/wolfssl/wolfcrypt/mpi_class.h
+include/wolfssl/wolfcrypt/mpi_superclass.h
+include/wolfssl/wolfcrypt/pkcs7.h
+include/wolfssl/wolfcrypt/poly1305.h
+include/wolfssl/wolfcrypt/pwdbased.h
+include/wolfssl/wolfcrypt/rabbit.h
+include/wolfssl/wolfcrypt/random.h
+include/wolfssl/wolfcrypt/ripemd.h
+include/wolfssl/wolfcrypt/rsa.h
+include/wolfssl/wolfcrypt/settings.h
+include/wolfssl/wolfcrypt/sha.h
+include/wolfssl/wolfcrypt/sha256.h
+include/wolfssl/wolfcrypt/sha512.h
+include/wolfssl/wolfcrypt/tfm.h
+include/wolfssl/wolfcrypt/types.h
+include/wolfssl/wolfcrypt/visibility.h
+include/wolfssl/wolfcrypt/wc_port.h
+lib/libwolfssl.a
+lib/libwolfssl.so
+lib/libwolfssl.so.0
+lib/libwolfssl.so.0.0.0
+libdata/pkgconfig/wolfssl.pc