aboutsummaryrefslogtreecommitdiffstats
path: root/security/wolfssl
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2016-01-07 05:32:10 +0800
committerjohans <johans@FreeBSD.org>2016-01-07 05:32:10 +0800
commit65100d6f2866c61064b6d786474d6107d6b5de76 (patch)
treebaa4c0ac3fafe818146f7f405824c91ee725d44b /security/wolfssl
parentf9b5a1be3fcb130c365b68456204d6bb67f51695 (diff)
downloadfreebsd-ports-gnome-65100d6f2866c61064b6d786474d6107d6b5de76.tar.gz
freebsd-ports-gnome-65100d6f2866c61064b6d786474d6107d6b5de76.tar.zst
freebsd-ports-gnome-65100d6f2866c61064b6d786474d6107d6b5de76.zip
- Update WolfSSL to 3.8.0 (new MASTER_SITES, WWW entry and description)
- Includes important security fixes for CVE-2015-7744 and CVE-2015-6925 see https://www.wolfssl.com/wolfSSL/Blog/Entries/2015/9/17_Two_Vulnerabilities_Recently_Found%2C_An_Attack_on_RSA_using_CRT_and_DoS_Vulnerability_With_DTLS.html - Disables support for SSLv3 PR: 205936 Submitted by: Christoph Moench-Tegeder <cmt@burggraben.net> MFH: 2016Q1
Diffstat (limited to 'security/wolfssl')
-rw-r--r--security/wolfssl/Makefile6
-rw-r--r--security/wolfssl/distinfo4
-rw-r--r--security/wolfssl/pkg-descr37
-rw-r--r--security/wolfssl/pkg-plist15
4 files changed, 36 insertions, 26 deletions
diff --git a/security/wolfssl/Makefile b/security/wolfssl/Makefile
index b5e8ce09d102..76c16678a11c 100644
--- a/security/wolfssl/Makefile
+++ b/security/wolfssl/Makefile
@@ -1,16 +1,16 @@
# $FreeBSD$
PORTNAME= wolfssl
-PORTVERSION= 3.4.6
+PORTVERSION= 3.8.0
CATEGORIES= security devel
-MASTER_SITES= http://www.yassl.com/
+MASTER_SITES= http://www.wolfssl.com/
MAINTAINER= johans@FreeBSD.org
COMMENT= Embedded SSL C-Library
LICENSE= GPLv2
-USES= zip libtool
+USES= libtool zip
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-dependency-tracking \
--enable-shared --enable-static \
diff --git a/security/wolfssl/distinfo b/security/wolfssl/distinfo
index 5fc63942dd35..0f19c317bebc 100644
--- a/security/wolfssl/distinfo
+++ b/security/wolfssl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (wolfssl-3.4.6.zip) = 515e2b0f719bc9f9c66a20c22166b1395426cf230e3fce2ffb49c26aaf4c37f0
-SIZE (wolfssl-3.4.6.zip) = 2118363
+SHA256 (wolfssl-3.8.0.zip) = 36369304dd107b2ae1360c91f3d0eea491802dcacb2155562652bf5257117016
+SIZE (wolfssl-3.8.0.zip) = 2437850
diff --git a/security/wolfssl/pkg-descr b/security/wolfssl/pkg-descr
index b19e1f8e0d01..943f90c37c25 100644
--- a/security/wolfssl/pkg-descr
+++ b/security/wolfssl/pkg-descr
@@ -1,23 +1,22 @@
-Wolfssl is an embedded SSL Library for programmers building security
+WolfSSL is an embedded SSL Library for programmers building security
functionality into their applications and devices.
-Features
- SSL version 3 and TLS versions 1, 1.1 and 1.2 (client and server)
- Minimum size of 60-100kb, depending on build options
- Runtime memory usage between 5-50kb
- DTLS support (client and server)
- OpenSSL compatibility layer
- zlib compression support
- integration in MySQL, stunnel, Lighttpd availible.
- MD2, MD4, MD5, SHA-1, RIPEMD, HMAC, DES, 3DES, AES, ARC4, TWOFISH, BLOWFISH,
- RSA, DSS, DH, and PKCS#5 PBKDF2
- ia32 assembly for AES, 3DES, BLOWFISH, TWOFISH, ARC4, MD5, SHA, and RIPEMD
- SSE2 instructions for Large Integers
- Simple API
- Interchangeable crypto and certificate libraries
- PEM and DER certificate support
- Very fast
+Highlights
+- Up to TLS 1.2 and DTLS 1.2
+- Full client and server support
+- Progressive list of supported ciphers
+- Key and Certificate generation
+- OCSP, CRL support
-LICENSE: GPL2 with FOSS extension
+Lightweight
+- Small Size: 20-100kB
+- Runtime Memory: 1-36kB
+- 20x smaller than OpenSSL
-WWW: http://www.yassl.com/
+Portable
+- Abstraction Layers (OS, Custom I/O, Standard C library, and more)
+- Simple API
+- OpenSSL Compatibility Layer
+- Long list of supported platforms
+
+WWW: http://www.wolfssl.com/
diff --git a/security/wolfssl/pkg-plist b/security/wolfssl/pkg-plist
index 00e1da96d078..22794ff63298 100644
--- a/security/wolfssl/pkg-plist
+++ b/security/wolfssl/pkg-plist
@@ -57,7 +57,10 @@ include/cyassl/openssl/des.h
include/cyassl/openssl/dh.h
include/cyassl/openssl/dsa.h
include/cyassl/openssl/ec.h
+include/cyassl/openssl/ec25519.h
+include/cyassl/openssl/ecdh.h
include/cyassl/openssl/ecdsa.h
+include/cyassl/openssl/ed25519.h
include/cyassl/openssl/engine.h
include/cyassl/openssl/err.h
include/cyassl/openssl/evp.h
@@ -100,7 +103,10 @@ include/wolfssl/openssl/des.h
include/wolfssl/openssl/dh.h
include/wolfssl/openssl/dsa.h
include/wolfssl/openssl/ec.h
+include/wolfssl/openssl/ec25519.h
+include/wolfssl/openssl/ecdh.h
include/wolfssl/openssl/ecdsa.h
+include/wolfssl/openssl/ed25519.h
include/wolfssl/openssl/engine.h
include/wolfssl/openssl/err.h
include/wolfssl/openssl/evp.h
@@ -151,8 +157,10 @@ include/wolfssl/wolfcrypt/error-crypt.h
include/wolfssl/wolfcrypt/fe_operations.h
include/wolfssl/wolfcrypt/fips_test.h
include/wolfssl/wolfcrypt/ge_operations.h
+include/wolfssl/wolfcrypt/hash.h
include/wolfssl/wolfcrypt/hc128.h
include/wolfssl/wolfcrypt/hmac.h
+include/wolfssl/wolfcrypt/idea.h
include/wolfssl/wolfcrypt/integer.h
include/wolfssl/wolfcrypt/logging.h
include/wolfssl/wolfcrypt/md2.h
@@ -173,12 +181,15 @@ include/wolfssl/wolfcrypt/settings.h
include/wolfssl/wolfcrypt/sha.h
include/wolfssl/wolfcrypt/sha256.h
include/wolfssl/wolfcrypt/sha512.h
+include/wolfssl/wolfcrypt/signature.h
+include/wolfssl/wolfcrypt/srp.h
include/wolfssl/wolfcrypt/tfm.h
include/wolfssl/wolfcrypt/types.h
include/wolfssl/wolfcrypt/visibility.h
+include/wolfssl/wolfcrypt/wc_encrypt.h
include/wolfssl/wolfcrypt/wc_port.h
lib/libwolfssl.a
lib/libwolfssl.so
-lib/libwolfssl.so.0
-lib/libwolfssl.so.0.0.1
+lib/libwolfssl.so.3
+lib/libwolfssl.so.3.1.0
libdata/pkgconfig/wolfssl.pc