aboutsummaryrefslogtreecommitdiffstats
path: root/security/xinetd
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2004-02-22 11:26:14 +0800
committervanilla <vanilla@FreeBSD.org>2004-02-22 11:26:14 +0800
commit2d096dd9c130c4de4cbf5b5e744bfb7a3681f230 (patch)
tree7d717081fbb1b9593bf0b92726da46201de3f53b /security/xinetd
parentc090e231902277e70f2a0152e553c221b9079874 (diff)
downloadfreebsd-ports-gnome-2d096dd9c130c4de4cbf5b5e744bfb7a3681f230.tar.gz
freebsd-ports-gnome-2d096dd9c130c4de4cbf5b5e744bfb7a3681f230.tar.zst
freebsd-ports-gnome-2d096dd9c130c4de4cbf5b5e744bfb7a3681f230.zip
- Upgrade to 2.3.13.
- use USE_RC_SUBR. - remove BROKEN.
Diffstat (limited to 'security/xinetd')
-rw-r--r--security/xinetd/Makefile32
-rw-r--r--security/xinetd/distinfo3
-rw-r--r--security/xinetd/files.5/patch-xinetd::reconfig.c11
-rw-r--r--security/xinetd/files.5/patch-xinetd::service.c11
-rw-r--r--security/xinetd/files/patch-xinetd::Makefile.in11
-rw-r--r--security/xinetd/files/xinetd.sh22
-rw-r--r--security/xinetd/pkg-descr34
7 files changed, 16 insertions, 108 deletions
diff --git a/security/xinetd/Makefile b/security/xinetd/Makefile
index a951c74a3b91..51f9407323b1 100644
--- a/security/xinetd/Makefile
+++ b/security/xinetd/Makefile
@@ -6,43 +6,39 @@
#
PORTNAME= xinetd
-PORTVERSION= 2.3.12
-PORTREVISION= 1
+PORTVERSION= 2.3.13
+PORTREVISION= 0
CATEGORIES= security ipv6
MASTER_SITES= http://www.xinetd.org/
MAINTAINER= vanilla@FreeBSD.org
COMMENT= Replacement for inetd with better control and logging
-BROKEN= "Checksum mismatch"
-
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_RC_SUBR= yes
ALL_TARGET= build
CONFIGURE_ARGS+= --with-loadavg --with-libwrap --with-ipv6
+STARTUP_FILE= ${PREFIX}/etc/rc.d/xinetd.sh
+RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
MAN5= xinetd.conf.5
MAN8= xconv.8 xinetd.8 xinetd.log.8
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500029
-EXTRA_PATCHES!= ${ECHO_CMD} ${PKGDIR}/files.5/patch-*
-.endif
-
post-patch:
${FIND} ${WRKSRC}/libs/src -name Makefile.in | ${XARGS} \
${REINPLACE_CMD} -e 's!\@INSTALL\@!/bin/cp!; s!-m 640!!'
- @${SED} 's|%%PREFIX%%|${PREFIX}|g' < ${WRKSRC}/xinetd/xconfig.h \
- > ${WRKSRC}/xinetd/xconfig.h.new
- @${MV} ${WRKSRC}/xinetd/xconfig.h.new ${WRKSRC}/xinetd/xconfig.h
+ @${REINPLACE_CMD} 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/xinetd/xconfig.h
+
+pre-install:
+ -@[ -f ${STARTUP_FILE} ] && \
+ (${ECHO} "Remove old ${STARTUP_FILE} before install." && exit 1)
post-install:
- @if [ ! -f ${PREFIX}/etc/rc.d/xinetd.sh ]; then \
- ${ECHO_CMD} "Install ${PREFIX}/etc/rc.d/xinetd.sh startup file."; \
- ${INSTALL_SCRIPT} -m 751 ${FILESDIR}/xinetd.sh ${PREFIX}/etc/rc.d/xinetd.sh; \
- fi
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/xinetd.sh.tmpl > ${STARTUP_FILE}
+ @${CHMOD} 755 ${STARTUP_FILE}
@${STRIP_CMD} ${PREFIX}/sbin/xinetd
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/xinetd/distinfo b/security/xinetd/distinfo
index 169dfd3b08a9..c0330538147b 100644
--- a/security/xinetd/distinfo
+++ b/security/xinetd/distinfo
@@ -1 +1,2 @@
-MD5 (xinetd-2.3.12.tar.gz) = 16154191731b6449d934eecacef647dd
+MD5 (xinetd-2.3.13.tar.gz) = 4295b5fe12350f09b5892b363348ac8b
+SIZE (xinetd-2.3.13.tar.gz) = 297548
diff --git a/security/xinetd/files.5/patch-xinetd::reconfig.c b/security/xinetd/files.5/patch-xinetd::reconfig.c
deleted file mode 100644
index 7d4c0d5853f3..000000000000
--- a/security/xinetd/files.5/patch-xinetd::reconfig.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- xinetd/reconfig.c.orig Wed Oct 16 09:22:22 2002
-+++ xinetd/reconfig.c Wed Oct 16 09:24:09 2002
-@@ -23,6 +23,8 @@
- #endif
- #include <rpc/types.h>
- #include <rpc/xdr.h>
-+ #include <rpc/auth.h>
-+ #include <rpc/clnt.h>
- #include <rpc/pmap_clnt.h>
- #endif
- #include <rpc/rpc.h>
diff --git a/security/xinetd/files.5/patch-xinetd::service.c b/security/xinetd/files.5/patch-xinetd::service.c
deleted file mode 100644
index fcc82291fe61..000000000000
--- a/security/xinetd/files.5/patch-xinetd::service.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- xinetd/service.c.orig Wed Oct 16 09:25:06 2002
-+++ xinetd/service.c Wed Oct 16 09:25:26 2002
-@@ -31,6 +31,8 @@
- #endif
- #include <rpc/types.h>
- #include <rpc/xdr.h>
-+ #include <rpc/auth.h>
-+ #include <rpc/clnt.h>
- #include <rpc/pmap_clnt.h>
- #endif
- #include <rpc/rpc.h>
diff --git a/security/xinetd/files/patch-xinetd::Makefile.in b/security/xinetd/files/patch-xinetd::Makefile.in
deleted file mode 100644
index 1020dea74700..000000000000
--- a/security/xinetd/files/patch-xinetd::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- xinetd/Makefile.in.orig Sun Jun 8 00:47:24 2003
-+++ xinetd/Makefile.in Sat Sep 27 21:24:00 2003
-@@ -40,7 +40,7 @@
-
- INSTALL_CMD = @INSTALL@
-
--LIBS = -lsio -lmisc -lxlog -lstr -lpset -lportable @LIBS@
-+LIBS = -lsio -lmisc -lxlog -lpset -lportable -lstr @LIBS@
-
- INCLUDEDIR = -I../libs/include
- LIBDIR = -L../libs/lib
diff --git a/security/xinetd/files/xinetd.sh b/security/xinetd/files/xinetd.sh
deleted file mode 100644
index d40f74b432c8..000000000000
--- a/security/xinetd/files/xinetd.sh
+++ /dev/null
@@ -1,22 +0,0 @@
-#!/bin/sh
-
-if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
- echo "$0: Cannot determine the PREFIX" >&2
- exit 1
-fi
-
-case "$1" in
-start)
- [ -x ${PREFIX}/sbin/xinetd ] && \
- ${PREFIX}/sbin/xinetd -pidfile /var/run/xinetd.pid && \
- echo -n ' xinetd'
- ;;
-stop)
- killall xinetd && echo -n ' xinetd'
- ;;
-*)
- echo "Usage: `basename $0` {start|stop}" >&2
- ;;
-esac
-
-exit 0
diff --git a/security/xinetd/pkg-descr b/security/xinetd/pkg-descr
index 1caf7b8da626..80126e4f12a7 100644
--- a/security/xinetd/pkg-descr
+++ b/security/xinetd/pkg-descr
@@ -9,38 +9,4 @@ Its configuration file has a different format than inetd's one
and it understands different signals. However the signal-to-action
assignment can be changed.
-It is a lot better than inetd. Here are the reasons:
-
-1) It can do access control on all services based on:
- a. address of remote host
- b. time of access
-
-2) Access control works on all services, whether multi-threaded or
- single-threaded and for both the TCP and UDP protocols. All UDP
- packets can be checked as well as all TCP connections.
-
-3) It provides hard reconfiguration:
- a. kills servers for services that are no longer in the configuration file
- b. kills servers that no longer meet the access control criteria
-
-4) It can prevent denial-of-access attacks by
- a. placing limits on the number of servers for each service (avoids
- process table overflows)
- b. placing an upper bound on the number of processes it will fork
- c. placing limits on the size of log files it creates
-
-5) Extensive logging abilities:
- a. for every server started it can log:
- i) the time when the server was started
- ii) the remote host address
- iii) who was the remote user (if the other end runs a RFC-931/RFC-1413
- server)
- iv) how long the server was running
- (i, ii and iii can be logged for failed attempts too).
- b. for some services, if the access control fails, it can
- log information about the attempted access (for example,
- it can log the user name and command for the rsh service)
-
-6) No limit on number of server arguments
-
WWW: http://www.xinetd.org/