aboutsummaryrefslogtreecommitdiffstats
path: root/security/xinetd
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2002-10-16 09:39:17 +0800
committervanilla <vanilla@FreeBSD.org>2002-10-16 09:39:17 +0800
commite0a31332d419a619b9b584aa3f600f5a54f65a03 (patch)
tree1ed7e395a4c6f99eecdc580bdf1c443252e29840 /security/xinetd
parent7e23580fc4f4d0d07bdaf5f1bc9d40233b06ab7e (diff)
downloadfreebsd-ports-gnome-e0a31332d419a619b9b584aa3f600f5a54f65a03.tar.gz
freebsd-ports-gnome-e0a31332d419a619b9b584aa3f600f5a54f65a03.tar.zst
freebsd-ports-gnome-e0a31332d419a619b9b584aa3f600f5a54f65a03.zip
Upgrade to 2.3.9, and fix broken on -current.
PR: ports/44040 Submitted by: Jens Rehsack <rehsack@liwing.de>
Diffstat (limited to 'security/xinetd')
-rw-r--r--security/xinetd/Makefile10
-rw-r--r--security/xinetd/distinfo2
-rw-r--r--security/xinetd/files.5/patch-xinetd::reconfig.c11
-rw-r--r--security/xinetd/files.5/patch-xinetd::service.c11
4 files changed, 31 insertions, 3 deletions
diff --git a/security/xinetd/Makefile b/security/xinetd/Makefile
index af9993265fd0..a7d87a8372d0 100644
--- a/security/xinetd/Makefile
+++ b/security/xinetd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xinetd
-PORTVERSION= 2.3.8
+PORTVERSION= 2.3.9
PORTREVISION= 0
CATEGORIES= security
MASTER_SITES= http://www.xinetd.org/
@@ -21,6 +21,12 @@ CONFIGURE_ARGS+= --with-loadavg --with-libwrap
MAN5= xinetd.conf.5
MAN8= xconv.8 xinetd.8 xinetd.log.8
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500029
+EXTRA_PATCHES!= ${ECHO_CMD} ${PKGDIR}/files.5/patch-*
+.endif
+
post-patch:
${FIND} ${WRKSRC}/libs/src -name Makefile.in | ${XARGS} \
${PERL} -pi -e 's!\@INSTALL\@!/bin/cp!; s!-m 640!!'
@@ -35,4 +41,4 @@ post-install:
fi
@${STRIP_CMD} ${PREFIX}/sbin/xinetd
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/xinetd/distinfo b/security/xinetd/distinfo
index d0c72ce7d582..7b689d9f0413 100644
--- a/security/xinetd/distinfo
+++ b/security/xinetd/distinfo
@@ -1 +1 @@
-MD5 (xinetd-2.3.8.tar.gz) = 70b5270bb717014d38e024c154301547
+MD5 (xinetd-2.3.9.tar.gz) = d879f6e19468f92abecf2cec7e21e246
diff --git a/security/xinetd/files.5/patch-xinetd::reconfig.c b/security/xinetd/files.5/patch-xinetd::reconfig.c
new file mode 100644
index 000000000000..7d4c0d5853f3
--- /dev/null
+++ b/security/xinetd/files.5/patch-xinetd::reconfig.c
@@ -0,0 +1,11 @@
+--- xinetd/reconfig.c.orig Wed Oct 16 09:22:22 2002
++++ xinetd/reconfig.c Wed Oct 16 09:24:09 2002
+@@ -23,6 +23,8 @@
+ #endif
+ #include <rpc/types.h>
+ #include <rpc/xdr.h>
++ #include <rpc/auth.h>
++ #include <rpc/clnt.h>
+ #include <rpc/pmap_clnt.h>
+ #endif
+ #include <rpc/rpc.h>
diff --git a/security/xinetd/files.5/patch-xinetd::service.c b/security/xinetd/files.5/patch-xinetd::service.c
new file mode 100644
index 000000000000..fcc82291fe61
--- /dev/null
+++ b/security/xinetd/files.5/patch-xinetd::service.c
@@ -0,0 +1,11 @@
+--- xinetd/service.c.orig Wed Oct 16 09:25:06 2002
++++ xinetd/service.c Wed Oct 16 09:25:26 2002
+@@ -31,6 +31,8 @@
+ #endif
+ #include <rpc/types.h>
+ #include <rpc/xdr.h>
++ #include <rpc/auth.h>
++ #include <rpc/clnt.h>
+ #include <rpc/pmap_clnt.h>
+ #endif
+ #include <rpc/rpc.h>