aboutsummaryrefslogtreecommitdiffstats
path: root/security/xmlsec1
diff options
context:
space:
mode:
authorbrnrd <brnrd@FreeBSD.org>2016-10-08 19:21:02 +0800
committerbrnrd <brnrd@FreeBSD.org>2016-10-08 19:21:02 +0800
commitdc0f54b3169a1b3449664d93a86fd88da30716a2 (patch)
treeab1b67fa2992f2237056b3a954c978f9b89b7b50 /security/xmlsec1
parent34eb346415aacc209489f0afaa700d44d79de1dc (diff)
downloadfreebsd-ports-gnome-dc0f54b3169a1b3449664d93a86fd88da30716a2.tar.gz
freebsd-ports-gnome-dc0f54b3169a1b3449664d93a86fd88da30716a2.tar.zst
freebsd-ports-gnome-dc0f54b3169a1b3449664d93a86fd88da30716a2.zip
security/xmlsec1: Fix build with LibreSSL
- Fix build with LibreSSL - USE_OPENSSL -> USES= ssl PR: 213301 Submitted by: grembo Reported by: grembo Approved by: ssl blanket
Diffstat (limited to 'security/xmlsec1')
-rw-r--r--security/xmlsec1/Makefile3
-rw-r--r--security/xmlsec1/files/patch-configure32
2 files changed, 33 insertions, 2 deletions
diff --git a/security/xmlsec1/Makefile b/security/xmlsec1/Makefile
index 028e72ba5a11..4065461e89ec 100644
--- a/security/xmlsec1/Makefile
+++ b/security/xmlsec1/Makefile
@@ -25,8 +25,7 @@ NSS_LIB_DEPENDS= libnss3.so:security/nss
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= libtool pathfix pkgconfig
-USE_OPENSSL= yes
+USES= libtool pathfix pkgconfig ssl
USE_GNOME= libxml2 libxslt
USE_LDCONFIG= yes
diff --git a/security/xmlsec1/files/patch-configure b/security/xmlsec1/files/patch-configure
new file mode 100644
index 000000000000..510d4c602683
--- /dev/null
+++ b/security/xmlsec1/files/patch-configure
@@ -0,0 +1,32 @@
+https://github.com/lsh123/xmlsec/pull/45
+
+ - LibreSSL:
+ * defines OPENSSL_VERSION_NUMBER as 0x20000000L
+ * deFines LIBRESS_VERSION_NUMBER in opensslv.h
+ * was forked from 1.0.1f / 0x1000107fL
+
+PR: https://bugs.freebsd.org/213301
+Reported by: Michael Gmelin <grembo@freebsd.org>
+
+--- configure.ac.orig 2016-04-20 16:26:22 UTC
++++ configure.ac
+@@ -495,7 +495,7 @@ if test "z$OPENSSL_FOUND" = "zyes" -a "z
+ if test "z$OPENSSL_VERSION" = "z" ; then
+ AC_EGREP_CPP(yes,[
+ #include <openssl/opensslv.h>
+- #if OPENSSL_VERSION_NUMBER >= 0x10100000L
++ #if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
+ yes
+ #endif
+ ],[
+--- configure.orig 2016-10-08 10:49:21 UTC
++++ configure
+@@ -14258,7 +14258,7 @@ $as_echo_n "checking for openssl librari
+ /* end confdefs.h. */
+
+ #include <openssl/opensslv.h>
+- #if OPENSSL_VERSION_NUMBER >= 0x10100000L
++ #if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
+ yes
+ #endif
+