aboutsummaryrefslogtreecommitdiffstats
path: root/security/yersinia
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-11-15 01:07:08 +0800
committersem <sem@FreeBSD.org>2005-11-15 01:07:08 +0800
commit35435d1f9d93e76e05b29c4fb94f5a9eb6b97f0b (patch)
treee8a63ec5e69747bc60a66ae6393226de6a3cf329 /security/yersinia
parentb56264adbb1e79205d6439c49991712e0aec4a6d (diff)
downloadfreebsd-ports-gnome-35435d1f9d93e76e05b29c4fb94f5a9eb6b97f0b.tar.gz
freebsd-ports-gnome-35435d1f9d93e76e05b29c4fb94f5a9eb6b97f0b.tar.zst
freebsd-ports-gnome-35435d1f9d93e76e05b29c4fb94f5a9eb6b97f0b.zip
libnet update:
- move 1.0 obsoleted version to net/libnet10 net/libnet is latest Stable Version net/libnet is latest Beta Version - Fix all depended ports with a new DEPENDS scheme - While I'm here fix security/yersinia build on 4.x (getopt_long and ncurses issues) PR: ports/85519 (based on) Submitted by: Stas Yakovlev <stas.yakovlev_at_gmail.com>
Diffstat (limited to 'security/yersinia')
-rw-r--r--security/yersinia/Makefile6
-rw-r--r--security/yersinia/files/patch-src-ncurses-gui.c15
2 files changed, 19 insertions, 2 deletions
diff --git a/security/yersinia/Makefile b/security/yersinia/Makefile
index 0414c9b833b5..e41b627832c9 100644
--- a/security/yersinia/Makefile
+++ b/security/yersinia/Makefile
@@ -7,6 +7,7 @@
PORTNAME= yersinia
PORTVERSION= 0.5.4
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,10 +15,11 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= se@FreeBSD.org
COMMENT= Layer 2 vulnerability scanner (switches, spanning tree, 802.1q ...)
+USE_GETOPT_LONG= yes
+
.include <bsd.port.pre.mk>
-# Dependency on file that is not also installed by libnet (1.0.2) port!
-BUILD_DEPENDS= ${LOCALBASE}/share/examples/libnet/ip_raw.c:${PORTSDIR}/net/libnet-devel
+BUILD_DEPENDS= libnet*>=1.1.2,1:${PORTSDIR}/net/libnet
.if ${OSVERSION} < 500000
BUILD_DEPENDS+= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
diff --git a/security/yersinia/files/patch-src-ncurses-gui.c b/security/yersinia/files/patch-src-ncurses-gui.c
new file mode 100644
index 000000000000..0fc407a9964d
--- /dev/null
+++ b/security/yersinia/files/patch-src-ncurses-gui.c
@@ -0,0 +1,15 @@
+--- src/ncurses-gui.c.orig Mon Nov 14 17:49:42 2005
++++ src/ncurses-gui.c Mon Nov 14 18:01:48 2005
+@@ -87,6 +87,12 @@
+ #include "ncurses-gui.h"
+
+
++#ifdef __FreeBSD__
++#include <sys/param.h>
++#if __FreeBSD_version < 500037
++#define resize_term resizeterm
++#endif
++#endif
+
+ /*
+ * Initialization routines for the GUI