aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2017-04-08 01:23:23 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2017-04-09 21:34:11 +0800
commit9f7fc44db169442d34f5e578aefe4c79201c1f55 (patch)
treeef35837c692ee4202ba49b6dfbbbea7acb621a53 /security
parent844a78ad9b049ee8c60cf1b4cae1c38181135392 (diff)
downloadfreebsd-ports-gnome-9f7fc44db169442d34f5e578aefe4c79201c1f55.tar.gz
freebsd-ports-gnome-9f7fc44db169442d34f5e578aefe4c79201c1f55.tar.zst
freebsd-ports-gnome-9f7fc44db169442d34f5e578aefe4c79201c1f55.zip
security/sslsplit: fix build with libressl-devel
While here, add LICENSE, USES=ssl, strip the binary PR: 216846 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl>
Diffstat (limited to 'security')
-rw-r--r--security/sslsplit/Makefile10
-rw-r--r--security/sslsplit/files/patch-ssl.c24
2 files changed, 31 insertions, 3 deletions
diff --git a/security/sslsplit/Makefile b/security/sslsplit/Makefile
index 1d60defd65d9..2e5a58be4245 100644
--- a/security/sslsplit/Makefile
+++ b/security/sslsplit/Makefile
@@ -1,20 +1,24 @@
-# Created by: Steve Wills <swills@freebsd.org>
# $FreeBSD$
PORTNAME= sslsplit
PORTVERSION= 0.5.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security
MASTER_SITES= http://mirror.roe.ch/rel/sslsplit/
MAINTAINER= swills@FreeBSD.org
COMMENT= Transparent and scalable SSL/TLS interception
+LICENSE= BSD2CLAUSE
+
LIB_DEPENDS= libevent.so:devel/libevent
-USES= gmake pkgconfig tar:bzip2 uidfix
+USES= gmake pkgconfig tar:bzip2 uidfix ssl
MAKEFILE= GNUmakefile
MAKE_ENV= DESTDIR=${STAGEDIR} MANDIR=man INSTALLUID=${UID} INSTALLGID=${GID}
PLIST_FILES= bin/sslsplit man/man1/sslsplit.1.gz
+post-stage:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/sslsplit
+
.include <bsd.port.mk>
diff --git a/security/sslsplit/files/patch-ssl.c b/security/sslsplit/files/patch-ssl.c
new file mode 100644
index 000000000000..31635e4aadc9
--- /dev/null
+++ b/security/sslsplit/files/patch-ssl.c
@@ -0,0 +1,24 @@
+--- ssl.c.orig 2016-03-27 13:46:35 UTC
++++ ssl.c
+@@ -477,15 +477,14 @@ ssl_ssl_state_to_str(SSL *ssl)
+ int rv;
+
+ rv = asprintf(&str, "%08x = %s%s%s%04x = %s (%s) [%s]",
+- ssl->state,
+- (ssl->state & SSL_ST_CONNECT) ? "SSL_ST_CONNECT|" : "",
+- (ssl->state & SSL_ST_ACCEPT) ? "SSL_ST_ACCEPT|" : "",
+- (ssl->state & SSL_ST_BEFORE) ? "SSL_ST_BEFORE|" : "",
+- ssl->state & SSL_ST_MASK,
++ SSL_get_state(ssl),
++ (SSL_get_state(ssl) & SSL_ST_CONNECT) ? "SSL_ST_CONNECT|" : "",
++ (SSL_get_state(ssl) & SSL_ST_ACCEPT) ? "SSL_ST_ACCEPT|" : "",
++ (SSL_get_state(ssl) & SSL_ST_BEFORE) ? "SSL_ST_BEFORE|" : "",
++ SSL_get_state(ssl) & SSL_ST_MASK,
+ SSL_state_string(ssl),
+ SSL_state_string_long(ssl),
+- (ssl->type == SSL_ST_CONNECT) ? "connect socket"
+- : "accept socket");
++ "");
+
+ return (rv < 0) ? NULL : str;
+ }