aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-07-08 21:08:20 +0800
committerpawel <pawel@FreeBSD.org>2014-07-08 21:08:20 +0800
commit0072474f151da60b08938a6b35366fe0a249f1d4 (patch)
treeb438ef33f2a7ec39b40bd4bbe434c2aa86a47c99 /security
parent2a47f84751456538086ad99a7ef2a683271e5b4d (diff)
downloadfreebsd-ports-gnome-0072474f151da60b08938a6b35366fe0a249f1d4.tar.gz
freebsd-ports-gnome-0072474f151da60b08938a6b35366fe0a249f1d4.tar.zst
freebsd-ports-gnome-0072474f151da60b08938a6b35366fe0a249f1d4.zip
- Add staging support
- Port uses GNU configure - Switch to pkg-plist instead of PLIST_FILES - Fix typos in pkg-descr - Convert Makefile to normal tab style
Diffstat (limited to 'security')
-rw-r--r--security/fswatch/Makefile37
-rw-r--r--security/fswatch/pkg-descr4
-rw-r--r--security/fswatch/pkg-plist11
3 files changed, 28 insertions, 24 deletions
diff --git a/security/fswatch/Makefile b/security/fswatch/Makefile
index 8f50d1249f30..0a902db306cf 100644
--- a/security/fswatch/Makefile
+++ b/security/fswatch/Makefile
@@ -1,32 +1,25 @@
# Created by: dominik karczmarski <dominik@karczmarski.com>
# $FreeBSD$
-PORTNAME= fswatch
-DISTVERSION= 0.02beta5
-CATEGORIES= security sysutils
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-0.02beta5
+PORTNAME= fswatch
+DISTVERSION= 0.02beta5
+CATEGORIES= security sysutils
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-0.02beta5
-MAINTAINER= ports@FreeBSD.org
-COMMENT= File system checksum checker
+MAINTAINER= ports@FreeBSD.org
+COMMENT= File system checksum checker
-HAS_CONFIGURE= yes
-SUB_FILES= pkg-message
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --enable-regex \
+ --enable-stflags
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/.b/beta/}/
+SUB_FILES= pkg-message
-CONFIGURE_ARGS+= --prefix=${PREFIX} \
- --enable-regex \
- --enable-stflags
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/.b/beta/}/
-PLIST_FILES= bin/fswbuild bin/fswcmp bin/fswshow \
- bin/fswconf etc/fswatch.conf.sample
-
-MAN1= fswbuild.1 fswcmp.1 fswshow.1 fswconf.1
-MAN5= fswatch.conf.5
-MAN7= fswatch.7
-
-NO_STAGE= yes
-post-install:
- @${CAT} ${PKGMESSAGE}
+post-patch:
+ @${REINPLACE_CMD} '/INSTALL/ s|prefix)|DESTDIR)$$(&|' \
+ ${WRKSRC}/examples/Makefile.in
.include <bsd.port.mk>
diff --git a/security/fswatch/pkg-descr b/security/fswatch/pkg-descr
index fd6fd1e9315f..e2a14a96a45e 100644
--- a/security/fswatch/pkg-descr
+++ b/security/fswatch/pkg-descr
@@ -2,10 +2,10 @@ fswatch:
- is a utility to guard changes in a file system.
- is composed of three simple programs: fswbuild, fswcmp, fswshow. fswbuild
- builds a file system information database. fswcmp compairs two database files
+ builds a file system information database. fswcmp compares two database files
and returns what changes a in file system have been introduced. fswshow shows
contents of database file. a file information database is platform
- independend.
+ independent.
- can collect the following information about files (and directories): inode,
links, uid, gid, mode, size, flags, ctime, checksum (sha1) ; and can show
diff --git a/security/fswatch/pkg-plist b/security/fswatch/pkg-plist
new file mode 100644
index 000000000000..765844316f7a
--- /dev/null
+++ b/security/fswatch/pkg-plist
@@ -0,0 +1,11 @@
+bin/fswbuild
+bin/fswcmp
+bin/fswconf
+bin/fswshow
+etc/fswatch.conf.sample
+man/man1/fswbuild.1.gz
+man/man1/fswcmp.1.gz
+man/man1/fswconf.1.gz
+man/man1/fswshow.1.gz
+man/man5/fswatch.conf.5.gz
+man/man7/fswatch.7.gz