aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-04-08 23:05:48 +0800
committerbapt <bapt@FreeBSD.org>2015-04-08 23:05:48 +0800
commit11557d3b1ca381824ecc50f020623ed56d4ce36a (patch)
tree81627af7b0f0c701d807cb8a4046a4740517b9f9 /security
parent1ed12c409b16770d2cb109c7a67bf65ef1a3f27b (diff)
downloadfreebsd-ports-gnome-11557d3b1ca381824ecc50f020623ed56d4ce36a.tar.gz
freebsd-ports-gnome-11557d3b1ca381824ecc50f020623ed56d4ce36a.tar.zst
freebsd-ports-gnome-11557d3b1ca381824ecc50f020623ed56d4ce36a.zip
Add a new USES=waf to handle the waf building system, allowing to factorise code
Plug waf into MAKE_CMD and CONFIGURE_CMD so the regular defined targets can be reused Always define _MAKE_JOBS so that when bsd.port.mk will stop overwritting _MAKE_JOBS when parallel jobs are disabled we can enforce -j1 (which is needed to really disable parallelisation with waf WAF_CMD has been created to allow one to override the location of the waf script relatively to WRKSRC CONFIGURE_TARGET is by default defined to "configure" ALL_TARGET is by default defined to "build" INSTALL_TARGET is by default defined to "install" USES=waf is by default stagedir safe
Diffstat (limited to 'security')
-rw-r--r--security/hotssh/Makefile11
1 files changed, 1 insertions, 10 deletions
diff --git a/security/hotssh/Makefile b/security/hotssh/Makefile
index 127ca72ba198..5aafc4300a22 100644
--- a/security/hotssh/Makefile
+++ b/security/hotssh/Makefile
@@ -25,7 +25,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:${PORTSDIR}/devel/py-dbus \
${PYTHON_SITELIBDIR}/gtk-2.0/vtemodule.so:${PORTSDIR}/x11-toolkits/py-vte
USE_GNOME= pygtk2 gnomedocutils libxslt glib20
-USES= gettext python tar:bzip2
+USES= gettext python tar:bzip2 waf
INSTALLS_ICONS= yes
B64DECODE?= /usr/bin/b64decode
@@ -37,13 +37,4 @@ post-extract:
@cd ${WRKSRC} && ${B64DECODE} -o waf.diff ${FILESDIR}/waf.diff && ${BSPATCH} waf.beforepatch waf waf.diff && ${CHMOD} 755 waf
@${GREP} -Rl '%%LOCALBASE%%' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g"
-do-configure:
- @cd ${WRKSRC} && ./waf configure --prefix=${PREFIX}
-
-do-build:
- @cd ${WRKSRC} && ./waf
-
-do-install:
- @cd ${WRKSRC} && ./waf install --destdir=${STAGEDIR}
-
.include <bsd.port.mk>