aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorfoxfair <foxfair@FreeBSD.org>2003-06-30 15:41:04 +0800
committerfoxfair <foxfair@FreeBSD.org>2003-06-30 15:41:04 +0800
commit13204de5be8fd0863f28a600f65402b552c18254 (patch)
tree9ea491ade23cbd6c3eb9cc5c90c53d28ab0008a4 /security
parentd63d02fd8d04a629a6e71d6d3f063187423485bf (diff)
downloadfreebsd-ports-gnome-13204de5be8fd0863f28a600f65402b552c18254.tar.gz
freebsd-ports-gnome-13204de5be8fd0863f28a600f65402b552c18254.tar.zst
freebsd-ports-gnome-13204de5be8fd0863f28a600f65402b552c18254.zip
Reviewed by:
Approved by: Obtained from: MFC after: Import hydra-2.2, base on PR/43942. This port is provided as a standalone program to avoid installing a full Nessus scanner system. Submitted by: Laurent LEVIER <llevier@argosnet.com>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/hydra/Makefile28
-rw-r--r--security/hydra/distinfo1
-rw-r--r--security/hydra/pkg-descr8
-rw-r--r--security/hydra/pkg-plist1
5 files changed, 39 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index dca3c25a4731..eafee1eda5a4 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -97,6 +97,7 @@
SUBDIR += heimdal
SUBDIR += hlfl
SUBDIR += hping
+ SUBDIR += hydra
SUBDIR += ident2
SUBDIR += identify
SUBDIR += ifd-devkit
diff --git a/security/hydra/Makefile b/security/hydra/Makefile
new file mode 100644
index 000000000000..6816b3e9a86c
--- /dev/null
+++ b/security/hydra/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: hydra
+# Date created: Tue Oct 08, 2002
+# Whom: Laurent LEVIER (llevier@argosnet.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= hydra
+PORTVERSION= 2.2
+CATEGORIES= security
+MASTER_SITES= http://www.thc.org/releases/ \
+ ${MASTER_SITE_PACKETSTORM}
+MASTER_SITE_SUBDIR= groups/thc
+
+MAINTAINER= llevier@argosnet.com
+COMMENT= Bruce Force Attack Utility working on multiple network services
+
+.include <bsd.port.pre.mk>
+
+GNU_CONFIGURE= yes
+
+.if !target(post-install) && (${PORTNAME} == "hydra")
+post-install:
+ @strip ${PREFIX}/bin/hydra
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/hydra/distinfo b/security/hydra/distinfo
new file mode 100644
index 000000000000..1904416892c4
--- /dev/null
+++ b/security/hydra/distinfo
@@ -0,0 +1 @@
+MD5 (hydra-2.2.tar.gz) = 05042c1add6155ea48233df05a1e37ae
diff --git a/security/hydra/pkg-descr b/security/hydra/pkg-descr
new file mode 100644
index 000000000000..58ca6f4c64a8
--- /dev/null
+++ b/security/hydra/pkg-descr
@@ -0,0 +1,8 @@
+Hydra is a parallized login hacker utility. Hydra can brute force attack on
+FTP, POP3, IMAP, Telnet, HTTP Auth, NNTP, VNC, ICQ, Socks5, PCNFS and more
+services within SSL support. This port is provided as a standalone program to
+avoid installing a full Nessus scanner system.
+
+NEWS: Hydra is now included in Nessus!
+
+WWW: http://www.thc.org/releases.php
diff --git a/security/hydra/pkg-plist b/security/hydra/pkg-plist
new file mode 100644
index 000000000000..b0dd2acbced9
--- /dev/null
+++ b/security/hydra/pkg-plist
@@ -0,0 +1 @@
+bin/hydra