aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-06-03 09:07:28 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-06-03 09:07:28 +0800
commit1edde759e4ed396bfb36409d2670a2b0bbc1679d (patch)
tree93047e86e6aca1f045a714553ed3bc4597815fdf /security
parent635906ac66d8dd186a00a0af3687f961d92309c0 (diff)
downloadfreebsd-ports-gnome-1edde759e4ed396bfb36409d2670a2b0bbc1679d.tar.gz
freebsd-ports-gnome-1edde759e4ed396bfb36409d2670a2b0bbc1679d.tar.zst
freebsd-ports-gnome-1edde759e4ed396bfb36409d2670a2b0bbc1679d.zip
- Support staging
- Use new LIB_DEPENDS syntax - Fix docs installation
Diffstat (limited to 'security')
-rw-r--r--security/gringotts/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/security/gringotts/Makefile b/security/gringotts/Makefile
index 4e499931f6c0..ffcee6cf59a0 100644
--- a/security/gringotts/Makefile
+++ b/security/gringotts/Makefile
@@ -10,8 +10,8 @@ MASTER_SITES= BERLIOS
MAINTAINER= ports@FreeBSD.org
COMMENT= GTK application to securely store sensitive data
-LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
- gringotts.2:${PORTSDIR}/security/libgringotts
+LIB_DEPENDS= libpopt.so:${PORTSDIR}/devel/popt \
+ libgringotts.so:${PORTSDIR}/security/libgringotts
USES= pkgconfig
USE_GNOME= gtk20
@@ -20,7 +20,8 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e \
'/^install-data-am:/s|install-DsktpDATA|| ; \
@@ -30,12 +31,10 @@ post-patch:
'/^install-exec-am:/s|install-exec-local||' ${WRKSRC}/src/Makefile.in
post-install:
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${PREFIX}/share/applications
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${STAGEDIR}${PREFIX}/share/applications
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in AUTHORS BUGS ChangeLog FAQ NEWS README TODO
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>