aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-08-05 00:25:22 +0800
committeritetcu <itetcu@FreeBSD.org>2006-08-05 00:25:22 +0800
commit23027361abf501f67bde8b3417fab19c646f7c95 (patch)
tree68a7a7e4d3ba95ae36b7089d1da8b2565d96e993 /security
parent6c1028f35f99b3fdc497e1766131e0cd0a9df5b7 (diff)
downloadfreebsd-ports-gnome-23027361abf501f67bde8b3417fab19c646f7c95.tar.gz
freebsd-ports-gnome-23027361abf501f67bde8b3417fab19c646f7c95.tar.zst
freebsd-ports-gnome-23027361abf501f67bde8b3417fab19c646f7c95.zip
This library implements Blowfish, DES, and Triple-DES.
Author: Gerd Stolpmann WWW: http://www.ocaml-programming.de/packages/ PR: ports/101213 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/ocaml-cryptgps/Makefile51
-rw-r--r--security/ocaml-cryptgps/distinfo3
-rw-r--r--security/ocaml-cryptgps/pkg-descr4
4 files changed, 59 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 4043479ce594..ab07c3af6b45 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -272,6 +272,7 @@
SUBDIR += nmapfe
SUBDIR += nofgpg
SUBDIR += nss
+ SUBDIR += ocaml-cryptgps
SUBDIR += ocaml-cryptokit
SUBDIR += oidentd
SUBDIR += oinkmaster
diff --git a/security/ocaml-cryptgps/Makefile b/security/ocaml-cryptgps/Makefile
new file mode 100644
index 000000000000..229b4dd2180a
--- /dev/null
+++ b/security/ocaml-cryptgps/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: ocaml-cryptgps
+# Date created: 2006-08-01
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= cryptgps
+PORTVERSION= 0.2.1
+CATEGORIES= security
+MASTER_SITES= http://www.ocaml-programming.de/packages/
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= Symmetric cryptographic algorithms package for OCaml
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_GMAKE= yes
+USE_OCAML= yes
+USE_OCAML_FINDLIB=yes
+
+ALL_TARGET= all opt
+MASTERPORT= ${PORTSDIR}/devel/ocaml-camlidl
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
+.endif
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/ocaml/bsd.ocaml.mk"
+
+post-extract:
+# For nonstandard prefixes
+.if !exists(${OCAMLFIND_DESTDIR})
+ ${MKDIR} ${OCAMLFIND_DESTDIR}
+.endif
+.if !exists(${OCAMLFIND_LDCONF})
+ ${TOUCH} ${OCAMLFIND_LDCONF}
+.endif
+
+post-install:
+ @${FIND} ${OCAMLFIND_DESTDIR}/${PORTNAME} -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/ocaml-cryptgps/distinfo b/security/ocaml-cryptgps/distinfo
new file mode 100644
index 000000000000..079c909c09f8
--- /dev/null
+++ b/security/ocaml-cryptgps/distinfo
@@ -0,0 +1,3 @@
+MD5 (cryptgps-0.2.1.tar.gz) = 656afb40fa681079296551b546cb02df
+SHA256 (cryptgps-0.2.1.tar.gz) = 7a6c65531781e98c64277e908b8832f6321fe0a8c928cd6a7e89a7ca0489e7d6
+SIZE (cryptgps-0.2.1.tar.gz) = 37532
diff --git a/security/ocaml-cryptgps/pkg-descr b/security/ocaml-cryptgps/pkg-descr
new file mode 100644
index 000000000000..da49e1fa998d
--- /dev/null
+++ b/security/ocaml-cryptgps/pkg-descr
@@ -0,0 +1,4 @@
+This library implements Blowfish, DES, and Triple-DES.
+
+Author: Gerd Stolpmann
+WWW: http://www.ocaml-programming.de/packages/