aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-07-29 17:14:01 +0800
committerkoobs <koobs@FreeBSD.org>2014-07-29 17:14:01 +0800
commit251e0fee3108d88ec93cc367c760133f38c6ca05 (patch)
tree6e006ddeb399677b788bc6b0d19773b91912ae97 /security
parentb58a905c42f50b52934f5b0f40c87393fdd7a651 (diff)
downloadfreebsd-ports-gnome-251e0fee3108d88ec93cc367c760133f38c6ca05.tar.gz
freebsd-ports-gnome-251e0fee3108d88ec93cc367c760133f38c6ca05.tar.zst
freebsd-ports-gnome-251e0fee3108d88ec93cc367c760133f38c6ca05.zip
security/gnutls: Support OPTIONal library dependencies
Factor out libidn, libp11-kit and libtspi into OPTIONal library dependencies, with the CRYWRAP, P11KIT and TPM options respectively, as per the upstream documentation [1]. Make ZLIB an OPTION because we can, and the choice to customise compression support in security software (especially lately) may be very useful for some consumers. Add CRYWRAP, P11KIT, TPM and ZLIB to OPTIONS_DEFAULT to retain current default functionality. [1] http://gnutls.org/manual/html_node/Downloading-and-installing.html Inspired by: Recent gnutls 2 -> 3 change, fan of minimal dependencies PR: 192090 Submitted by: koobs Approved by: maintainer
Diffstat (limited to 'security')
-rw-r--r--security/gnutls/Makefile30
-rw-r--r--security/gnutls/pkg-plist4
2 files changed, 23 insertions, 11 deletions
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index a55cc9d6a5c1..7872a9475855 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gnutls
PORTVERSION= 3.2.16
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security net
MASTER_SITES= GNUPG/gnutls/v3.2
@@ -15,10 +15,7 @@ LICENSE_FILE_GPLv3= ${WRKSRC}/COPYING
LICENSE_FILE_LGPL21= ${WRKSRC}/COPYING.LESSER
LIB_DEPENDS= libnettle.so:${PORTSDIR}/security/nettle \
- libp11-kit.so:${PORTSDIR}/security/p11-kit \
- libidn.so:${PORTSDIR}/dns/libidn \
- libtasn1.so:${PORTSDIR}/security/libtasn1 \
- libtspi.so:${PORTSDIR}/security/trousers
+ libtasn1.so:${PORTSDIR}/security/libtasn1
USES= gmake iconv libtool makeinfo pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
@@ -30,16 +27,31 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV= MAKEINFOFLAGS=--no-split
-OPTIONS_DEFINE= EXAMPLES LIBDANE NLS
-OPTIONS_SUB= yes
+OPTIONS_DEFINE= CRYWRAP EXAMPLES LIBDANE NLS P11KIT TPM ZLIB
+OPTIONS_DEFAULT= CRYWRAP P11KIT TPM ZLIB
+OPTIONS_SUB= yes
-LIBDANE_DESC= DNSSEC support for DANE (danetool --check)
-LIBDANE_LIB_DEPENDS= libunbound.so:${PORTSDIR}/dns/unbound
+CRYWRAP_DESC= Enable Crywrap TLS proxy service
+CRYWRAP_LIB_DEPENDS= libidn.so:${PORTSDIR}/dns/libidn
+CRYWRAP_CONFIGURE_ENABLE= crywrap
+
+LIBDANE_DESC= DNSSEC support for DANE (danetool --check)
+LIBDANE_LIB_DEPENDS= libunbound.so:${PORTSDIR}/dns/unbound
LIBDANE_CONFIGURE_ENABLE= libdane
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
+P11KIT_DESC= PKCS\#11 and p11-kit support
+P11KIT_CONFIGURE_WITH= p11-kit
+P11KIT_LIB_DEPENDS= libp11-kit.so:${PORTSDIR}/security/p11-kit
+
+TPM_DESC= TPM (trousers) support
+TPM_CONFIGURE_WITH= tpm
+TPM_LIB_DEPENDS= libtspi.so:${PORTSDIR}/security/trousers
+
+ZLIB_CONFIGURE_WITH= zlib
+
INFO= gnutls gnutls-guile
post-patch:
diff --git a/security/gnutls/pkg-plist b/security/gnutls/pkg-plist
index 39fc0bf99971..ce4e609f6dd5 100644
--- a/security/gnutls/pkg-plist
+++ b/security/gnutls/pkg-plist
@@ -4,10 +4,10 @@ bin/gnutls-cli
bin/gnutls-cli-debug
bin/gnutls-serv
bin/ocsptool
-bin/p11tool
+%%P11KIT%%bin/p11tool
bin/psktool
bin/srptool
-bin/tpmtool
+%%TPM%%bin/tpmtool
include/gnutls/abstract.h
include/gnutls/compat.h
include/gnutls/crypto.h