aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2012-06-24 11:26:33 +0800
committerzi <zi@FreeBSD.org>2012-06-24 11:26:33 +0800
commit252a1857ce2b59ae6b154f3b135c2613b02bb4dc (patch)
treee57f94030846f4c304fac4a7b9eb27e28e9e3ef9 /security
parentf69340f1da3f086453ea8ea9af1dfb8d561b3c72 (diff)
downloadfreebsd-ports-gnome-252a1857ce2b59ae6b154f3b135c2613b02bb4dc.tar.gz
freebsd-ports-gnome-252a1857ce2b59ae6b154f3b135c2613b02bb4dc.tar.zst
freebsd-ports-gnome-252a1857ce2b59ae6b154f3b135c2613b02bb4dc.zip
- Update to 4.00
- Convert to OptionsNG
Diffstat (limited to 'security')
-rw-r--r--security/openconnect/Makefile33
-rw-r--r--security/openconnect/distinfo4
-rw-r--r--security/openconnect/files/patch-www_Makefile.am8
-rw-r--r--security/openconnect/pkg-plist2
4 files changed, 24 insertions, 23 deletions
diff --git a/security/openconnect/Makefile b/security/openconnect/Makefile
index 20cff6a304ba..341c32f5f231 100644
--- a/security/openconnect/Makefile
+++ b/security/openconnect/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openconnect
-PORTVERSION= 3.20
+PORTVERSION= 4.00
CATEGORIES= security
MASTER_SITES= ftp://ftp.infradead.org/pub/openconnect/ \
http://mirrors.rit.edu/zi/
@@ -17,43 +17,44 @@ COMMENT= A client for Cisco's AnyConnect SSL VPN
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING.LGPL
-LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
+LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2
RUN_DEPENDS= vpnc-script:${PORTSDIR}/sysutils/vpnc-scripts
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-nls --with-vpnc-script=${LOCALBASE}/sbin/vpnc-script
+CONFIGURE_ARGS= --disable-nls --with-vpnc-script=${LOCALBASE}/sbin/vpnc-script \
+ --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
USE_AUTOTOOLS= aclocal autoconf libtool
USE_GNOME= gnomehack pkgconfig
USE_GMAKE= yes
+USE_OPENSSL= yes
MAKE_JOBS_SAFE= yes
ACLOCAL_ARGS= -I .
-USE_OPENSSL= yes
USE_LDCONFIG= yes
PORTDOCS= *
MAN8= openconnect.8
-OPTIONS= PROXY "Enable automatic proxy configuratio via libproxy" off \
- OPENSSLPORT "Use OpenSSL from ports" off
+OPTIONS_DEFINE= PROXY GNUTLS
+
+PROXY_DESC= Enable automatic proxy configuratio via libproxy
+GNUTLS_DESC= Use GnuTLS instead of OpenSSL(EXPERIMENTAL)
.include <bsd.port.options.mk>
-.if defined(WITH_OPENSSLPORT)
-WITH_OPENSSL_PORT= yes
-.else
-WITH_OPENSSL_BASE= yes
+.if ${PORT_OPTIONS:MGNUTLS}
+.if ${OSVERSION} < 900007
+BROKEN= GnuTLS support currently requires FreeBSD 9.x or above
+.endif
+LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
+CONFIGURE_ARGS+=--with-gnutls
.endif
.include <bsd.port.pre.mk>
-.if defined(WITH_PROXY)
-LIB_DEPENDS+= proxy.1:${PORTSDIR}/net/libproxy
+.if ${PORT_OPTIONS:MPROXY}
+LIB_DEPENDS+= proxy:${PORTSDIR}/net/libproxy
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|libdir)/pkgconfig|prefix)/libdata/pkgconfig|' \
- ${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.am
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
diff --git a/security/openconnect/distinfo b/security/openconnect/distinfo
index f8800e30f513..25d025196630 100644
--- a/security/openconnect/distinfo
+++ b/security/openconnect/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openconnect-3.20.tar.gz) = b92c5417fa0fd97899cafb79c930c285ec4ccde9e24550426536f93e4164e9fe
-SIZE (openconnect-3.20.tar.gz) = 576247
+SHA256 (openconnect-4.00.tar.gz) = 6c560db8126cdb947a92a96140c4908f894e82dd913fd4a7dfe7267d269625fb
+SIZE (openconnect-4.00.tar.gz) = 1053324
diff --git a/security/openconnect/files/patch-www_Makefile.am b/security/openconnect/files/patch-www_Makefile.am
index 462abfcc73f8..d15f6a04537d 100644
--- a/security/openconnect/files/patch-www_Makefile.am
+++ b/security/openconnect/files/patch-www_Makefile.am
@@ -1,10 +1,10 @@
---- ./www/Makefile.am.orig 2012-04-15 10:31:27.000000000 -0400
-+++ ./www/Makefile.am 2012-04-15 10:31:33.000000000 -0400
+--- ./www/Makefile.am.orig 2012-06-23 20:40:22.000000000 -0400
++++ ./www/Makefile.am 2012-06-23 20:40:44.000000000 -0400
@@ -25,6 +25,6 @@
manual.html: openconnect.8.inc
- openconnect.8.inc: $(top_srcdir)/openconnect.8
+ openconnect.8.inc: ../openconnect.8
- groff -t -K UTF-8 -mandoc -Txhtml $? | sed -e '1,/<body>/d' -e '/<\/body>/,$$d' > $@
+ groff -t -mandoc -Thtml $^ | sed -e '1,/<body>/d' -e '/<\/body>/,$$d' > $@
- EXTRA_DIST = $(patsubst %.html,%.xml,$(ALL_PAGES)) menu1.xml menu2*.xml html.py
+ EXTRA_DIST = $(patsubst %.html,%.xml,$(ALL_PAGES)) $(srcdir)/menu1.xml $(srcdir)/menu2*.xml $(srcdir)/html.py
diff --git a/security/openconnect/pkg-plist b/security/openconnect/pkg-plist
index 65239a6c8a5a..afc96235fa78 100644
--- a/security/openconnect/pkg-plist
+++ b/security/openconnect/pkg-plist
@@ -3,5 +3,5 @@ include/openconnect.h
lib/libopenconnect.a
lib/libopenconnect.la
lib/libopenconnect.so
-lib/libopenconnect.so.1
+lib/libopenconnect.so.2
libdata/pkgconfig/openconnect.pc