aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-04-11 02:18:09 +0800
committerswills <swills@FreeBSD.org>2011-04-11 02:18:09 +0800
commit281bb1cc1dbe6939d53f27733cf8d537050e20dc (patch)
treea39d720d5dc4e88e9d857aa56f5975a7da5ffc57 /security
parent5ab67ad7a6d341b9e28e7508912c27da5cd45c4c (diff)
downloadfreebsd-ports-gnome-281bb1cc1dbe6939d53f27733cf8d537050e20dc.tar.gz
freebsd-ports-gnome-281bb1cc1dbe6939d53f27733cf8d537050e20dc.tar.zst
freebsd-ports-gnome-281bb1cc1dbe6939d53f27733cf8d537050e20dc.zip
- Mark broken with Ruby 1.9
Diffstat (limited to 'security')
-rw-r--r--security/ruby-aes/Makefile6
-rw-r--r--security/ruby-blowfish/Makefile6
-rw-r--r--security/ruby-cast_256/Makefile6
-rw-r--r--security/ruby-mcrypt/Makefile6
-rw-r--r--security/ruby-pam/Makefile6
5 files changed, 25 insertions, 5 deletions
diff --git a/security/ruby-aes/Makefile b/security/ruby-aes/Makefile
index 70d9f9877b39..8cd6ca20c38a 100644
--- a/security/ruby-aes/Makefile
+++ b/security/ruby-aes/Makefile
@@ -39,4 +39,8 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/ruby-blowfish/Makefile b/security/ruby-blowfish/Makefile
index bc72a3df2275..8541bd96e7a2 100644
--- a/security/ruby-blowfish/Makefile
+++ b/security/ruby-blowfish/Makefile
@@ -38,4 +38,8 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/ruby-cast_256/Makefile b/security/ruby-cast_256/Makefile
index 69db860b707d..4a243f2a2009 100644
--- a/security/ruby-cast_256/Makefile
+++ b/security/ruby-cast_256/Makefile
@@ -49,4 +49,8 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/ruby-mcrypt/Makefile b/security/ruby-mcrypt/Makefile
index c31e9f28a826..1268d24881ce 100644
--- a/security/ruby-mcrypt/Makefile
+++ b/security/ruby-mcrypt/Makefile
@@ -40,4 +40,8 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/ruby-pam/Makefile b/security/ruby-pam/Makefile
index 4701a03ea3c7..9febd4f4146d 100644
--- a/security/ruby-pam/Makefile
+++ b/security/ruby-pam/Makefile
@@ -33,4 +33,8 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/test/* ${RUBY_MODEXAMPLESDIR}/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>