aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-05-18 00:57:14 +0800
committertijl <tijl@FreeBSD.org>2014-05-18 00:57:14 +0800
commit28e42c75bcdfdc70a96743cb31f866dc008a24dd (patch)
treeeae79d4f3cebba3d0e91ecad3c25f200503106b5 /security
parentf084098040cd9061d9bb36e65f8cb0abd8cf4f76 (diff)
downloadfreebsd-ports-gnome-28e42c75bcdfdc70a96743cb31f866dc008a24dd.tar.gz
freebsd-ports-gnome-28e42c75bcdfdc70a96743cb31f866dc008a24dd.tar.zst
freebsd-ports-gnome-28e42c75bcdfdc70a96743cb31f866dc008a24dd.zip
Convert net-im/libpurple (and slave ports net-im/finch and net-im/pidgin)
to "USES=libtool tar:bzip2". Bump PORTREVISION on all dependent ports and modernise them as well (USES, LIB_DEPENDS, staging). audio/pidgin-musictracker: - Replace LIBS with LDFLAGS. - Disable static plugin. net/online-desktop: Remove obsolete patches. net-im/mbpurple: - Drop pkgconf dependency. - Replace post-patch with MAKE_ARGS. - Use standard do-build. net-im/pidgin-audacious-remote: Disable static plugin. net-im/pidgin-birthday-reminder: Disable static plugin. net-im/pidgin-fetion: Replace pkg-plist with PLIST_FILES. net-im/pidgin-guifications: - Drop USE_GNOME=gnomeprefix. - Replace LIBS with LDFLAGS. net-im/pidgin-hotkeys: - Drop CFLAGS=-fPIC. - Fix build on systems without gcc. net-im/pidgin-libnotify: - Use option helpers. - Drop references to PTHREAD_CFLAGS and PTHREAD_LIBS. net-im/pidgin-manualsize: Fix build on systems without gcc. net-im/pidgin-privacy-please: - Replace a patch with CPPFLAGS and LDFLAGS. - Don't use USE_LDCONFIG for a plugin. net-im/pidgin-sipe: - Don't use USE_LDCONFIG for a plugin. - Drop PORTDOCS that don't contain useful documentation. - Patch configure with s/LDLAGS/LDFLAGS/ so LDFLAGS can replace LIBS. - Use option helpers and fix Kerberos option. - Remove obsolete CONFIGURE_ENV. security/pidgin-encryption: - Drop references to PTHREAD_CFLAGS and PTHREAD_LIBS. - Disable static plugin. - Use option helpers. security/pidgin-otr: - Drop redundant comment about PORTREVISION. - Add USE_GNOME=gtk20. - Drop references to PTHREAD_CFLAGS and PTHREAD_LIBS. - Port uses stack protector unconditionally so link with -lssp_nonshared when necessary like Mk/bsd.ssp.mk does. Approved by: portmgr (PORTREVISION bump on unstaged port)
Diffstat (limited to 'security')
-rw-r--r--security/pidgin-encryption/Makefile31
-rw-r--r--security/pidgin-encryption/pkg-plist3
-rw-r--r--security/pidgin-otr/Makefile18
-rw-r--r--security/pidgin-otr/pkg-plist2
4 files changed, 22 insertions, 32 deletions
diff --git a/security/pidgin-encryption/Makefile b/security/pidgin-encryption/Makefile
index 539d6eec1d9a..e2d0d89f16ca 100644
--- a/security/pidgin-encryption/Makefile
+++ b/security/pidgin-encryption/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pidgin
PORTVERSION= 3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}-encrypt/Releases/${PORTVERSION}
PKGNAMESUFFIX= -encryption
@@ -13,37 +13,28 @@ MAINTAINER= perlfu@gmail.com
COMMENT= Encryption Plugin for the Pidgin instant messenger client
BUILD_DEPENDS= ${LOCALBASE}/bin/pidgin:${PORTSDIR}/net-im/pidgin
-LIB_DEPENDS= purple.10:${PORTSDIR}/net-im/libpurple \
- nss3:${PORTSDIR}/security/nss
+RUN_DEPENDS= ${LOCALBASE}/bin/pidgin:${PORTSDIR}/net-im/pidgin
+LIB_DEPENDS= libpurple.so:${PORTSDIR}/net-im/libpurple \
+ libnss3.so:${PORTSDIR}/security/nss
USE_GNOME= gtk20
USES= gettext gmake pkgconfig
GNU_CONFIGURE= yes
-CPPFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-CONFIGURE_ARGS= --with-nspr-includes=${LOCALBASE}/include/nspr \
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --disable-static \
+ --with-nspr-includes=${LOCALBASE}/include/nspr \
--with-nspr-libs=${LOCALBASE}/lib \
--with-nss-includes=${LOCALBASE}/include/nss/nss \
--with-nss-libs=${LOCALBASE}/lib/nss
-NO_STAGE= yes
-
OPTIONS_DEFINE= NLS
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+OPTIONS_SUB= yes
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
post-extract:
- @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|glib/.*\.h"|glib.h"|g' ${WRKSRC}/rsa_nss.c
.include <bsd.port.mk>
diff --git a/security/pidgin-encryption/pkg-plist b/security/pidgin-encryption/pkg-plist
index e5ed4e6f0e6e..5b644ff03ceb 100644
--- a/security/pidgin-encryption/pkg-plist
+++ b/security/pidgin-encryption/pkg-plist
@@ -1,5 +1,3 @@
-lib/pidgin/encrypt.a
-lib/pidgin/encrypt.la
lib/pidgin/encrypt.so
%%NLS%%share/locale/cs/LC_MESSAGES/pidgin-encryption.mo
%%NLS%%share/locale/da/LC_MESSAGES/pidgin-encryption.mo
@@ -32,4 +30,3 @@ share/pixmaps/pidgin-encryption/icon_out_capable.png
share/pixmaps/pidgin-encryption/icon_out_lock.png
share/pixmaps/pidgin-encryption/icon_out_unlock.png
@dirrm share/pixmaps/pidgin-encryption
-@dirrmtry lib/pidgin
diff --git a/security/pidgin-otr/Makefile b/security/pidgin-otr/Makefile
index a9bb2492435f..51f425ca003b 100644
--- a/security/pidgin-otr/Makefile
+++ b/security/pidgin-otr/Makefile
@@ -2,9 +2,7 @@
PORTNAME= otr
PORTVERSION= 4.0.0
-# Please do not bump PORTREVISION for this port unless you have
-# confirmed via testing that it is necessary
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security net-im net
MASTER_SITES= http://www.cypherpunks.ca/otr/
PKGNAMEPREFIX= pidgin-
@@ -21,13 +19,19 @@ LIB_DEPENDS= libotr.so.5:${PORTSDIR}/security/libotr \
libgcrypt.so:${PORTSDIR}/security/libgcrypt \
libpurple.so:${PORTSDIR}/net-im/libpurple
-USE_GNOME= intltool
-USES= gettext gmake pkgconfig
+USES= gettext gmake libtool pkgconfig
+USE_GNOME= gtk20
GNU_CONFIGURE= yes
-CPPFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-libotr-prefix=${LOCALBASE}/lib \
--with-libotr-inc-prefix=${LOCALBASE}/include
+.include <bsd.port.options.mk>
+
+.if ${OSVERSION} < 1000036 && ${ARCH} == i386
+LDFLAGS+= -lssp_nonshared
+.endif
+
.include <bsd.port.mk>
diff --git a/security/pidgin-otr/pkg-plist b/security/pidgin-otr/pkg-plist
index 104795db02e8..32de4fa07e55 100644
--- a/security/pidgin-otr/pkg-plist
+++ b/security/pidgin-otr/pkg-plist
@@ -1,4 +1,3 @@
-lib/pidgin/pidgin-otr.la
lib/pidgin/pidgin-otr.so
share/locale/ar/LC_MESSAGES/pidgin-otr.mo
share/locale/de/LC_MESSAGES/pidgin-otr.mo
@@ -17,4 +16,3 @@ share/locale/sk/LC_MESSAGES/pidgin-otr.mo
share/locale/sv/LC_MESSAGES/pidgin-otr.mo
share/locale/vi/LC_MESSAGES/pidgin-otr.mo
share/locale/zh_CN/LC_MESSAGES/pidgin-otr.mo
-@dirrmtry lib/pidgin