aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-03-01 09:36:56 +0800
committerclsung <clsung@FreeBSD.org>2007-03-01 09:36:56 +0800
commit3547a435fae9ed359cecb41d0cbb6a9985e3040d (patch)
tree8735eb3fd05b510608fd4813c85842fd17ec7576 /security
parent6b4a79d333eefe82c1251441041dfd8525b3fae0 (diff)
downloadfreebsd-ports-gnome-3547a435fae9ed359cecb41d0cbb6a9985e3040d.tar.gz
freebsd-ports-gnome-3547a435fae9ed359cecb41d0cbb6a9985e3040d.tar.zst
freebsd-ports-gnome-3547a435fae9ed359cecb41d0cbb6a9985e3040d.zip
Add sshguard 0.91, protect networked hosts from brute force attacks
against ssh. PR: ports/109439 Submitted by: Mij <mij at bitchx.it>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/sshguard/Makefile43
-rw-r--r--security/sshguard/distinfo3
-rw-r--r--security/sshguard/pkg-descr12
4 files changed, 59 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index becab54b037a..f7d58a18aa34 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -678,6 +678,7 @@
SUBDIR += ssh2-nox11
SUBDIR += ssh_askpass_gtk2
SUBDIR += sshblock
+ SUBDIR += sshguard
SUBDIR += sshit
SUBDIR += sslproxy
SUBDIR += sslsniffer
diff --git a/security/sshguard/Makefile b/security/sshguard/Makefile
new file mode 100644
index 000000000000..8698ebf78777
--- /dev/null
+++ b/security/sshguard/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: sshguard
+# Date created: 2007-02-22
+# Whom: Mij <mij@bitchx.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sshguard
+PORTVERSION= 0.91
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= mij@bitchx.it
+COMMENT= Protect networked hosts from brute force attacks against ssh
+
+PLIST_FILES= sbin/sshguard
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+
+OPTIONS= PF "Use PF as firewall backend" on \
+ IPFW "Use IPFW as firewall backend" off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITH_PF) && defined(WITH_IPFW)
+# compile with IPFW support
+CONFIGURE_ARGS+= --with-firewall=ipfw
+.else
+# compile with PF support
+CONFIGURE_ARGS+= --with-firewall=pf
+.endif
+
+post-install:
+ # spare pkg-message
+ ${ECHO_MSG} " Sshguard installed successfully."
+ ${ECHO_MSG} "Make it active by putting in /etc/syslog.conf something like:"
+ ${ECHO_MSG} " auth.info;authpriv.info |exec ${PREFIX}/sbin/sshguard"
+ ${ECHO_MSG} "Otherwise, run sshguard standalone with (as root):"
+ ${ECHO_MSG} " tail -n 0 -f /var/log/auth.log | ${PREFIX}/sbin/sshguard"
+
+.include <bsd.port.post.mk>
diff --git a/security/sshguard/distinfo b/security/sshguard/distinfo
new file mode 100644
index 000000000000..07be1e50c899
--- /dev/null
+++ b/security/sshguard/distinfo
@@ -0,0 +1,3 @@
+MD5 (sshguard-0.91.tar.bz2) = e6fb218fe2450f14b38ae5c5b67f0b6a
+SHA256 (sshguard-0.91.tar.bz2) = c1e16d1d20ff192e0368bd8ddfe6acede5a90fef10ce0558655bacf62c29c42f
+SIZE (sshguard-0.91.tar.bz2) = 63751
diff --git a/security/sshguard/pkg-descr b/security/sshguard/pkg-descr
new file mode 100644
index 000000000000..6b077a154aba
--- /dev/null
+++ b/security/sshguard/pkg-descr
@@ -0,0 +1,12 @@
+Sshguard monitors ssh servers from their logging activity. It reacts to messages
+about dangerous activity by blocking the source address with the local firewall.
+
+Sshguard can operate all the major firewalling systems:
+* PF (OpenBSD, FreeBSD, NetBSD, DragonFly BSD)
+* netfilter/iptables (Linux)
+* IPFIREWALL/ipfw (FreeBSD, Mac OS X)
+
+Sshguard is reliable, easy to set up and demands very few resources to the
+system.
+
+WWW: http://sshguard.sourceforge.net