aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2008-06-02 23:49:41 +0800
committerskv <skv@FreeBSD.org>2008-06-02 23:49:41 +0800
commit38efebd3324f8fdd0ca65de357cfd30a1eea2823 (patch)
treed9c2046524d3a15408e0754b6c7bcc0729011e61 /security
parent13ead04847d7b0a693e976a9ef09a39fc08c027f (diff)
downloadfreebsd-ports-gnome-38efebd3324f8fdd0ca65de357cfd30a1eea2823.tar.gz
freebsd-ports-gnome-38efebd3324f8fdd0ca65de357cfd30a1eea2823.tar.zst
freebsd-ports-gnome-38efebd3324f8fdd0ca65de357cfd30a1eea2823.zip
Update to 0.3.1
PR: ports/123649 Submitted by: Greg Larkin <glarkin xx sourcehosting.net> Changes: http://www.keepassx.org/change_log
Diffstat (limited to 'security')
-rw-r--r--security/keepassx/Makefile8
-rw-r--r--security/keepassx/distinfo6
-rw-r--r--security/keepassx/files/patch-src-mainwindow.cpp32
-rw-r--r--security/keepassx/files/patch-src-src.pro21
-rw-r--r--security/keepassx/pkg-plist121
5 files changed, 106 insertions, 82 deletions
diff --git a/security/keepassx/Makefile b/security/keepassx/Makefile
index ad898d64f3f8..7a50fbb1bcad 100644
--- a/security/keepassx/Makefile
+++ b/security/keepassx/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= KeePassX
-PORTVERSION= 0.2.2
-PORTREVISION= 3
+PORTVERSION= 0.3.1
CATEGORIES= security
MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME:L}
@@ -15,10 +14,11 @@ MASTER_SITE_SUBDIR= ${PORTNAME:L}
MAINTAINER= skv@FreeBSD.org
COMMENT= Cross Platform Password Manager
-WRKSRC= ${WRKDIR}/${PORTNAME:L}-${PORTVERSION}
+DATADIR= ${PREFIX}/share/${PORTNAME:L}
USE_QT_VER= 4
-QT_COMPONENTS= qmake_build moc_build uic_build qt3support_build corelib gui xml
+QT_COMPONENTS= qmake_build moc_build uic_build qt3support_build rcc_build \
+ corelib gui xml
HAS_CONFIGURE= yes
USE_XORG= xt inputproto xtst xrender xrandr xfixes xcursor\
xext x11 sm ice xi
diff --git a/security/keepassx/distinfo b/security/keepassx/distinfo
index 482d0ee36514..39fab8d77ac2 100644
--- a/security/keepassx/distinfo
+++ b/security/keepassx/distinfo
@@ -1,3 +1,3 @@
-MD5 (KeePassX-0.2.2.tar.gz) = 5ee945ab12c2667ef5c4013a0636c26f
-SHA256 (KeePassX-0.2.2.tar.gz) = ee588bd744195e394e7b618b8e0aeb25cbf37ca5b619b1c7e2176fd412b29cbd
-SIZE (KeePassX-0.2.2.tar.gz) = 302656
+MD5 (KeePassX-0.3.1.tar.gz) = 1d6ebb010e44cf2d0a635b4796498694
+SHA256 (KeePassX-0.3.1.tar.gz) = 1f37b67f64d1b8d13b9c9c51fdfe15fe1cb33d122773b12688bb5213510876d2
+SIZE (KeePassX-0.3.1.tar.gz) = 501954
diff --git a/security/keepassx/files/patch-src-mainwindow.cpp b/security/keepassx/files/patch-src-mainwindow.cpp
deleted file mode 100644
index 9291974e0546..000000000000
--- a/security/keepassx/files/patch-src-mainwindow.cpp
+++ /dev/null
@@ -1,32 +0,0 @@
---- src/mainwindow.cpp.orig Wed Jun 7 12:54:20 2006
-+++ src/mainwindow.cpp Mon Jun 4 08:56:25 2007
-@@ -879,6 +879,9 @@
-
- void KeepassMainWindow::OnEditUsernameToClipboard(){
- Clipboard->setText(currentEntry()->UserName, QClipboard::Clipboard);
-+if(Clipboard->supportsSelection()){
-+ Clipboard->setText(currentEntry()->UserName, QClipboard::Selection);
-+}
- ClipboardTimer.setSingleShot(true);
- ClipboardTimer.start(config.ClipboardTimeOut*1000);
- }
-@@ -886,6 +889,9 @@
- void KeepassMainWindow::OnEditPasswordToClipboard(){
- currentEntry()->Password.unlock();
- Clipboard->setText(currentEntry()->Password.string(),QClipboard::Clipboard);
-+if(Clipboard->supportsSelection()){
-+ Clipboard->setText(currentEntry()->Password.string(),QClipboard::Selection);
-+}
- ClipboardTimer.setSingleShot(true);
- ClipboardTimer.start(config.ClipboardTimeOut*1000);
- currentEntry()->Password.lock();
-@@ -894,6 +900,9 @@
-
- void KeepassMainWindow::OnClipboardTimeOut(){
- Clipboard->clear(QClipboard::Clipboard);
-+if(Clipboard->supportsSelection()){
-+ Clipboard->clear(QClipboard::Selection);
-+}
- }
-
- void KeepassMainWindow::OnEditSaveAttachment(){
diff --git a/security/keepassx/files/patch-src-src.pro b/security/keepassx/files/patch-src-src.pro
new file mode 100644
index 000000000000..54cde3355c1c
--- /dev/null
+++ b/security/keepassx/files/patch-src-src.pro
@@ -0,0 +1,21 @@
+--- src/src.pro.orig 2008-05-09 13:23:13.000000000 -0400
++++ src/src.pro 2008-05-09 13:34:37.000000000 -0400
+@@ -18,6 +18,7 @@
+ }
+
+ win32 : QMAKE_WIN32 = 1
++freebsd-* : QMAKE_FREEBSD = 1
+
+ #-------------------------------------------------------------------------------
+ # Platform Specific: Unix (except MacOS X)
+@@ -49,6 +50,10 @@
+ HEADERS += Application_X11.h
+ }
+ SOURCES += main_unix.cpp
++ isEqual(QMAKE_FREEBSD,1){
++ CONFIG -= precompile_header
++ QMAKE_CXXFLAGS += -include keepassx.h
++ }
+ }
+
+
diff --git a/security/keepassx/pkg-plist b/security/keepassx/pkg-plist
index de75fc5dfd7d..3d84787460a2 100644
--- a/security/keepassx/pkg-plist
+++ b/security/keepassx/pkg-plist
@@ -1,43 +1,78 @@
-bin/keepass
-share/keepass/license.html
-share/keepass/i18n/keepass-de_DE.qm
-share/keepass/i18n/keepass-fr_FR.qm
-share/keepass/icons/clientic.png
-share/keepass/icons/i18n.png
-share/keepass/icons/keepassx.png
-share/keepass/icons/key.png
-share/keepass/icons/ok.png
-share/keepass/icons/search.png
-share/keepass/icons/settings.png
-share/keepass/icons/nuvola/32x32/actions/configure.png
-share/keepass/icons/nuvola/32x32/actions/edit.png
-share/keepass/icons/nuvola/32x32/actions/edit_add.png
-share/keepass/icons/nuvola/32x32/actions/editcopy.png
-share/keepass/icons/nuvola/32x32/actions/editdelete.png
-share/keepass/icons/nuvola/32x32/actions/exit.png
-share/keepass/icons/nuvola/32x32/actions/fileclose.png
-share/keepass/icons/nuvola/32x32/actions/fileexport.png
-share/keepass/icons/nuvola/32x32/actions/filenew.png
-share/keepass/icons/nuvola/32x32/actions/fileopen.png
-share/keepass/icons/nuvola/32x32/actions/filesave.png
-share/keepass/icons/nuvola/32x32/actions/filesaveas.png
-share/keepass/icons/nuvola/32x32/actions/find.png
-share/keepass/icons/nuvola/32x32/actions/help.png
-share/keepass/icons/nuvola/32x32/actions/identity.png
-share/keepass/icons/nuvola/32x32/actions/klipper_dock.png
-share/keepass/icons/nuvola/32x32/actions/reload.png
-share/keepass/icons/nuvola/32x32/actions/run.png
-share/keepass/icons/nuvola/32x32/apps/ktouch.png
-share/keepass/icons/nuvola/32x32/filesystems/desktop.png
-share/keepass/icons/nuvola/32x32/filesystems/folder.png
-share/keepass/icons/nuvola/32x32/filesystems/folder_home.png
-share/keepass/icons/nuvola/32x32/filesystems/network_local.png
-share/keepass/icons/nuvola/32x32/filesystems/trashcan_full.png
-@dirrm share/keepass/icons/nuvola/32x32/filesystems
-@dirrm share/keepass/icons/nuvola/32x32/apps
-@dirrm share/keepass/icons/nuvola/32x32/actions
-@dirrm share/keepass/icons/nuvola/32x32
-@dirrm share/keepass/icons/nuvola
-@dirrm share/keepass/icons
-@dirrm share/keepass/i18n
-@dirrm share/keepass
+bin/keepassx
+share/applications/keepassx.desktop
+%%DATADIR%%/doc/css/style.css
+%%DATADIR%%/doc/images/headerbackground.png
+%%DATADIR%%/doc/images/logo.png
+%%DATADIR%%/doc/index.html
+%%DATADIR%%/doc/keepassx.adp
+%%DATADIR%%/icons/alarmclock.png
+%%DATADIR%%/icons/appsettings.png
+%%DATADIR%%/icons/autotype.png
+%%DATADIR%%/icons/bookmark.png
+%%DATADIR%%/icons/bookmark_add.png
+%%DATADIR%%/icons/bookmark_del.png
+%%DATADIR%%/icons/bookmark_edit.png
+%%DATADIR%%/icons/bookmark_folder.png
+%%DATADIR%%/icons/bookmark_this.png
+%%DATADIR%%/icons/clientic.png
+%%DATADIR%%/icons/clock.png
+%%DATADIR%%/icons/cloneentry.png
+%%DATADIR%%/icons/copypwd.png
+%%DATADIR%%/icons/copyusername.png
+%%DATADIR%%/icons/dbsearch.png
+%%DATADIR%%/icons/dbsettings.png
+%%DATADIR%%/icons/delete.png
+%%DATADIR%%/icons/deleteentry.png
+%%DATADIR%%/icons/deletegroup.png
+%%DATADIR%%/icons/dice.png
+%%DATADIR%%/icons/document.png
+%%DATADIR%%/icons/down.png
+%%DATADIR%%/icons/editentry.png
+%%DATADIR%%/icons/editgroup.png
+%%DATADIR%%/icons/exit.png
+%%DATADIR%%/icons/expired.png
+%%DATADIR%%/icons/fileclose.png
+%%DATADIR%%/icons/filedelete.png
+%%DATADIR%%/icons/filenew.png
+%%DATADIR%%/icons/fileopen.png
+%%DATADIR%%/icons/filesave.png
+%%DATADIR%%/icons/filesaveas.png
+%%DATADIR%%/icons/filesavedisabled.png
+%%DATADIR%%/icons/generator.png
+%%DATADIR%%/icons/groupsearch.png
+%%DATADIR%%/icons/help.png
+%%DATADIR%%/icons/i18n.png
+%%DATADIR%%/icons/keepassx.png
+%%DATADIR%%/icons/keepassx_large.png
+%%DATADIR%%/icons/keepassx_locked.png
+%%DATADIR%%/icons/key.png
+%%DATADIR%%/icons/lock.png
+%%DATADIR%%/icons/manual.png
+%%DATADIR%%/icons/newentry.png
+%%DATADIR%%/icons/newgroup.png
+%%DATADIR%%/icons/ok.png
+%%DATADIR%%/icons/openurl.png
+%%DATADIR%%/icons/pwd_hide.png
+%%DATADIR%%/icons/pwd_show.png
+%%DATADIR%%/icons/restore.png
+%%DATADIR%%/icons/search.png
+%%DATADIR%%/icons/swap.png
+%%DATADIR%%/icons/templates.png
+%%DATADIR%%/icons/text_block.png
+%%DATADIR%%/icons/text_bold.png
+%%DATADIR%%/icons/text_center.png
+%%DATADIR%%/icons/text_italic.png
+%%DATADIR%%/icons/text_left.png
+%%DATADIR%%/icons/text_right.png
+%%DATADIR%%/icons/text_under.png
+%%DATADIR%%/icons/trashcan.png
+%%DATADIR%%/icons/up.png
+%%DATADIR%%/license.html
+share/pixmaps/keepassx.xpm
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%/i18n
+@dirrm %%DATADIR%%/doc/images
+@dirrm %%DATADIR%%/doc/css
+@dirrm %%DATADIR%%/doc
+@dirrm %%DATADIR%%
+@dirrmtry share/applications