aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-05-23 02:20:22 +0800
committeraaron <aaron@FreeBSD.org>2006-05-23 02:20:22 +0800
commit390d04332bfe75bed73c415d0c5c357f4c9c6ef8 (patch)
tree2a43b61c212c8ecfcf60b44bc5f76208d250cf37 /security
parent1902e87046a805a11c42a470af765d3376d4a05c (diff)
downloadfreebsd-ports-gnome-390d04332bfe75bed73c415d0c5c357f4c9c6ef8.tar.gz
freebsd-ports-gnome-390d04332bfe75bed73c415d0c5c357f4c9c6ef8.tar.zst
freebsd-ports-gnome-390d04332bfe75bed73c415d0c5c357f4c9c6ef8.zip
Adding port security/p5-Tree-Authz, a library implementing a Role-Based Access Control authorization scheme.
Approved by: tobez (implicit)
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Tree-Authz/Makefile33
-rw-r--r--security/p5-Tree-Authz/distinfo3
-rw-r--r--security/p5-Tree-Authz/pkg-descr17
-rw-r--r--security/p5-Tree-Authz/pkg-plist4
5 files changed, 58 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index a582c3f3f4fb..65432a9e4396 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -437,6 +437,7 @@
SUBDIR += p5-SHA
SUBDIR += p5-Safe-Hole
SUBDIR += p5-Tie-EncryptedHash
+ SUBDIR += p5-Tree-Authz
SUBDIR += pad
SUBDIR += pam-mysql
SUBDIR += pam-pgsql
diff --git a/security/p5-Tree-Authz/Makefile b/security/p5-Tree-Authz/Makefile
new file mode 100644
index 000000000000..f83376647b18
--- /dev/null
+++ b/security/p5-Tree-Authz/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: Tree-Authz
+# Date created: 22 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tree-Authz
+PORTVERSION= 0.03
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Tree
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Role-Based Access Control authorization scheme
+
+BUILD_DEPENDS= ${SITE_PERL}/Lingua/EN/Inflect/Number.pm:${PORTSDIR}/textproc/p5-Lingua-EN-Inflect-Number \
+ ${SITE_PERL}Devel/Symdump.pm:${PORTSDIR}/devel/p5-Devel-Symdump \
+ ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Tree::Authz.3 Tree::Authz::Role.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Tree-Authz/distinfo b/security/p5-Tree-Authz/distinfo
new file mode 100644
index 000000000000..d22670dcfea5
--- /dev/null
+++ b/security/p5-Tree-Authz/distinfo
@@ -0,0 +1,3 @@
+MD5 (Tree-Authz-0.03.tar.gz) = f1dc5d1396f560443510939c6559d4c3
+SHA256 (Tree-Authz-0.03.tar.gz) = badc383ad599d5acffedee608d12fe55e160b3ad1c957cfed0bf2303b3e44dbc
+SIZE (Tree-Authz-0.03.tar.gz) = 12165
diff --git a/security/p5-Tree-Authz/pkg-descr b/security/p5-Tree-Authz/pkg-descr
new file mode 100644
index 000000000000..2f9b9059b513
--- /dev/null
+++ b/security/p5-Tree-Authz/pkg-descr
@@ -0,0 +1,17 @@
+Class for inheritable, role-based permissions system (Role Based Access
+Control - RBAC).
+
+Custom methods can be placed on role objects. Authorization can be
+performed either by checking whether the role name matches the required
+name, or by testing (via can) whether the role can perform the method
+required.
+
+Two role are specified by default. At the top, superusers can do anything
+($superuser->can( $action ) always returns a coderef). At the bottom, the
+base role can do nothing ($base->can( $action ) always returns undef).
+
+All roles are automatically capable of authorizing actions named for the
+singular and plural of the role name.
+
+WWW: http://search.cpan.org/dist/Tree-Authz
+Author: David Baird <cpan@riverside-cms.co.uk>
diff --git a/security/p5-Tree-Authz/pkg-plist b/security/p5-Tree-Authz/pkg-plist
new file mode 100644
index 000000000000..8bcae95584f3
--- /dev/null
+++ b/security/p5-Tree-Authz/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Tree/Authz.pm
+%%SITE_PERL%%/Tree/Authz/Role.pm
+@dirrm %%SITE_PERL%%/Tree/Authz
+@dirrmtry %%SITE_PERL%%/Tree