aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2012-03-11 04:46:26 +0800
committerohauer <ohauer@FreeBSD.org>2012-03-11 04:46:26 +0800
commit3a946def2a2625b73e907f3770de15895962e524 (patch)
treee6a2e80ed322cc3c784418433b9e05e938935c24 /security
parent33d759af5af2f729b7364ebff9ab76cd0c995696 (diff)
downloadfreebsd-ports-gnome-3a946def2a2625b73e907f3770de15895962e524.tar.gz
freebsd-ports-gnome-3a946def2a2625b73e907f3770de15895962e524.tar.zst
freebsd-ports-gnome-3a946def2a2625b73e907f3770de15895962e524.zip
- adjust FreeBSD version provuded by snort-rules
( pulledpork bug id:110) - fix SSL download - remove check for perl < 501000 - portlint Feature safe: yes
Diffstat (limited to 'security')
-rw-r--r--security/pulledpork/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/security/pulledpork/Makefile b/security/pulledpork/Makefile
index 32682aacbdb8..a68176ee6e5b 100644
--- a/security/pulledpork/Makefile
+++ b/security/pulledpork/Makefile
@@ -7,22 +7,24 @@
PORTNAME= pulledpork
PORTVERSION= 0.6.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= ohauer@FreeBSD.org
COMMENT= Script to update snort-2.8+ rules
+LICENSE= GPLv2
+
RUN_DEPENDS= p5-Crypt-SSLeay>=0.57:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ p5-LWP-Protocol-https>=6.00:${PORTSDIR}/www/p5-LWP-Protocol-https \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-LICENSE= GPLv2
-
NO_BUILD= yes
USE_PERL5_RUN= yes
-PLIST_DIRS= %%ETCDIR%% \
- %%DATADIR%%
+PLIST_DIRSTRY= %%ETCDIR%%
+PLIST_DIRS= %%DATADIR%%
PLIST_FILES= bin/pulledpork.pl \
%%ETCDIR%%/disablesid.conf.sample \
@@ -35,12 +37,6 @@ PLIST_FILES= bin/pulledpork.pl \
SUB_FILES= pkg-message
-.include <bsd.port.pre.mk>
-
-.if (${PERL_LEVEL} < 501000)
-RUN_DEPENDS+= p5-Archive-Tar>=1.52:${PORTSDIR}/archivers/p5-Archive-Tar
-.endif
-
.if !defined(NOPORTDOCS)
PORTDOCS= LICENSE README README.CATEGORIES README.CHANGES README.RULESET README.SHAREDOBJECTS
.endif
@@ -54,6 +50,9 @@ post-patch:
-e "s|/usr/local/lib/snort_dynamicrules/|${PREFIX}/etc/snort/so_rules/|g" \
${WRKSRC}/etc/pulledpork.conf
@${REINPLACE_CMD} -e "s| /usr/bin/perl|${PERL}|" ${WRKSRC}/contrib/oink-conv.pl
+# pulledpork bug id:110
+ @${REINPLACE_CMD} -e 's|distro=FreeBSD-8.0|distro=FreeBSD-8-1|g' \
+ ${WRKSRC}/etc/pulledpork.conf
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/pulledpork.pl ${PREFIX}/bin
@@ -80,4 +79,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>