aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-11-11 02:16:38 +0800
committerpawel <pawel@FreeBSD.org>2012-11-11 02:16:38 +0800
commit3b178888f527c50f4af297d2d552c0478ee8026e (patch)
treecaf75042dfe4b054ae41cd0419ef01897d95b241 /security
parentf9d4e5a85741953af12e8d3a0ce5d631ce1a96b8 (diff)
downloadfreebsd-ports-gnome-3b178888f527c50f4af297d2d552c0478ee8026e.tar.gz
freebsd-ports-gnome-3b178888f527c50f4af297d2d552c0478ee8026e.tar.zst
freebsd-ports-gnome-3b178888f527c50f4af297d2d552c0478ee8026e.zip
- Update MASTER_SITES and WWW: line
- Support CFLAGS properly - Add MAKE_JOBS_SAFE - Don't install license file twice PR: ports/172064 Submitted by: KATO Tsuguru <tkato432@yahoo.com> Feature safe: yes
Diffstat (limited to 'security')
-rw-r--r--security/xyssl/Makefile35
-rw-r--r--security/xyssl/files/patch-Makefile12
-rw-r--r--security/xyssl/pkg-descr5
-rw-r--r--security/xyssl/pkg-plist14
4 files changed, 37 insertions, 29 deletions
diff --git a/security/xyssl/Makefile b/security/xyssl/Makefile
index 51e9863df3e0..9aac6c3d4b51 100644
--- a/security/xyssl/Makefile
+++ b/security/xyssl/Makefile
@@ -1,32 +1,39 @@
-# New ports collection makefile for: xyssl
-# Date created: 2007-04-05
-# Whom: mdh <mdh@solitox.net>
-#
+# Created by: mdh <mdh@solitox.net>
# $FreeBSD$
-#
PORTNAME= xyssl
PORTVERSION= 0.9
+DISTVERSIONSUFFIX= -bsd
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= http://www.evolane.com/download/mirror/etcl/ \
- http://www.straightrunning.com/code/
-DISTFILES= xyssl-${PORTVERSION}-bsd.tgz
+ http://polarssl.org/code/releases/
+EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-COMMENT= A lightweight SSL and TLS toolkit for C developers
+COMMENT= Lightweight SSL and TLS toolkit for C developers
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/BSD.txt
-# HAS_CONFIGURE= no
-# GNU_CONFIGURE= no
+PORTDOCS= ChangeLog
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-PORTDOCS= BSD.txt ChangeLog
+MAKE_JOBS_SAFE= yes
+
+.include <bsd.port.options.mk>
+
+post-patch:
+.for i in library/Makefile programs/Makefile
+ @${REINPLACE_CMD} -e \
+ '/^CFLAGS/s|[[:space:]]=| +=| ; \
+ s|^OFLAGS|#OFLAGS| ; \
+ s|^.SILENT:|#.SILENT:|' ${WRKSRC}/${i}
+.endfor
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/BSD.txt ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/ChangeLog ${DOCSDIR}
.endif
diff --git a/security/xyssl/files/patch-Makefile b/security/xyssl/files/patch-Makefile
index 1845d1217ebf..91473e573026 100644
--- a/security/xyssl/files/patch-Makefile
+++ b/security/xyssl/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2008-03-16 14:23:22.000000000 +0000
-+++ Makefile 2009-01-02 23:45:48.380520000 +0000
-@@ -1,6 +1,6 @@
+--- Makefile.orig 2008-03-16 23:23:22.000000000 +0900
++++ Makefile 2012-07-12 22:47:37.000000000 +0900
+@@ -1,26 +1,26 @@
-DESTDIR=/usr/local
-PREFIX=xyssl_
@@ -9,7 +9,11 @@
.SILENT:
-@@ -10,17 +10,17 @@
+ all:
+- cd library && make all && cd ..
+- cd programs && make all && cd ..
++ cd library && $(MAKE) all && cd ..
++ cd programs && $(MAKE) all && cd ..
install:
mkdir -p $(DESTDIR)/include/xyssl
diff --git a/security/xyssl/pkg-descr b/security/xyssl/pkg-descr
index 2f4669e5531b..c8f3f29b9619 100644
--- a/security/xyssl/pkg-descr
+++ b/security/xyssl/pkg-descr
@@ -4,7 +4,4 @@ and 3DES ciphers, and the MD2, MD4, MD5, SHA1, and SHA256 hashes.
Support is also included for X.509 certificate structures,
as well as an internal PRNG.
-LICENSE: BSD
-Copyright (c) 2006-2008, Christophe Devine.
-
-WWW: http://xyssl.org/
+WWW: http://polarssl.org/
diff --git a/security/xyssl/pkg-plist b/security/xyssl/pkg-plist
index 33ea21ed1f89..d291565e367e 100644
--- a/security/xyssl/pkg-plist
+++ b/security/xyssl/pkg-plist
@@ -1,21 +1,20 @@
-lib/libxyssl.a
bin/xyssl_aescrypt2
-bin/xyssl_hello
-bin/xyssl_md5sum
-bin/xyssl_sha1sum
-bin/xyssl_sha2sum
+bin/xyssl_benchmark
bin/xyssl_dh_client
bin/xyssl_dh_genprime
bin/xyssl_dh_server
+bin/xyssl_hello
+bin/xyssl_md5sum
bin/xyssl_mpi_demo
bin/xyssl_rsa_genkey
bin/xyssl_rsa_sign
bin/xyssl_rsa_verify
+bin/xyssl_selftest
+bin/xyssl_sha1sum
+bin/xyssl_sha2sum
bin/xyssl_ssl_client1
bin/xyssl_ssl_client2
bin/xyssl_ssl_server
-bin/xyssl_benchmark
-bin/xyssl_selftest
bin/xyssl_ssl_test
include/xyssl/aes.h
include/xyssl/arc4.h
@@ -41,4 +40,5 @@ include/xyssl/sha4.h
include/xyssl/ssl.h
include/xyssl/timing.h
include/xyssl/x509.h
+lib/libxyssl.a
@dirrm include/xyssl