aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2003-08-06 16:46:45 +0800
committerdaichi <daichi@FreeBSD.org>2003-08-06 16:46:45 +0800
commit4f439876953d4f9929dd6842bdb9f108ea211e3f (patch)
tree6beaf9cf0b402d945da3bba01f7aaa071fdd98b8 /security
parentb7d6d23e7458b2075c2db37a76c6584f73f963ae (diff)
downloadfreebsd-ports-gnome-4f439876953d4f9929dd6842bdb9f108ea211e3f.tar.gz
freebsd-ports-gnome-4f439876953d4f9929dd6842bdb9f108ea211e3f.tar.zst
freebsd-ports-gnome-4f439876953d4f9929dd6842bdb9f108ea211e3f.zip
fix security/py-m2crypto:
- use PYTHON_VERSION Pointed out by: kuriyama
Diffstat (limited to 'security')
-rw-r--r--security/py-m2crypto/Makefile4
-rw-r--r--security/py-m2crypto/files/patch-SWIG::Makefile11
2 files changed, 10 insertions, 5 deletions
diff --git a/security/py-m2crypto/Makefile b/security/py-m2crypto/Makefile
index 6ea55f140bd8..c6e982efce9a 100644
--- a/security/py-m2crypto/Makefile
+++ b/security/py-m2crypto/Makefile
@@ -23,9 +23,13 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/SWIG
USE_PYTHON= yes
USE_ZIP= yes
USE_OPENSSL= yes
+USE_REINPLACE= yes
PINSTALL_PLIST= ${WRKDIR}/pinstall-plist
+post-patch:
+ ${REINPLACE_CMD} "s/PYTHON_VERSION/${PYTHON_VERSION}/" ${WRKSRC}/Makefile
+
post-build:
${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/../M2Crypto
diff --git a/security/py-m2crypto/files/patch-SWIG::Makefile b/security/py-m2crypto/files/patch-SWIG::Makefile
index 59ec0a7a492b..e6d34ff9d941 100644
--- a/security/py-m2crypto/files/patch-SWIG::Makefile
+++ b/security/py-m2crypto/files/patch-SWIG::Makefile
@@ -1,11 +1,12 @@
---- Makefile.orig Wed Aug 6 16:47:51 2003
-+++ Makefile Wed Aug 6 16:49:15 2003
-@@ -3,7 +3,7 @@
+--- Makefile.orig Wed Aug 6 17:33:10 2003
++++ Makefile Wed Aug 6 17:34:04 2003
+@@ -3,8 +3,7 @@
CFLAGS = -DTHREADING -g
INCLUDE = -I/usr/local/include -I.
LIBS = -L/usr/local/lib -lssl -lcrypto
-PYVER = 2.2
-+PYVER = 2.3
- PYINCLUDE = -DHAVE_CONFIG_H -I/usr/local/include/python$(PYVER) \
+-PYINCLUDE = -DHAVE_CONFIG_H -I/usr/local/include/python$(PYVER) \
++PYINCLUDE = -DHAVE_CONFIG_H -I/usr/local/include/PYTHON_VERSION \
-I/usr/local/lib/python$(PYVER)/config
PYLIB = /usr/local/lib/python$(PYVER)/config
+