aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-10-10 15:26:28 +0800
committerkrion <krion@FreeBSD.org>2003-10-10 15:26:28 +0800
commit4ff16e192e1dece4a9fbc322e32ed69d06d9fd93 (patch)
treee91ca89a466d30dbf0a2481b5263a246fd81d8a1 /security
parent1125d864d2aaa91859a3e3c35f7bb15f5d413bc9 (diff)
downloadfreebsd-ports-gnome-4ff16e192e1dece4a9fbc322e32ed69d06d9fd93.tar.gz
freebsd-ports-gnome-4ff16e192e1dece4a9fbc322e32ed69d06d9fd93.tar.zst
freebsd-ports-gnome-4ff16e192e1dece4a9fbc322e32ed69d06d9fd93.zip
- Add patch to fix a build problem with NOINET6 defined.
- Bump PORTREVISION PR: 57812 Submitted by: maintainer
Diffstat (limited to 'security')
-rw-r--r--security/pf/Makefile1
-rw-r--r--security/pf/files/patch-ac14
2 files changed, 15 insertions, 0 deletions
diff --git a/security/pf/Makefile b/security/pf/Makefile
index cf2b6ac8bfdc..09f7b54eac21 100644
--- a/security/pf/Makefile
+++ b/security/pf/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pf_freebsd
PORTVERSION= 1.66
+PORTREVISION= 1
CATEGORIES= security ipv6
MASTER_SITES= http://pf4freebsd.love2party.net/
.if defined(WITH_ALTQ) && (${WITH_ALTQ} == "yes")
diff --git a/security/pf/files/patch-ac b/security/pf/files/patch-ac
new file mode 100644
index 000000000000..419153765ace
--- /dev/null
+++ b/security/pf/files/patch-ac
@@ -0,0 +1,14 @@
+--- freebsd_tcpdump/print-tcp.c.orig Thu Oct 9 19:55:02 2003
++++ freebsd_tcpdump/print-tcp.c Thu Oct 9 19:56:28 2003
+@@ -406,7 +406,11 @@
+ }
+
+ /* OS Fingerprint */
++#ifdef INET6
+ if (oflag && ip6 == NULL && (flags & (TH_SYN|TH_ACK)) == TH_SYN) {
++#else
++ if (oflag && (flags & (TH_SYN|TH_ACK)) == TH_SYN) {
++#endif
+ struct pf_osfp_enlist *head = NULL;
+ struct pf_osfp_entry *fp;
+ unsigned long left;