aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2008-01-17 21:17:25 +0800
committerale <ale@FreeBSD.org>2008-01-17 21:17:25 +0800
commit5436fa077dfbf5484423d613d68cd9901a7c218b (patch)
treed7750fa9b99e5b7b22b96be5921193a5830fa7c3 /security
parentf0602def70dc74896815aaab91be37f6a880387a (diff)
downloadfreebsd-ports-gnome-5436fa077dfbf5484423d613d68cd9901a7c218b.tar.gz
freebsd-ports-gnome-5436fa077dfbf5484423d613d68cd9901a7c218b.tar.zst
freebsd-ports-gnome-5436fa077dfbf5484423d613d68cd9901a7c218b.zip
CKA_CERTIFICATE_TYPE value is CK_ULONG.
This fixes storing certificates on 64-bit platforms.
Diffstat (limited to 'security')
-rw-r--r--security/opensc/Makefile1
-rw-r--r--security/opensc/files/patch-src_pkcs11_misc.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/security/opensc/Makefile b/security/opensc/Makefile
index 48457bf6dbb3..794d12689673 100644
--- a/security/opensc/Makefile
+++ b/security/opensc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= opensc
DISTVERSION= 0.11.4
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= http://www.opensc-project.org/files/${PORTNAME}/ \
http://www.opensc-project.org/files/${PORTNAME}/testing/
diff --git a/security/opensc/files/patch-src_pkcs11_misc.c b/security/opensc/files/patch-src_pkcs11_misc.c
new file mode 100644
index 000000000000..e849213c9929
--- /dev/null
+++ b/security/opensc/files/patch-src_pkcs11_misc.c
@@ -0,0 +1,11 @@
+--- src/pkcs11/misc.c.orig 2008-01-17 12:22:03.000000000 +0100
++++ src/pkcs11/misc.c 2008-01-17 12:22:18.000000000 +0100
+@@ -233,7 +233,7 @@
+ case CKA_PRIVATE:
+ size = sizeof(CK_BBOOL); break;
+ case CKA_CERTIFICATE_TYPE:
+- size = sizeof(CKA_CERTIFICATE_TYPE); break;
++ size = sizeof(CK_ULONG); break;
+ case CKA_MODULUS_BITS:
+ size = sizeof(CK_ULONG); break;
+ case CKA_OBJECT_ID: