aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-12-15 21:37:30 +0800
committerpav <pav@FreeBSD.org>2007-12-15 21:37:30 +0800
commit558738be4a7fe52b7284bed1b8f1a4c2938a5bad (patch)
treed8c47a1d174c710f335a54c329449e84d9be0898 /security
parentcc8bc47bca47e02a0fb6d9aec1cb42eff0696b60 (diff)
downloadfreebsd-ports-gnome-558738be4a7fe52b7284bed1b8f1a4c2938a5bad.tar.gz
freebsd-ports-gnome-558738be4a7fe52b7284bed1b8f1a4c2938a5bad.tar.zst
freebsd-ports-gnome-558738be4a7fe52b7284bed1b8f1a4c2938a5bad.zip
- List QT components
- Try if it builds now PR: ports/117658 Submitted by: Mark D. Foster <mark@foster.cc> (maintainer)
Diffstat (limited to 'security')
-rw-r--r--security/xca/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/security/xca/Makefile b/security/xca/Makefile
index 7580a419f7d9..9a1502786fe0 100644
--- a/security/xca/Makefile
+++ b/security/xca/Makefile
@@ -14,11 +14,10 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= mark@foster.cc
COMMENT= Graphical certification authority
-BROKEN= Does not compile
-
USE_GMAKE= yes
USE_OPENSSL= yes
USE_QT_VER= 4
+QT_COMPONENTS= gui moc uic qmake rcc linguist
CC?= gcc
CXX?= g++
@@ -28,7 +27,7 @@ MANCOMPRESSED= yes
.include <bsd.port.pre.mk>
post-patch:
- @echo "CPPFLAGS=-I. -I.. -I${WRKSRC}/ui -I/usr/X11R6/include -I${QT_PREFIX}/include/Qt" > ${WRKSRC}/Local.mak
+ @echo "CPPFLAGS=-I. -I.. -I${WRKSRC}/ui -I${LOCALBASE}/include -I${QT_PREFIX}/include/Qt" > ${WRKSRC}/Local.mak
@echo "CFLAGS= ${CFLAGS} -Wall -ggdb" >> ${WRKSRC}/Local.mak
@echo "LDFLAGS= ${LDFLAGS} -L${LOCALBASE}/lib" >> ${WRKSRC}/Local.mak
@echo "LIBS= -lQtGui -lc_r -lcrypto" >> ${WRKSRC}/Local.mak