aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-07-08 18:57:08 +0800
committerpawel <pawel@FreeBSD.org>2014-07-08 18:57:08 +0800
commit64a1ff10c9980ef95fe8d8ad6a62d3179d238462 (patch)
treed109529b1dd5ddb806cd267c3b23b0426a57a2e3 /security
parent767da5c9abcef9de80125e6f20d6837ca4beb6ca (diff)
downloadfreebsd-ports-gnome-64a1ff10c9980ef95fe8d8ad6a62d3179d238462.tar.gz
freebsd-ports-gnome-64a1ff10c9980ef95fe8d8ad6a62d3179d238462.tar.zst
freebsd-ports-gnome-64a1ff10c9980ef95fe8d8ad6a62d3179d238462.zip
- Add staging support
- Convert to new options framework - Port uses GNU configure
Diffstat (limited to 'security')
-rw-r--r--security/dmitry/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/security/dmitry/Makefile b/security/dmitry/Makefile
index 6aaf2b2ebc06..69ab6ab250e1 100644
--- a/security/dmitry/Makefile
+++ b/security/dmitry/Makefile
@@ -8,22 +8,19 @@ MASTER_SITES= ${MASTER_SITE_PACKETSTORM}
MASTER_SITE_SUBDIR= UNIX/misc
DISTNAME= DMitry-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Deepmagic Information Gathering Tool
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
-PLIST_FILES= bin/dmitry
-
-MAN1= dmitry.1
+PLIST_FILES= bin/dmitry man/man1/dmitry.1.gz
PORTDOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>