aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-03-04 00:08:11 +0800
committerpav <pav@FreeBSD.org>2004-03-04 00:08:11 +0800
commit72d3c033a2ba4c9e16a01158ae819eede21b96fa (patch)
treeeaa2ff1bc1459c797628d4733dfdcf57c2b91ce6 /security
parent8509ab059e3b93493b18d82c67b72eabc65ec140 (diff)
downloadfreebsd-ports-gnome-72d3c033a2ba4c9e16a01158ae819eede21b96fa.tar.gz
freebsd-ports-gnome-72d3c033a2ba4c9e16a01158ae819eede21b96fa.tar.zst
freebsd-ports-gnome-72d3c033a2ba4c9e16a01158ae819eede21b96fa.zip
Add fpc-md5, a Free Pascal module with MD5 hash routines.
PR: ports/62593 Submitted by: John Merryweather Cooper <coop9211@uidaho.edu>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/fpc-hash/Makefile46
-rw-r--r--security/fpc-hash/distinfo2
-rw-r--r--security/fpc-hash/pkg-descr8
-rw-r--r--security/fpc-hash/pkg-plist4
-rw-r--r--security/fpc-md5/Makefile46
-rw-r--r--security/fpc-md5/distinfo2
-rw-r--r--security/fpc-md5/pkg-descr8
-rw-r--r--security/fpc-md5/pkg-plist4
9 files changed, 121 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 8190689f4c83..b761253f7b94 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -80,6 +80,7 @@
SUBDIR += finger_mysql
SUBDIR += firewalk
SUBDIR += flawfinder
+ SUBDIR += fpc-md5
SUBDIR += fpm
SUBDIR += fragroute
SUBDIR += fragrouter
diff --git a/security/fpc-hash/Makefile b/security/fpc-hash/Makefile
new file mode 100644
index 000000000000..b18d4567fc33
--- /dev/null
+++ b/security/fpc-hash/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: fpc-md5
+# Date created: 8 February 2004
+# Whom: John Merryweather Cooper
+#
+# $FreeBSD$
+#
+
+PORTNAME= md5
+PORTVERSION= 1.0.10
+CATEGORIES= security lang
+MASTER_SITES= http://www.borgsdemons.com/distfiles/
+PKGNAMEPREFIX= fpc-
+
+MAINTAINER= coop9211@uidaho.edu
+COMMENT= Free Pascal unit for MD5 hash routines
+
+BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+ONLY_FOR_ARCHS= i386
+
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
+
+MAKE_ENV+= PATH=${LOCALBASE}/bin:$$PATH \
+ FPC=${LOCALBASE}/bin/ppc386 \
+ INSTALL_BASEDIR=${PREFIX}/lib/fpc/${PORTVERSION} \
+ INSTALL_BINDIR=${PREFIX}/bin \
+ GCCLIBDIR=/usr/lib \
+ RELEASE=1
+
+post-patch:
+# change to alter amount of optimization
+ @${FIND} ${WRKDIR}/packages/base/md5 -name "Makefile*" | \
+ ${XARGS} ${REINPLACE_CMD} 's|-OG2p3|-OG2p1|g'
+
+do-build:
+ @${SETENV} ${MAKE_ENV} ${GMAKE} -C \
+ ${WRKDIR}/packages/base/md5 all
+
+do-install:
+ @${SETENV} ${MAKE_ENV} ${GMAKE} -C \
+ ${WRKDIR}/packages/base/md5 install
+
+.include <bsd.port.mk>
diff --git a/security/fpc-hash/distinfo b/security/fpc-hash/distinfo
new file mode 100644
index 000000000000..63335e3a52a3
--- /dev/null
+++ b/security/fpc-hash/distinfo
@@ -0,0 +1,2 @@
+MD5 (md5-1.0.10.tar.gz) = 45a5474d459a8bc481749f276566f0e5
+SIZE (md5-1.0.10.tar.gz) = 10675
diff --git a/security/fpc-hash/pkg-descr b/security/fpc-hash/pkg-descr
new file mode 100644
index 000000000000..e1e2b8a7b5a9
--- /dev/null
+++ b/security/fpc-hash/pkg-descr
@@ -0,0 +1,8 @@
+The md5 unit is part of the base packages for Free Pascal,
+a 32-bit Turbo Pascal/Delphi compatible compiler. This unit
+provides MD5 hash routines.
+
+WWW: http://www.freepascal.org/
+
+--
+John Merryweather Cooper <coop9211@uidaho.edu>
diff --git a/security/fpc-hash/pkg-plist b/security/fpc-hash/pkg-plist
new file mode 100644
index 000000000000..b37dc5e394e6
--- /dev/null
+++ b/security/fpc-hash/pkg-plist
@@ -0,0 +1,4 @@
+lib/fpc/%%PORTVERSION%%/units/freebsd/md5/Package.fpc
+lib/fpc/%%PORTVERSION%%/units/freebsd/md5/md5.o
+lib/fpc/%%PORTVERSION%%/units/freebsd/md5/md5.ppu
+@dirrm lib/fpc/%%PORTVERSION%%/units/freebsd/md5
diff --git a/security/fpc-md5/Makefile b/security/fpc-md5/Makefile
new file mode 100644
index 000000000000..b18d4567fc33
--- /dev/null
+++ b/security/fpc-md5/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: fpc-md5
+# Date created: 8 February 2004
+# Whom: John Merryweather Cooper
+#
+# $FreeBSD$
+#
+
+PORTNAME= md5
+PORTVERSION= 1.0.10
+CATEGORIES= security lang
+MASTER_SITES= http://www.borgsdemons.com/distfiles/
+PKGNAMEPREFIX= fpc-
+
+MAINTAINER= coop9211@uidaho.edu
+COMMENT= Free Pascal unit for MD5 hash routines
+
+BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+ONLY_FOR_ARCHS= i386
+
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
+
+MAKE_ENV+= PATH=${LOCALBASE}/bin:$$PATH \
+ FPC=${LOCALBASE}/bin/ppc386 \
+ INSTALL_BASEDIR=${PREFIX}/lib/fpc/${PORTVERSION} \
+ INSTALL_BINDIR=${PREFIX}/bin \
+ GCCLIBDIR=/usr/lib \
+ RELEASE=1
+
+post-patch:
+# change to alter amount of optimization
+ @${FIND} ${WRKDIR}/packages/base/md5 -name "Makefile*" | \
+ ${XARGS} ${REINPLACE_CMD} 's|-OG2p3|-OG2p1|g'
+
+do-build:
+ @${SETENV} ${MAKE_ENV} ${GMAKE} -C \
+ ${WRKDIR}/packages/base/md5 all
+
+do-install:
+ @${SETENV} ${MAKE_ENV} ${GMAKE} -C \
+ ${WRKDIR}/packages/base/md5 install
+
+.include <bsd.port.mk>
diff --git a/security/fpc-md5/distinfo b/security/fpc-md5/distinfo
new file mode 100644
index 000000000000..63335e3a52a3
--- /dev/null
+++ b/security/fpc-md5/distinfo
@@ -0,0 +1,2 @@
+MD5 (md5-1.0.10.tar.gz) = 45a5474d459a8bc481749f276566f0e5
+SIZE (md5-1.0.10.tar.gz) = 10675
diff --git a/security/fpc-md5/pkg-descr b/security/fpc-md5/pkg-descr
new file mode 100644
index 000000000000..e1e2b8a7b5a9
--- /dev/null
+++ b/security/fpc-md5/pkg-descr
@@ -0,0 +1,8 @@
+The md5 unit is part of the base packages for Free Pascal,
+a 32-bit Turbo Pascal/Delphi compatible compiler. This unit
+provides MD5 hash routines.
+
+WWW: http://www.freepascal.org/
+
+--
+John Merryweather Cooper <coop9211@uidaho.edu>
diff --git a/security/fpc-md5/pkg-plist b/security/fpc-md5/pkg-plist
new file mode 100644
index 000000000000..b37dc5e394e6
--- /dev/null
+++ b/security/fpc-md5/pkg-plist
@@ -0,0 +1,4 @@
+lib/fpc/%%PORTVERSION%%/units/freebsd/md5/Package.fpc
+lib/fpc/%%PORTVERSION%%/units/freebsd/md5/md5.o
+lib/fpc/%%PORTVERSION%%/units/freebsd/md5/md5.ppu
+@dirrm lib/fpc/%%PORTVERSION%%/units/freebsd/md5