aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2007-02-02 21:57:29 +0800
committergabor <gabor@FreeBSD.org>2007-02-02 21:57:29 +0800
commit7961e4a82fc28b5f07999c5536e50a7131472b3c (patch)
tree3a0ecaf30010f6457356639a417283e82df6e25a /security
parent3e3ba1e60ca3af246725d6f0e1277304b81376c4 (diff)
downloadfreebsd-ports-gnome-7961e4a82fc28b5f07999c5536e50a7131472b3c.tar.gz
freebsd-ports-gnome-7961e4a82fc28b5f07999c5536e50a7131472b3c.tar.zst
freebsd-ports-gnome-7961e4a82fc28b5f07999c5536e50a7131472b3c.zip
This module Uses OpenSSL to encrypt using the
AES, Blowfish, Cast5, IDEA and DES cyphers. WWW: http://www.aolserver.com/ - Martin Matuska martin@matuska.org PR: ports/105781 Submitted by: Martin Matuska <martin@matuska.org> Approved by: erwin (mentor)
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/aolserver-nsencrypt/Makefile43
-rw-r--r--security/aolserver-nsencrypt/distinfo3
-rw-r--r--security/aolserver-nsencrypt/pkg-descr7
-rw-r--r--security/aolserver-nsencrypt/pkg-plist3
5 files changed, 57 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 3f218cdfe51a..3ee9bddd9ef6 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -18,6 +18,7 @@
SUBDIR += amavisd
SUBDIR += amavisd-milter
SUBDIR += amavisd-new
+ SUBDIR += aolserver-nsencrypt
SUBDIR += apg
SUBDIR += arirang
SUBDIR += audit
diff --git a/security/aolserver-nsencrypt/Makefile b/security/aolserver-nsencrypt/Makefile
new file mode 100644
index 000000000000..4f8209f428e8
--- /dev/null
+++ b/security/aolserver-nsencrypt/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: aolserver-nsencrypt
+# Date created: 12 Oct 2006
+# Whom: Martin Matuska <martin@matuska.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aolserver-nsencrypt
+PORTVERSION= 0.4
+CATEGORIES= security www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= aolserver
+DISTFILES= nsencrypt-${PORTVERSION}-src.tar.gz
+DIST_SUBDIR= aolserver
+
+MAINTAINER= martin@matuska.org
+COMMENT= OpenSSL data encryption module for AOLserver
+
+WRKSRC= ${WRKDIR}/nsencrypt-${PORTVERSION}
+
+AOLSERVERBASE?= ${PREFIX}/aolserver
+BUILD_DEPENDS+= ${AOLSERVERBASE}/bin/nsd:${PORTSDIR}/www/aolserver
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+PLIST_SUB+= AOLSERVERBASE=${AOLSERVERBASE:S/${PREFIX}\///}
+
+USE_OPENSSL= yes
+USE_GMAKE= yes
+
+MAKE_ARGS= AOLSERVER=${AOLSERVERBASE} OPENSSL=${OPENSSLBASE}
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= ChangeLog readme.txt
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${DOCSDIR}
+.for FILE in ${PORTDOCS}
+ @ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/aolserver-nsencrypt/distinfo b/security/aolserver-nsencrypt/distinfo
new file mode 100644
index 000000000000..3015650d25cf
--- /dev/null
+++ b/security/aolserver-nsencrypt/distinfo
@@ -0,0 +1,3 @@
+MD5 (aolserver/nsencrypt-0.4-src.tar.gz) = 458db61ac61ab716cc6ceb06a2712dd1
+SHA256 (aolserver/nsencrypt-0.4-src.tar.gz) = 6565d8e73963ca6dc1446176a67dbd864ba31b2697102dd2e27a6fc56a393442
+SIZE (aolserver/nsencrypt-0.4-src.tar.gz) = 7163
diff --git a/security/aolserver-nsencrypt/pkg-descr b/security/aolserver-nsencrypt/pkg-descr
new file mode 100644
index 000000000000..8e91c0f7b13e
--- /dev/null
+++ b/security/aolserver-nsencrypt/pkg-descr
@@ -0,0 +1,7 @@
+This module Uses OpenSSL to encrypt using the
+AES, Blowfish, Cast5, IDEA and DES cyphers.
+
+WWW: http://www.aolserver.com/
+
+- Martin Matuska
+martin@matuska.org
diff --git a/security/aolserver-nsencrypt/pkg-plist b/security/aolserver-nsencrypt/pkg-plist
new file mode 100644
index 000000000000..ba4ce9d6dc8f
--- /dev/null
+++ b/security/aolserver-nsencrypt/pkg-plist
@@ -0,0 +1,3 @@
+%%AOLSERVERBASE%%/bin/nsencrypt.so
+%%AOLSERVERBASE%%/lib/libnsencrypt.a
+%%AOLSERVERBASE%%/lib/libnsencrypt.so