aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorbrnrd <brnrd@FreeBSD.org>2016-04-18 03:19:09 +0800
committerbrnrd <brnrd@FreeBSD.org>2016-04-18 03:19:09 +0800
commit80674840a07fb5dd89aab416ea746e693104dd7c (patch)
treed0b528a20b466e8a94d0e392688bd6debc0dbe25 /security
parent21ea86f41d23796e17071caeaece5f143bfb27b2 (diff)
downloadfreebsd-ports-gnome-80674840a07fb5dd89aab416ea746e693104dd7c.tar.gz
freebsd-ports-gnome-80674840a07fb5dd89aab416ea746e693104dd7c.tar.zst
freebsd-ports-gnome-80674840a07fb5dd89aab416ea746e693104dd7c.zip
security/py-cryptography: Update to 1.3.1
- Update to latest version 1.3.1 - Remove patch now included upstream - Add patch to allow build without openssl/e_os.h in base Reviewed by: koobs (mentor, python), feld (mentor) Approved by: feld (mentor) Differential Revision: D5959
Diffstat (limited to 'security')
-rw-r--r--security/py-cryptography/Makefile3
-rw-r--r--security/py-cryptography/distinfo4
-rw-r--r--security/py-cryptography/files/patch-64c9d89331
-rw-r--r--security/py-cryptography/files/patch-src___cffi__src_build__openssl.py32
4 files changed, 35 insertions, 35 deletions
diff --git a/security/py-cryptography/Makefile b/security/py-cryptography/Makefile
index 6bfa1cd7d987..0847622c2f12 100644
--- a/security/py-cryptography/Makefile
+++ b/security/py-cryptography/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= cryptography
-PORTVERSION= 1.0.2
-PORTREVISION= 4
+PORTVERSION= 1.3.1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/security/py-cryptography/distinfo b/security/py-cryptography/distinfo
index fe6401d114e7..7efae487da7d 100644
--- a/security/py-cryptography/distinfo
+++ b/security/py-cryptography/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cryptography-1.0.2.tar.gz) = d64cd491e91ddf642c643bea16532c2a2da2da054cca6df756edadd55a8bacca
-SIZE (cryptography-1.0.2.tar.gz) = 332870
+SHA256 (cryptography-1.3.1.tar.gz) = b4b36175e0f95ddc88435c26dbe3397edce48e2ff5fe41d504cdb3beddcd53e2
+SIZE (cryptography-1.3.1.tar.gz) = 383852
diff --git a/security/py-cryptography/files/patch-64c9d893 b/security/py-cryptography/files/patch-64c9d893
deleted file mode 100644
index f9ec88a3ecfe..000000000000
--- a/security/py-cryptography/files/patch-64c9d893
+++ /dev/null
@@ -1,31 +0,0 @@
-From 64c9d893c3748e962d01a935625c58610826f23c Mon Sep 17 00:00:00 2001
-From: Paul Kehrer <paul.l.kehrer@gmail.com>
-Date: Tue, 1 Mar 2016 14:22:32 -0600
-Subject: [PATCH] move BIO_new_mem_buf to macros to handle 1.0.2g signature
- change
-
----
- src/_cffi_src/openssl/bio.py | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/src/_cffi_src/openssl/bio.py b/src/_cffi_src/openssl/bio.py
-index ac86683..6439e63 100644
---- src/_cffi_src/openssl/bio.py
-+++ src/_cffi_src/openssl/bio.py
-@@ -99,7 +99,6 @@
- BIO *BIO_next(BIO *);
- BIO *BIO_find_type(BIO *, int);
- BIO_METHOD *BIO_s_mem(void);
--BIO *BIO_new_mem_buf(void *, int);
- BIO_METHOD *BIO_s_file(void);
- BIO *BIO_new_file(const char *, const char *);
- BIO *BIO_new_fp(FILE *, int);
-@@ -127,6 +126,8 @@
- """
-
- MACROS = """
-+/* BIO_new_mem_buf became const void * in 1.0.2g */
-+BIO *BIO_new_mem_buf(void *, int);
- long BIO_set_fd(BIO *, long, int);
- long BIO_get_fd(BIO *, char *);
- long BIO_set_mem_eof_return(BIO *, int);
diff --git a/security/py-cryptography/files/patch-src___cffi__src_build__openssl.py b/security/py-cryptography/files/patch-src___cffi__src_build__openssl.py
new file mode 100644
index 000000000000..121180e065fe
--- /dev/null
+++ b/security/py-cryptography/files/patch-src___cffi__src_build__openssl.py
@@ -0,0 +1,32 @@
+Use upstream post-1.3.1 patch for LibreSSL
+
+From 1e88d741f6e15d9170466a08dfe85f28b12c7623 Mon Sep 17 00:00:00 2001
+From: Paul Kehrer <paul.l.kehrer@gmail.com>
+Date: Mon, 28 Mar 2016 22:00:00 -0400
+Subject: [PATCH] fix libressl breakage reported in #2858
+
+---
+ src/_cffi_src/build_openssl.py | 9 ++++++++-
+ 1 file changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/src/_cffi_src/build_openssl.py b/src/_cffi_src/build_openssl.py
+index 2ff28d7..3f92529 100644
+--- src/_cffi_src/build_openssl.py.orig
++++ src/_cffi_src/build_openssl.py
+@@ -38,8 +38,15 @@ def _osx_libraries(build_static):
+
+
+ _PRE_INCLUDE = """
++#include <openssl/opensslv.h>
++/*
++ LibreSSL removed e_os2.h from the public headers so we'll only include it
++ if we're using vanilla OpenSSL.
++*/
++#if !defined(LIBRESSL_VERSION_NUMBER)
+ #include <openssl/e_os2.h>
+-#if defined(OPENSSL_SYS_WINDOWS)
++#endif
++#if defined(OPENSSL_SYS_WINDOWS) || defined(_WIN32)
+ #include <windows.h>
+ #endif
+ """