aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authortdb <tdb@FreeBSD.org>2005-12-04 03:30:14 +0800
committertdb <tdb@FreeBSD.org>2005-12-04 03:30:14 +0800
commit84f746223998da21992f460aa6be2efbfba85ff6 (patch)
tree74dee263ac56a7088367427ef38e281f98aa2a83 /security
parent70842b7b683c7dd61695aa9b24e19d0a8b46b200 (diff)
downloadfreebsd-ports-gnome-84f746223998da21992f460aa6be2efbfba85ff6.tar.gz
freebsd-ports-gnome-84f746223998da21992f460aa6be2efbfba85ff6.tar.zst
freebsd-ports-gnome-84f746223998da21992f460aa6be2efbfba85ff6.zip
- Update to 1.08
PR: 89861 Submitted by: Wesley Shields <wxs@csh.rit.edu> (maintainer) Approved by: clement (mentor)
Diffstat (limited to 'security')
-rw-r--r--security/libtomcrypt/Makefile18
-rw-r--r--security/libtomcrypt/distinfo7
-rw-r--r--security/libtomcrypt/files/patch-makefile31
3 files changed, 27 insertions, 29 deletions
diff --git a/security/libtomcrypt/Makefile b/security/libtomcrypt/Makefile
index d6222e9c361d..e19158e51657 100644
--- a/security/libtomcrypt/Makefile
+++ b/security/libtomcrypt/Makefile
@@ -6,14 +6,11 @@
#
PORTNAME= libtomcrypt
-PORTVERSION= 1.06
+PORTVERSION= 1.08
CATEGORIES= security
MASTER_SITES= http://libtomcrypt.org/files/
DISTNAME= crypt-${PORTVERSION}
-PATCH_SITES= http://www.libtomcrypt.org/files/patch-1.06/
-PATCHFILES= makefile.diff
-
MAINTAINER= wxs@csh.rit.edu
COMMENT= Comprehensive, modular and portable cryptographic toolkit
@@ -52,12 +49,19 @@ CFLAGS+= -DTFM_DESC
BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX
.else
NOPORTDOCS= yes
-INSTALL_TARGET= install_lib
+MAKE_ARGS+= NODOCS=yes
.endif
.if defined(MAINTAINER_MODE)
test: build
- (cd ${WRKSRC} && ${GMAKE} test && ${WRKSRC}/test)
-.endif
+ @${ECHO_MSG} "Testing with -DUSE_TFM..."
+ (cd ${WRKSRC} && CFLAGS="${CFLAGS} -DUSE_TFM" EXTRALIBS="-L${PREFIX}/lib -ltfm" ${GMAKE} test && ${WRKSRC}/test)
+ @${ECHO_MSG} "Cleaning up test binary..."
+ @${RM} ${WRKSRC}/test
+ @${RM} ${WRKSRC}/demos/test.o
+
+ @${ECHO_MSG} "Testing with -DUSE_LTM..."
+ (cd ${WRKSRC} && CFLAGS="${CFLAGS} -DUSE_LTM" EXTRALIBS="-L${PREFIX}/lib -ltommath" ${GMAKE} test && ${WRKSRC}/test)
+.endif
.include <bsd.port.post.mk>
diff --git a/security/libtomcrypt/distinfo b/security/libtomcrypt/distinfo
index 3571f3dd934f..c14344a82c36 100644
--- a/security/libtomcrypt/distinfo
+++ b/security/libtomcrypt/distinfo
@@ -1,4 +1,3 @@
-MD5 (crypt-1.06.tar.bz2) = f7b5fd2a5d4b2917576da7885f27e4a0
-SIZE (crypt-1.06.tar.bz2) = 1160330
-MD5 (makefile.diff) = 76b18782400494589c35e12e6cdd081d
-SIZE (makefile.diff) = 1372
+MD5 (crypt-1.08.tar.bz2) = 3cce06f48b4ae59f0e287d21fb2d2a54
+SHA256 (crypt-1.08.tar.bz2) = e972295b49f89ddf6e5d3e12295048aece888ba421924289be14abadeac54119
+SIZE (crypt-1.08.tar.bz2) = 1192803
diff --git a/security/libtomcrypt/files/patch-makefile b/security/libtomcrypt/files/patch-makefile
index de4f9b53d746..b9473b735fa6 100644
--- a/security/libtomcrypt/files/patch-makefile
+++ b/security/libtomcrypt/files/patch-makefile
@@ -1,15 +1,15 @@
---- makefile.orig Thu Aug 18 13:07:13 2005
-+++ makefile Thu Aug 18 13:10:14 2005
-@@ -15,7 +15,7 @@
- #ARFLAGS=r
+--- makefile.orig Thu Nov 24 12:55:28 2005
++++ makefile Fri Dec 2 22:38:47 2005
+@@ -24,7 +24,7 @@
+ endif
# Compilation flags. Note the += does not write over the user's CFLAGS!
-CFLAGS += -c -I./testprof/ -I./src/headers/ -Wall -Wsign-compare -W -Wshadow -Wno-unused-parameter -DLTC_SOURCE
+CFLAGS += -c -I./testprof/ -I./src/headers/ -Wall -Wsign-compare -W -Wshadow -DLTC_SOURCE
# additional warnings (newer GCC 3.4 and higher)
- #CFLAGS += -Wsystem-headers -Wdeclaration-after-statement -Wbad-function-cast -Wcast-align -Wstrict-prototypes -Wmissing-prototypes \
-@@ -24,10 +24,10 @@
+ ifdef GCC_34
+@@ -35,10 +35,10 @@
ifndef IGNORE_SPEED
# optimize for SPEED
@@ -22,26 +22,21 @@
# optimize for SIZE
#CFLAGS += -Os -DLTC_SMALL_CODE
-@@ -249,10 +249,16 @@
- install: library docs
+@@ -275,11 +275,11 @@
+ endif
install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(LIBPATH)
install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(INCPATH)
- install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(DATAPATH)
-+ install -d -g $(GROUP) -o $(USER) $(DATAPATH)
-+ install -g $(GROUP) -o $(USER) $(LIBNAME) $(DESTDIR)$(LIBPATH)
-+ install -g $(GROUP) -o $(USER) $(HEADERS) $(DESTDIR)$(INCPATH)
-+ install -g $(GROUP) -o $(USER) doc/crypt.pdf $(DATAPATH)
-+
-+install_lib: library
-+ install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(LIBPATH)
-+ install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(INCPATH)
install -g $(GROUP) -o $(USER) $(LIBNAME) $(DESTDIR)$(LIBPATH)
install -g $(GROUP) -o $(USER) $(HEADERS) $(DESTDIR)$(INCPATH)
+ ifndef NODOCS
- install -g $(GROUP) -o $(USER) doc/crypt.pdf $(DESTDIR)$(DATAPATH)
++ install -d -g $(GROUP) -o $(USER) $(DATAPATH)
++ install -g $(GROUP) -o $(USER) doc/crypt.pdf $(DATAPATH)
+ endif
install_test: testprof/$(LIBTEST)
- install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(LIBPATH)
-@@ -305,7 +311,7 @@
+@@ -333,7 +333,7 @@
latex crypt > /dev/null
makeindex crypt.idx > /dev/null
latex crypt > /dev/null