aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-07-26 13:40:22 +0800
committerbapt <bapt@FreeBSD.org>2012-07-26 13:40:22 +0800
commit8a3f534c898f1045896626964b7f3e3e406f946b (patch)
tree73bea5baa559b61c5e812c50ac96fad638950c75 /security
parentccde37a9b75ee6a15ed85af7d0f2e60c16c42192 (diff)
downloadfreebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.tar.gz
freebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.tar.zst
freebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.zip
new devel/pkgconf added to replace devel/pkg-config. new version of pkg-config
are no more self hosting so we are stuck with 0.25 version while pkgconf provide the same set of features as 0.27 and a compatible frontend. A symlink to pkg-config has been added for convenience and compatibility This also introduces a new macro to use pkgconf in your ports: USE_PKGCONFIG it can take the following arguments: - yes (meaning build only dep) - build (meaning build only dep) - run (meaning run only dep) - both (meaning run and build dep) From now USE_GNOME= pkgconfig is deprecated in favour of USE_PKGCONFIG The old gnome macro has been modified to use pkgconf but still the sameway: run and build dep to avoid large breakage. While here fix some ports relying on pkg-config but not specifying it, fix some ports broken because testing wrong .pc files, and fix ports using pkg-config --version to determine pkg-config version instead of pkg-config --modversion pkg-config like recommanded by pkg-config With Hat: portmgr Exp-runs by: bapt (pointhat-west), beat (pointyhat)
Diffstat (limited to 'security')
-rw-r--r--security/libotr/Makefile2
-rw-r--r--security/openvas-libraries/Makefile2
-rw-r--r--security/suricata/Makefile4
-rw-r--r--security/trousers/Makefile3
-rw-r--r--security/xmlsec1/Makefile2
5 files changed, 6 insertions, 7 deletions
diff --git a/security/libotr/Makefile b/security/libotr/Makefile
index d53a8f6f6abd..8383609285e2 100644
--- a/security/libotr/Makefile
+++ b/security/libotr/Makefile
@@ -20,7 +20,6 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= dougb@FreeBSD.org
COMMENT= The portable OTR Messaging Library and toolkit
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= gpg-error.0:${PORTSDIR}/security/libgpg-error \
gcrypt:${PORTSDIR}/security/libgcrypt
@@ -28,6 +27,7 @@ MAKE_JOBS_SAFE= yes
USE_AUTOTOOLS= autoconf libtool
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
MAN1= otr_toolkit.1
MLINKS= otr_toolkit.1 otr_parse.1 \
diff --git a/security/openvas-libraries/Makefile b/security/openvas-libraries/Makefile
index b38fce32a9a3..878096443a1f 100644
--- a/security/openvas-libraries/Makefile
+++ b/security/openvas-libraries/Makefile
@@ -14,12 +14,12 @@ MASTER_SITES= http://wald.intevation.org/frs/download.php/600/
MAINTAINER= ports@FreeBSD.org
COMMENT= Libraries for OpenVAS
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= gnutls.47:${PORTSDIR}/security/gnutls \
gcrypt.18:${PORTSDIR}/security/libgcrypt
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
USE_GNOME= glib20
MAKE_JOBS_UNSAFE= yes
diff --git a/security/suricata/Makefile b/security/suricata/Makefile
index a504d8686554..fe296bafc997 100644
--- a/security/suricata/Makefile
+++ b/security/suricata/Makefile
@@ -21,10 +21,10 @@ LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre \
yaml:${PORTSDIR}/textproc/libyaml \
htp:${PORTSDIR}/devel/libhtp
-BUILD_DEPENDS+= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet \
- pkg-config:${PORTSDIR}/devel/pkg-config
+BUILD_DEPENDS+= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
USE_AUTOTOOLS= automake autoconf libtool
+USE_PKGCONFIG= yes
USE_RC_SUBR= suricata
diff --git a/security/trousers/Makefile b/security/trousers/Makefile
index edfb90a6692c..78e7695920be 100644
--- a/security/trousers/Makefile
+++ b/security/trousers/Makefile
@@ -14,12 +14,11 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
MAINTAINER= nork@FreeBSD.org
COMMENT= The open-source TCG Software Stack
-BUILD_DEPENDS= ${LOCALBASE}/share/aclocal/pkg.m4:${PORTSDIR}/devel/pkg-config
-
USE_GMAKE= YES
USE_ICONV= YES
USE_OPENSSL= YES
USE_LDCONFIG= YES
+USE_PKGCONFIG= YES
USE_AUTOTOOLS= autoconf automake libtool
GNU_CONFIGURE= YES
MAKE_JOBS_SAFE= YES
diff --git a/security/xmlsec1/Makefile b/security/xmlsec1/Makefile
index 14b203122c71..a2105899c504 100644
--- a/security/xmlsec1/Makefile
+++ b/security/xmlsec1/Makefile
@@ -17,7 +17,6 @@ MASTER_SITES= http://www.aleksey.com/xmlsec/download/ \
MAINTAINER= johans@FreeBSD.org
COMMENT= XML Security Library
-RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
BUILD_DEPENDS:= ${RUN_DEPENDS}
OPTIONS_DEFINE= GNUTLS NSS
@@ -28,6 +27,7 @@ USE_OPENSSL= yes
USE_GNOME= gnomehack lthack libxslt
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
MAN1= xmlsec1.1 xmlsec1-config.1
CFLAGS+= -I${LOCALBASE}/include