aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2008-06-04 21:14:01 +0800
committeredwin <edwin@FreeBSD.org>2008-06-04 21:14:01 +0800
commit8b9a42d260550acb41a3942bdfcb8e8e21d6bd1f (patch)
treeede9fcab2139ee33f2986830e05dafe3f210e5ce /security
parent8599d7f95f1b87a8c43f88f8d70eb45e5b34ae9f (diff)
downloadfreebsd-ports-gnome-8b9a42d260550acb41a3942bdfcb8e8e21d6bd1f.tar.gz
freebsd-ports-gnome-8b9a42d260550acb41a3942bdfcb8e8e21d6bd1f.tar.zst
freebsd-ports-gnome-8b9a42d260550acb41a3942bdfcb8e8e21d6bd1f.zip
[NEW PORT] security/openvas-libnasl: NASL libraries for OpenVAS
OpenVAS stands for Open Vulnerability Assessment System and is a network security scanner with associated tools like a graphical user fontend. The core is a server component with a set of network vulnerability tests (NVTs) to detect security problems in remote systems and applications. WWW: http://www.openvas.org/ PR: ports/123129 Submitted by: Tomoyuki Sakurai <cherry@trombik.org>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/openvas-libnasl/Makefile33
-rw-r--r--security/openvas-libnasl/distinfo3
-rw-r--r--security/openvas-libnasl/files/patch-Makefile11
-rw-r--r--security/openvas-libnasl/pkg-descr6
-rw-r--r--security/openvas-libnasl/pkg-plist9
6 files changed, 63 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 8f853d43cdf7..e2f44afd6942 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -314,6 +314,7 @@
SUBDIR += openssl-beta
SUBDIR += openssl-stable
SUBDIR += openvas-client
+ SUBDIR += openvas-libnasl
SUBDIR += openvpn
SUBDIR += openvpn-admin
SUBDIR += openvpn-auth-ldap
diff --git a/security/openvas-libnasl/Makefile b/security/openvas-libnasl/Makefile
new file mode 100644
index 000000000000..a049added2d0
--- /dev/null
+++ b/security/openvas-libnasl/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: openvas-libnasl
+# Date created: 2008-04-27
+# Whom: Tomoyuki Sakurai <cherry@trombik.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openvas-libnasl
+PORTVERSION= 1.0.0
+CATEGORIES= security
+MASTER_SITES= http://wald.intevation.org/frs/download.php/406/
+
+MAINTAINER= cherry@trombik.org
+COMMENT= NASL libraries for OpenVAS
+
+LIB_DEPENDS= gcrypt.15:${PORTSDIR}/security/libgcrypt \
+ gnutls.26:${PORTSDIR}/security/gnutls \
+ gpg-error.0:${PORTSDIR}/security/libgpg-error \
+ gpgme.17:${PORTSDIR}/security/gpgme \
+ openvas.1:${PORTSDIR}/security/openvas-libraries \
+ openvas_hg.1:${PORTSDIR}/security/openvas-libraries \
+ tasn1.3:${PORTSDIR}/security/libtasn1
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_ICONV= yes
+USE_BISON= build
+
+MAN1= openvas-libnasl-config.1 openvas-nasl.1
+
+.include "${.CURDIR}/../../security/openvas-server/Makefile.common"
+
+.include <bsd.port.mk>
diff --git a/security/openvas-libnasl/distinfo b/security/openvas-libnasl/distinfo
new file mode 100644
index 000000000000..7813fd5ac91b
--- /dev/null
+++ b/security/openvas-libnasl/distinfo
@@ -0,0 +1,3 @@
+MD5 (openvas-libnasl-1.0.0.tar.gz) = 786a7e81f0bbcfedf2594ff731f5a7fc
+SHA256 (openvas-libnasl-1.0.0.tar.gz) = 85a70f418aa54b14220bab825897a93fcce7e850ce8d5a5cc5edfb9131089e06
+SIZE (openvas-libnasl-1.0.0.tar.gz) = 416197
diff --git a/security/openvas-libnasl/files/patch-Makefile b/security/openvas-libnasl/files/patch-Makefile
new file mode 100644
index 000000000000..44eb63df5c5f
--- /dev/null
+++ b/security/openvas-libnasl/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2008-04-27 13:27:21.000000000 +0900
++++ Makefile 2008-04-27 13:28:00.000000000 +0900
+@@ -41,7 +41,7 @@
+ $(INSTALL) -c -m 0644 doc/openvas-libnasl-config.1 ${mandir}/man1
+ $(INSTALL) -c -m 0644 doc/openvas-nasl.1 ${mandir}/man1
+ $(INSTALL) -c -m 0644 doc/openvas-libnasl-config.1 ${mandir}/man1
+- test -d ${localstatedir}/openvas || $(INSTALL_DIR) -m 755 ${localstatedir}/openvas
++ test -d ${localstatedir} || $(INSTALL_DIR) -m 755 ${localstatedir}
+
+
+ @echo
diff --git a/security/openvas-libnasl/pkg-descr b/security/openvas-libnasl/pkg-descr
new file mode 100644
index 000000000000..250f4bad0e3d
--- /dev/null
+++ b/security/openvas-libnasl/pkg-descr
@@ -0,0 +1,6 @@
+OpenVAS stands for Open Vulnerability Assessment System and is a network
+security scanner with associated tools like a graphical user fontend. The core
+is a server component with a set of network vulnerability tests (NVTs) to
+detect security problems in remote systems and applications.
+
+WWW: http://www.openvas.org/
diff --git a/security/openvas-libnasl/pkg-plist b/security/openvas-libnasl/pkg-plist
new file mode 100644
index 000000000000..1329aea95082
--- /dev/null
+++ b/security/openvas-libnasl/pkg-plist
@@ -0,0 +1,9 @@
+@comment $FreeBSD$
+bin/openvas-nasl
+bin/openvas-libnasl-config
+lib/libopenvasnasl.so.1
+lib/libopenvasnasl.so
+lib/libopenvasnasl.la
+lib/libopenvasnasl.a
+include/openvas/nasl.h
+@dirrmtry openvas