aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2001-02-27 07:09:21 +0800
committermi <mi@FreeBSD.org>2001-02-27 07:09:21 +0800
commit9ebf45e4b95da11b7a61c387969c06f5b7bdaecc (patch)
treec9af80c3860a38a401603a1db7a582d812af097b /security
parent8e390c547049fec06f53c2e182f5aa744eb76f22 (diff)
downloadfreebsd-ports-gnome-9ebf45e4b95da11b7a61c387969c06f5b7bdaecc.tar.gz
freebsd-ports-gnome-9ebf45e4b95da11b7a61c387969c06f5b7bdaecc.tar.zst
freebsd-ports-gnome-9ebf45e4b95da11b7a61c387969c06f5b7bdaecc.zip
Add pam-pgsql 0.3, a pam module for authenticating with PostgreSQL.
PR: 22876 Submitted by: Mikhail Teterin <mi@aldan.algebra.com>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/pam-pgsql/Makefile40
-rw-r--r--security/pam-pgsql/distinfo1
-rw-r--r--security/pam-pgsql/files/Makefile.bsd16
-rw-r--r--security/pam-pgsql/pkg-comment1
-rw-r--r--security/pam-pgsql/pkg-descr7
-rw-r--r--security/pam-pgsql/pkg-message9
-rw-r--r--security/pam-pgsql/pkg-plist6
8 files changed, 81 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 10194a5ab267..fecbf573b048 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -98,6 +98,7 @@
SUBDIR += p5-PGP-Sign
SUBDIR += pad
SUBDIR += pam-mysql
+ SUBDIR += pam-pgsql
SUBDIR += pam_krb5
SUBDIR += pgp
SUBDIR += pgp5
diff --git a/security/pam-pgsql/Makefile b/security/pam-pgsql/Makefile
new file mode 100644
index 000000000000..3f9f9e040729
--- /dev/null
+++ b/security/pam-pgsql/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: pam-pgsql
+# Date created: Nov 16, 2000
+# Whom: Mikhail Teterin <mi@aldan.algebra.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pam-pgsql
+PORTVERSION= 0.3
+CATEGORIES= security databases
+# When the family of Debian mirrors is added to bsd.port.mk,
+# this will suddenly start making sense:
+MASTER_SITES= http://ftp.debian.org/debian/${MASTER_SITE_SUBDIR}/ \
+ ftp://ftp.bora.net/pub/linux/debian/${MASTER_SITE_SUBDIR}/ \
+ ${MASTER_SITE_DEBIAN}
+MASTER_SITE_SUBDIR= dists/woody/main/source/admin
+DISTFILES= ${PORTNAME}_${PORTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= mi@aldan.algebra.com
+
+LIB_DEPENDS= pq:${PORTSDIR}/databases/postgresql7
+
+MAKEFILE= ${FILESDIR}/Makefile.bsd
+MAKE_ARGS+= -j 2
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/debian/changelog \
+ ${WRKSRC}/debian/copyright ${DOCDIR}
+
+PLIST_SUB+= DOC=''
+DOCDIR= ${LOCALBASE}/share/doc/pam-pgsql
+
+.else
+PLIST_SUB+= DOC='@comment '
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/pam-pgsql/distinfo b/security/pam-pgsql/distinfo
new file mode 100644
index 000000000000..abe6bbb45e44
--- /dev/null
+++ b/security/pam-pgsql/distinfo
@@ -0,0 +1 @@
+MD5 (pam-pgsql_0.3.tar.gz) = c34c18f98690e579da7cf810a3db2a00
diff --git a/security/pam-pgsql/files/Makefile.bsd b/security/pam-pgsql/files/Makefile.bsd
new file mode 100644
index 000000000000..634a5fd3cc67
--- /dev/null
+++ b/security/pam-pgsql/files/Makefile.bsd
@@ -0,0 +1,16 @@
+# This makefile is inspired by those in /usr/src/lib/libpam/modules :-)
+
+SRCS= pam_pgsql.c pam_get_pass.c pam_std_option.c pam_get_service.c
+LIB= pam_pgsql
+SHLIB_NAME=${LIB}.so
+
+LDADD= -lpam -L${LOCALBASE}/pgsql/lib -lpq
+INCLUDE= -I${LOCALBASE}/pgsql/include
+CFLAGS+= -Wall -D_GNU_SOURCE -I/opt/pgsql/include
+
+INTERNALLIB= we don't need no stinking static lib
+
+# Uncomment if you think, the lib should NOT go into /usr/lib directly:
+# LIBDIR= ${LOCALBASE}/lib
+
+.include <bsd.lib.mk>
diff --git a/security/pam-pgsql/pkg-comment b/security/pam-pgsql/pkg-comment
new file mode 100644
index 000000000000..adf0f427e60a
--- /dev/null
+++ b/security/pam-pgsql/pkg-comment
@@ -0,0 +1 @@
+A pam module for authenticating with PostgreSQL
diff --git a/security/pam-pgsql/pkg-descr b/security/pam-pgsql/pkg-descr
new file mode 100644
index 000000000000..528f5f33956a
--- /dev/null
+++ b/security/pam-pgsql/pkg-descr
@@ -0,0 +1,7 @@
+This is a PAM module for authenticating with PostgreSQL.
+
+It also supports:
+ - Checking account information (pam_acct_expired,new_authtok_reqd)
+ - Updating auth token
+
+WWW: http://www.debian.org/Packages/unstable/admin/libpam-pgsql.html
diff --git a/security/pam-pgsql/pkg-message b/security/pam-pgsql/pkg-message
new file mode 100644
index 000000000000..2853d3de3bb5
--- /dev/null
+++ b/security/pam-pgsql/pkg-message
@@ -0,0 +1,9 @@
+
+Follow the instructions in the
+
+ /usr/local/share/doc/pam-pgsql/README
+
+to use this module. Note, that unlike most other ports, this port
+installs a file into /usr/lib directly (/usr/lib/pam_pgsql.so),
+because PAM requires that.
+
diff --git a/security/pam-pgsql/pkg-plist b/security/pam-pgsql/pkg-plist
new file mode 100644
index 000000000000..1bd61e594b21
--- /dev/null
+++ b/security/pam-pgsql/pkg-plist
@@ -0,0 +1,6 @@
+%%DOC%%share/doc/pam_pgsql/README
+%%DOC%%share/doc/pam_pgsql/changelog
+%%DOC%%share/doc/pam_pgsql/copyright
+%%DOC%%@dirrm share/doc/pam_pgsql
+@cwd /usr
+lib/pam_pgsql.so