aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-30 05:07:39 +0800
committeradamw <adamw@FreeBSD.org>2014-07-30 05:07:39 +0800
commita3efce1abab3e3ffdacfd584b2689609a0979ef8 (patch)
tree89c14611c583909707d36d2ee33980021a65b425 /security
parent01d8d88f456e484b8265e7be7086d3b5a1b4b701 (diff)
downloadfreebsd-ports-gnome-a3efce1abab3e3ffdacfd584b2689609a0979ef8.tar.gz
freebsd-ports-gnome-a3efce1abab3e3ffdacfd584b2689609a0979ef8.tar.zst
freebsd-ports-gnome-a3efce1abab3e3ffdacfd584b2689609a0979ef8.zip
Convert a bunch of USE_XZ to USES=tar:xz.
Approved by: portmgr (not really, but touches unstaged ports)
Diffstat (limited to 'security')
-rw-r--r--security/gtkpasman/Makefile3
-rw-r--r--security/libsecret/Makefile3
-rw-r--r--security/nmapsi4/Makefile3
-rw-r--r--security/py-htpasswd/Makefile3
4 files changed, 4 insertions, 8 deletions
diff --git a/security/gtkpasman/Makefile b/security/gtkpasman/Makefile
index dc701ad7319e..7ca99d012a43 100644
--- a/security/gtkpasman/Makefile
+++ b/security/gtkpasman/Makefile
@@ -11,11 +11,10 @@ COMMENT= GTK+ passwords manager for system and network administrators
RUN_DEPENDS+= gpgv2:${PORTSDIR}/security/gnupg
-USES= desktop-file-utils gmake pkgconfig
+USES= desktop-file-utils gmake pkgconfig tar:xz
USE_GNOME= gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-gtk2
-USE_XZ= yes
SUB_FILES= pkg-message
diff --git a/security/libsecret/Makefile b/security/libsecret/Makefile
index 1338a2e22267..9deb7b9ff6d5 100644
--- a/security/libsecret/Makefile
+++ b/security/libsecret/Makefile
@@ -14,9 +14,8 @@ COMMENT= Library to access the secret service API
BUILD_DEPENDS= docbook-xsl>=0:${PORTSDIR}/textproc/docbook-xsl
LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt
-USE_XZ= yes
USE_GNOME= gnomehier glib20 libxslt:build intltool introspection:build
-USES= gettext gmake libtool:keepla pathfix pkgconfig
+USES= gettext gmake libtool:keepla pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-introspection --disable-vala
diff --git a/security/nmapsi4/Makefile b/security/nmapsi4/Makefile
index acab93edd3a4..50dde1536188 100644
--- a/security/nmapsi4/Makefile
+++ b/security/nmapsi4/Makefile
@@ -13,8 +13,7 @@ LICENSE= GPLv2
RUN_DEPENDS= ${LOCALBASE}/bin/nmap:${PORTSDIR}/security/nmap
-USES= cmake
-USE_XZ= yes
+USES= cmake tar:xz
INSTALLS_ICONS= yes
USE_QT4= gui qmake_build uic_build moc_build rcc_build network \
linguist_build webkit dbus
diff --git a/security/py-htpasswd/Makefile b/security/py-htpasswd/Makefile
index 2b61f1c8a690..fccc7778de31 100644
--- a/security/py-htpasswd/Makefile
+++ b/security/py-htpasswd/Makefile
@@ -11,9 +11,8 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= graudeejs@gmail.com
COMMENT= Replacement for htpasswd
-USES= shebangfix
+USES= shebangfix tar:xz
USE_PYTHON= yes
-USE_XZ= yes
PLIST_FILES= bin/${PORTNAME}.py