aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2007-11-27 01:45:55 +0800
committerade <ade@FreeBSD.org>2007-11-27 01:45:55 +0800
commita9c7d8ed52962098b4de90533996a041675d677e (patch)
tree3e3e6aab8ae32298357b6439128709de3b612401 /security
parent46291313e8e80e4f2888defdb042cbdcd27ccd5a (diff)
downloadfreebsd-ports-gnome-a9c7d8ed52962098b4de90533996a041675d677e.tar.gz
freebsd-ports-gnome-a9c7d8ed52962098b4de90533996a041675d677e.tar.zst
freebsd-ports-gnome-a9c7d8ed52962098b4de90533996a041675d677e.zip
Unbreak pthread-related issues on 5.x
Approved by: portmgr
Diffstat (limited to 'security')
-rw-r--r--security/clamav/Makefile7
-rw-r--r--security/squidclam/Makefile9
2 files changed, 3 insertions, 13 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index e78e3fdba8ac..19e71119c304 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -7,6 +7,7 @@
PORTNAME= clamav
PORTVERSION= 0.91.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF
@@ -105,12 +106,6 @@ CONFIGURE_ARGS+= --enable-gethostbyname_r
.if ${OSVERSION} >= 601000
PTHREAD_LIBS= -lthr
.endif
-# Maybe the port is broken for
-# FreeBSD 5.2.1 since -lc_r
-# and -pthread have both issues there.
-.if ${OSVERSION} == 502010
-PTHREAD_LIBS= -pthread
-.endif
.if !defined(WITHOUT_ARC)
RUN_DEPENDS+= arc:${PORTSDIR}/archivers/arc
diff --git a/security/squidclam/Makefile b/security/squidclam/Makefile
index 54362535f83f..9fa9e4806ea0 100644
--- a/security/squidclam/Makefile
+++ b/security/squidclam/Makefile
@@ -22,6 +22,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
USE_GMAKE= yes
NO_INSTALL_MANPAGES= yes
+CFLAGS+= ${PTHREAD_LIBS}
PORTDOCS= README Changelog
@@ -30,12 +31,6 @@ SUB_FILES= pkg-message
PLIST_FILES= bin/squidclam %%EXAMPLESDIR%%/squidclam.conf
PLIST_DIRS= %%EXAMPLESDIR%%
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600000
-BROKEN= Fails to compile: does not find pthread include file
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
-e 's|%%PREFIX%%|${PREFIX}|g' \
@@ -57,4 +52,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>