aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2008-09-16 20:11:43 +0800
committergarga <garga@FreeBSD.org>2008-09-16 20:11:43 +0800
commitabce371ad97db16e662803a8f2bc73fda5248033 (patch)
treed4dbb0e7c66e539a80b9b00ef4ffaca88997b2e3 /security
parent1ae24111c62facb415ef745a8a91aed98edc8a13 (diff)
downloadfreebsd-ports-gnome-abce371ad97db16e662803a8f2bc73fda5248033.tar.gz
freebsd-ports-gnome-abce371ad97db16e662803a8f2bc73fda5248033.tar.zst
freebsd-ports-gnome-abce371ad97db16e662803a8f2bc73fda5248033.zip
- UNBREAK: Fix build with clamav 0.94
- Bump PORTREVISION PR: ports/127421 Submitted by: maintainer Approved by: portmgr (pav)
Diffstat (limited to 'security')
-rw-r--r--security/klamav/Makefile3
-rw-r--r--security/klamav/files/patch-src_klammail_clamdmail.c11
2 files changed, 12 insertions, 2 deletions
diff --git a/security/klamav/Makefile b/security/klamav/Makefile
index 755ff025ad78..080a18ddecb9 100644
--- a/security/klamav/Makefile
+++ b/security/klamav/Makefile
@@ -7,6 +7,7 @@
PORTNAME= klamav
PORTVERSION= 0.44
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
@@ -36,8 +37,6 @@ CONFIGURE_ARGS+=--with-qt-dir=${QT_PREFIX} \
USE_KDELIBS_VER= 3
-BROKEN= Doesn't build with clamav-0.94
-
.include <bsd.port.pre.mk>
pre-configure:
diff --git a/security/klamav/files/patch-src_klammail_clamdmail.c b/security/klamav/files/patch-src_klammail_clamdmail.c
new file mode 100644
index 000000000000..77a6257aa95b
--- /dev/null
+++ b/security/klamav/files/patch-src_klammail_clamdmail.c
@@ -0,0 +1,11 @@
+--- src/klammail/clamdmail.c.orig 2008-09-16 08:46:48.000000000 -0300
++++ src/klammail/clamdmail.c 2008-09-16 08:47:25.000000000 -0300
+@@ -160,7 +160,7 @@
+ if(fsync(fd) == -1) {
+ // cli_dbgmsg("fsync() failed for descriptor %d\n", fd);
+ close(fd);
+- return CL_EFSYNC;
++ return CL_EIO;
+ }
+
+ close(fd);
-3/+1 * Mark the settings dialog as transient for the main windowRoss Burton2003-12-231-0/+1 * Implement.Ettore Perazzoli2003-12-051-31/+19 * If component_id is the empty string, pass NULL for it toEttore Perazzoli2003-12-041-0/+3 * Pass a label for the status bar control for now.Ettore Perazzoli2003-12-021-23/+0 * New member offline_handler. (offline_procedure_started_cb): New.Ettore Perazzoli2003-12-011-19/+58 * Reimplemented using EComponentRegistry.Ettore Perazzoli2003-11-211-36/+10 * Destroy the tooltips instead of unreffing them.Ettore Perazzoli2003-11-191-0/+23 * New helper function. (idle_cb): Call it if we have a local shell. Also,Ettore Perazzoli2003-11-181-1/+74 * Do not #include "e-local-folder.h".Ettore Perazzoli2003-11-181-3/+8 * New.Ettore Perazzoli2003-11-141-0/+26 * New signal "component_changed". (class_init): Install. (switch_view):Ettore Perazzoli2003-11-131-10/+18 * Added a new "-c" command-line arg. (idle_cb): If the arg is specified,Ettore Perazzoli2003-11-111-39/+17 * New member "component_registry". (e_shell_construct): Don't callEttore Perazzoli2003-10-231-216/+23 * Merge new-ui-branch to the trunk.Ettore Perazzoli2003-10-221-1238/+151 * Ooops, revert changes: wrong branch.Ettore Perazzoli2003-07-241-2/+1 * Create a new EShellWindow and show it.Ettore Perazzoli2003-07-241-1/+2 * Protect against the component name having slashes in it.Ettore Perazzoli2003-05-161-0/+5 * release the interface if we got itJP Rosevear2003-05-151-0/+2 * Free the temporary string.Hans Petter Jansson2003-04-161-1/+4 * Desensitize the window's top-level container rather than desensitizing theDan Winship2003-04-081-0/+3 * [#39467]Not Zed2003-04-021-12/+7 * Update for e_notice move. Likewise Likewise Likewise Likewise LikewiseDan Winship2003-03-251-9/+2 * add a "new_view_xid" arg, so the component has a window id to make use ofDan Winship2003-03-251-11/+12 * If you can't get a pixbuf icon for the folder's type, do not crash.Ettore Perazzoli2003-03-201-21/+0 * ** reverted the following patch from ettore, this is a gnome 2.2 apiNot Zed2003-03-071-2/+2 * (impl_Shell_selectUserFolder): At least for now,Ettore Perazzoli2003-03-071-2/+4 * (impl_finalize): UseEttore Perazzoli2003-03-071-2/+2 * fix the conf keys, currently unused.Not Zed2003-02-241-1/+1 * (e_shell_construct): UseEttore Perazzoli2003-01-291-2/+2 * Set GTK_RESPONSE_OK as the default response.Ettore Perazzoli2003-01-281-6/+10 * s/BonoboXObject/BonoboObject/ (for BONOBO_DISABLE_DEPRECATED)Dan Winship2003-01-141-8/+8 * Make the view save its settings as the default ones if it's the last one.Ettore Perazzoli2003-01-111-1/+5 * (parse_default_uri): Remove bogus is_default check.Ettore Perazzoli2003-01-111-2/+1 * Properly reset activity_interface to NULL.Ettore Perazzoli2003-01-101-4/+4 * [With this commit, the shell compiles without deprecatedEttore Perazzoli2002-12-201-24/+25 * changed to use a gtkdialog instead of a gnome one.Not Zed2002-12-021-7/+7 * use e_shell_ marshallers, and make sure STRING parameters map to *_STRING*Chris Toshok2002-11-201-2/+2 * Disabled for now.Ettore Perazzoli2002-11-201-130/+58 * Added rule to generate GNOME_Evolution_Shell.server.in fromEttore Perazzoli2002-11-161-2/+2 * Use bonobo_main_quit() instead of gtk_main_quit(). (shell_weak_notify):Ettore Perazzoli2002-11-151-7/+20 * (save_settings_for_views): Removed.Ettore Perazzoli2002-11-151-30/+1 * Removed. (no_views_left_cb): Use g_object_add_weak_pointer() instad ofEttore Perazzoli2002-11-151-25/+9 * (impl_dispose): Do unref the config_listener here [IEttore Perazzoli2002-11-121-1/+1 * (e_shell_show_settings): Allow type being NULL.Ettore Perazzoli2002-11-061-2/+3 * Use g_object_get_data() instead of gtk_object_get_data(). Likewise.Ettore Perazzoli2002-11-061-2/+2 * Split finalize/dispose. Likewise. Likewise. Likewise. Likewise. Likewise.Ettore Perazzoli2002-11-061-16/+46 * New. (impl_finalize): New. (destroy): Removed. (class_init): InstallEttore Perazzoli2002-11-061-6/+6 * Pass TRUE for arg allow_creation to e_shell_folder_selection_dialog_new().Ettore Perazzoli2002-11-051-2/+3 * Use g_object_set_data() instead of gtk_object_set_data(). Likewise.Ettore Perazzoli2002-11-041-7/+7 * Changed all gtk_object_refs()/gtk_object_unrefs() intoEttore Perazzoli2002-11-041-29/+29 * Renamed from GNOME_Evolution_Shell.oaf.in.Ettore Perazzoli2002-11-041-62/+52 * First big sync of my GNOME 2 porting work (incomplete, and stillEttore Perazzoli2002-11-021-23/+15 * Set the is_stock flag to TRUE for the summary folder.Ettore Perazzoli2002-10-241-0/+1 * [Finish fixing #11645.]Ettore Perazzoli2002-09-261-0/+31 * Don't destroy the dialog. It does that itself whenever it emitsDan Winship2002-09-251-2/+0 * (e_shell_construct): Oops, no @shell argument toEttore Perazzoli2002-09-241-1/+1 * Use e_shell_request_close_view().Ettore Perazzoli2002-09-241-17/+36 * Pass TRUE as @queue to e_shell_view_display_uri().Ettore Perazzoli2002-09-05