aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-08-20 16:01:17 +0800
committermiwi <miwi@FreeBSD.org>2008-08-20 16:01:17 +0800
commitb394772f3c1c146bf624e1e7158bd9949e0f7d62 (patch)
tree6d22638767df0a09e1345441ce2941e42bbd5b9f /security
parent94b9b10c47c1a94d908cca850438e81dddcce046 (diff)
downloadfreebsd-ports-gnome-b394772f3c1c146bf624e1e7158bd9949e0f7d62.tar.gz
freebsd-ports-gnome-b394772f3c1c146bf624e1e7158bd9949e0f7d62.tar.zst
freebsd-ports-gnome-b394772f3c1c146bf624e1e7158bd9949e0f7d62.zip
- Update to 0.2.0.30
PR: 126262 Submitted by: bf <bf2006a@yahoo.com>
Diffstat (limited to 'security')
-rw-r--r--security/tor/Makefile58
-rw-r--r--security/tor/distinfo6
-rw-r--r--security/tor/pkg-plist3
3 files changed, 43 insertions, 24 deletions
diff --git a/security/tor/Makefile b/security/tor/Makefile
index 0ee325ea1217..b0a73a58882c 100644
--- a/security/tor/Makefile
+++ b/security/tor/Makefile
@@ -6,23 +6,28 @@
#
PORTNAME= tor
-PORTVERSION= 0.1.2.19
-PORTREVISION= 2
+DISTVERSION= 0.2.0.30
CATEGORIES= security net
MASTER_SITES= http://www.torproject.org/dist/ \
- http://mirror.onionland.org/dist/
-DISTNAME= ${PORTNAME}-${PORTVERSION}
+ http://tor.cypherpunks.at/dist/ \
+ http://tor.depthstrike.com/dist/ \
+ http://tor.boinc.ch/dist/ \
+ http://tor.anonymity.cn/dist/
MAINTAINER= miwi@FreeBSD.org
COMMENT= An anonymizing overlay network for TCP
RUN_DEPENDS= tsocks:${PORTSDIR}/net/tsocks
-LIB_DEPENDS= event-1.4:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= event-1.3e:${PORTSDIR}/devel/libevent
GNU_CONFIGURE= yes
USE_OPENSSL= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
-OPTIONS= EVENTDNS "asynchronous DNS module" on \
+OPTIONS= BUFFREELISTS "freelists for buffer RAM" on \
+ CELLPOOL "memory pool allocator for cells" on \
+ TCMALLOC "use the tcmalloc memory allocation library" off \
THREADS "multi-threading support" on \
TRANSPARENT "transparent proxy support" on \
VIDALIA "Vidalia graphical Tor controller" off
@@ -30,25 +35,33 @@ OPTIONS= EVENTDNS "asynchronous DNS module" on \
USE_RC_SUBR= tor
SUB_FILES= pkg-message
-CONFLICTS= tor-devel*
+CONFLICTS= tor-devel-[0-9]*
MANCOMPRESSED= no
-MAN1= tor.1 tor-resolve.1 torify.1
+MAN1= tor.1 tor-resolve.1 torify.1 tor-gencert.1
.include <bsd.port.pre.mk>
-CONFIGURE_ENV+= CPPFLAGS+=-I{LOCALBASE}/include \
- LDFLAGS+=-L{LOCALBASE}/lib
+.if defined(WITH_BUFFREELISTS)
+CONFIGURE_ARGS+= --enable-buf-freelists
+.else
+CONFIGURE_ARGS+= --disable-buf-freelists
+.endif
-.if defined(WITH_EVENTDNS)
-CONFIGURE_ARGS+= --enable-eventdns
+.if defined(WITH_CELLPOOL)
+CONFIGURE_ARGS+= --enable-cell-pool
.else
-CONFIGURE_ARGS+= --disable-eventdns
+CONFIGURE_ARGS+= --disable-cell-pool
+.endif
+
+.if defined(WITH_TCMALLOC)
+CONFIGURE_ARGS+= --with-tcmalloc
+LIB_DEPENDS+= tcmalloc:${PORTSDIR}/devel/google-perftools
.endif
.if defined(WITH_THREADS)
CONFIGURE_ARGS+= --enable-threads
-CONFIGURE_ENV+= LDFLAGS+={PTHREAD_LIBS}
+CFLAGS+= ${PTHREAD_CFLAGS}
.else
CONFIGURE_ARGS+= --disable-threads
.endif
@@ -68,17 +81,16 @@ post-patch:
${WRKSRC}/contrib/tor-tsocks.conf.sample
@${REINPLACE_CMD} -e "s|tor-tsocks.conf|tor-tsocks.conf.sample|g" \
${WRKSRC}/contrib/Makefile.in
-#fix typos in configure scripts, undesirable compiler flags, wrong location of in6.h
- @${FIND} ${WRKSRC} -type f | ${XARGS} \
+ @${FIND} -X ${WRKSRC} -type f | ${XARGS} \
-n 10 ${REINPLACE_CMD} -E \
- -e 's!-g -O2!!' \
- -e 's!-O2!!' \
- -e 's|netintet|netinet|g' \
+ -e 's|-g -O2||g' \
+ -e 's|-O2||g' \
+ -e 's|-g -O||g' \
-e 's|netinet/in6|netinet6/in6|g'
post-configure:
- @${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e \
- 's|-lpthread|${PTHREAD_LIBS}|g'
+ @${FIND} -X ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e \
+ "s|-lpthread|${PTHREAD_LIBS}|g"
pre-su-install:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} \
@@ -93,4 +105,8 @@ post-install:
${CHOWN} _tor:_tor /var/db/tor
${CAT} ${PKGMESSAGE}
+regression-test:
+ @( cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check )
+
.include <bsd.port.post.mk>
diff --git a/security/tor/distinfo b/security/tor/distinfo
index 423882389f54..7cae0bc0eb3f 100644
--- a/security/tor/distinfo
+++ b/security/tor/distinfo
@@ -1,3 +1,3 @@
-MD5 (tor-0.1.2.19.tar.gz) = 4b3f9963b843010af5aa3bd6266d11e0
-SHA256 (tor-0.1.2.19.tar.gz) = 7e57198a0858f5ba8651d75225248c85b619e905f0ff4dbb45fffa2d03a1aa61
-SIZE (tor-0.1.2.19.tar.gz) = 1264275
+MD5 (tor-0.2.0.30.tar.gz) = d37b582ee35b4f69564b0635a449b5f6
+SHA256 (tor-0.2.0.30.tar.gz) = bc9e8bf841ef64f8b06eef91eeab430f91147a3c4d7a6919826fa33b20453387
+SIZE (tor-0.2.0.30.tar.gz) = 2155463
diff --git a/security/tor/pkg-plist b/security/tor/pkg-plist
index 6dac940cc517..9459fabaccee 100644
--- a/security/tor/pkg-plist
+++ b/security/tor/pkg-plist
@@ -1,6 +1,9 @@
bin/tor
+bin/tor-gencert
bin/tor-resolve
bin/torify
etc/tor/tor-tsocks.conf.sample
etc/tor/torrc.sample
+share/tor/geoip
+@dirrm share/tor
@dirrm etc/tor