aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2002-08-06 13:46:17 +0800
committerdinoex <dinoex@FreeBSD.org>2002-08-06 13:46:17 +0800
commitb5d1eb17926706bbc195bc8602f5e8c001534303 (patch)
treee0eb76ccf001f2788f48616165234a0f22f8a571 /security
parent0a9e14deaf82129473ae80c1a7771b35840c2cdf (diff)
downloadfreebsd-ports-gnome-b5d1eb17926706bbc195bc8602f5e8c001534303.tar.gz
freebsd-ports-gnome-b5d1eb17926706bbc195bc8602f5e8c001534303.tar.zst
freebsd-ports-gnome-b5d1eb17926706bbc195bc8602f5e8c001534303.zip
Sync Bugfix from CURRENT
Diffstat (limited to 'security')
-rw-r--r--security/openssl-beta/Makefile1
-rw-r--r--security/openssl-beta/files/patch-asn1_lib.c11
-rw-r--r--security/openssl/Makefile1
-rw-r--r--security/openssl/files/patch-asn1_lib.c11
4 files changed, 24 insertions, 0 deletions
diff --git a/security/openssl-beta/Makefile b/security/openssl-beta/Makefile
index 198de33855fd..4e3bdfebf782 100644
--- a/security/openssl-beta/Makefile
+++ b/security/openssl-beta/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openssl
PORTVERSION= 0.9.6e
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/source/ \
ftp://ftp.openssl.org/source/ \
diff --git a/security/openssl-beta/files/patch-asn1_lib.c b/security/openssl-beta/files/patch-asn1_lib.c
new file mode 100644
index 000000000000..ec5b10e43ee1
--- /dev/null
+++ b/security/openssl-beta/files/patch-asn1_lib.c
@@ -0,0 +1,11 @@
+--- crypto/asn1/asn1_lib.c.orig Tue Jul 30 12:18:29 2002
++++ crypto/asn1/asn1_lib.c Mon Aug 5 18:25:17 2002
+@@ -124,7 +124,7 @@
+ (int)(omax+ *pp));
+
+ #endif
+- if (*plength > (omax - (*pp - p)))
++ if (*plength > (omax - (p - *pp)))
+ {
+ ASN1err(ASN1_F_ASN1_GET_OBJECT,ASN1_R_TOO_LONG);
+ /* Set this so that even if things are not long enough
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 198de33855fd..4e3bdfebf782 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openssl
PORTVERSION= 0.9.6e
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/source/ \
ftp://ftp.openssl.org/source/ \
diff --git a/security/openssl/files/patch-asn1_lib.c b/security/openssl/files/patch-asn1_lib.c
new file mode 100644
index 000000000000..ec5b10e43ee1
--- /dev/null
+++ b/security/openssl/files/patch-asn1_lib.c
@@ -0,0 +1,11 @@
+--- crypto/asn1/asn1_lib.c.orig Tue Jul 30 12:18:29 2002
++++ crypto/asn1/asn1_lib.c Mon Aug 5 18:25:17 2002
+@@ -124,7 +124,7 @@
+ (int)(omax+ *pp));
+
+ #endif
+- if (*plength > (omax - (*pp - p)))
++ if (*plength > (omax - (p - *pp)))
+ {
+ ASN1err(ASN1_F_ASN1_GET_OBJECT,ASN1_R_TOO_LONG);
+ /* Set this so that even if things are not long enough