aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2012-06-11 10:36:41 +0800
committerzi <zi@FreeBSD.org>2012-06-11 10:36:41 +0800
commitb9a8a8122a79786af31097be4147aac7de965ee0 (patch)
tree66bb4a4e36a510f8ffdfc6db62debe0f5b1a0739 /security
parentff68d55513c85e07c61775d187bb4bb1e67f2d6a (diff)
downloadfreebsd-ports-gnome-b9a8a8122a79786af31097be4147aac7de965ee0.tar.gz
freebsd-ports-gnome-b9a8a8122a79786af31097be4147aac7de965ee0.tar.zst
freebsd-ports-gnome-b9a8a8122a79786af31097be4147aac7de965ee0.zip
New port: security/razorback-masterNugget:
Razorback is a framework for an intelligence driven security solution. It consists of a Dispatcher at the core of the system, surrounded by Nuggets of varying types. WWW: http://razorbacktm.sourceforge.net/ PR: ports/167739 Submitted by: Tom Judge <tom@tomjudge.com>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/razorback-masterNugget/Makefile50
-rw-r--r--security/razorback-masterNugget/distinfo2
-rw-r--r--security/razorback-masterNugget/files/masterNugget.in38
-rw-r--r--security/razorback-masterNugget/files/masterNugget_safed.in33
-rw-r--r--security/razorback-masterNugget/pkg-descr5
-rw-r--r--security/razorback-masterNugget/pkg-plist7
7 files changed, 136 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 5ac496c5fad1..4aabcb32085f 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -791,6 +791,7 @@
SUBDIR += razorback-fileInject
SUBDIR += razorback-fsMonitor
SUBDIR += razorback-fsWalk
+ SUBDIR += razorback-masterNugget
SUBDIR += rdigest
SUBDIR += retranslator
SUBDIR += revelation
diff --git a/security/razorback-masterNugget/Makefile b/security/razorback-masterNugget/Makefile
new file mode 100644
index 000000000000..d2ad6e79355f
--- /dev/null
+++ b/security/razorback-masterNugget/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: razorback-masterNugget
+# Date created: 2011/06/8
+# Whom: Tom Judge <tom@tomjudge.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= masterNugget
+PORTVERSION= 0.5.0
+CATEGORIES= security
+MASTER_SITES= SF/razorbacktm/Nuggets
+PKGNAMEPREFIX= razorback-
+DIST_SUBDIR= razorback
+
+MAINTAINER= tj@FreeBSD.org
+COMMENT= Framework for an intelligence driven security - Master Nugget
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= razorback_api:${PORTSDIR}/security/razorback-api
+
+OPTIONS_DEFINE= DEBUG ASSERT
+ASSERT_DESC= Enable Asserts
+
+.include <bsd.port.options.mk>
+
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool
+USE_RC_SUBR= masterNugget masterNugget_safed
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+USERS?= razorback
+GROUPS?= razorback
+
+.if ${PORT_OPTIONS:MDEBUG}
+CONFIGURE_ARGS+=--enable-debug
+.endif
+
+.if ${PORT_OPTIONS:MASSERT}
+CONFIGURE_ARGS+=--enable-assert
+.endif
+
+post-install:
+ @if [ ! -f ${PREFIX}/etc/razorback/master_nugget.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/razorback/master_nugget.conf.sample ${PREFIX}/etc/razorback/master_nugget.conf ; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/security/razorback-masterNugget/distinfo b/security/razorback-masterNugget/distinfo
new file mode 100644
index 000000000000..ca719751af5b
--- /dev/null
+++ b/security/razorback-masterNugget/distinfo
@@ -0,0 +1,2 @@
+SHA256 (razorback/masterNugget-0.5.0.tar.gz) = 015ccdeb24537cec35b8f2f511134e9db73140d339f9f2b2bf713838b4354aed
+SIZE (razorback/masterNugget-0.5.0.tar.gz) = 321438
diff --git a/security/razorback-masterNugget/files/masterNugget.in b/security/razorback-masterNugget/files/masterNugget.in
new file mode 100644
index 000000000000..18673a8d9d1a
--- /dev/null
+++ b/security/razorback-masterNugget/files/masterNugget.in
@@ -0,0 +1,38 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: masterNugget
+# REQUIRE: dispatcher clamd
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf to enable the razorback master nugget:
+#
+# masterNugget_enable="YES"
+
+. /etc/rc.subr
+
+name=masterNugget
+rcvar=masterNugget_enable
+
+load_rc_config $name
+
+masterNugget_enable=${masterNugget_enable:-"NO"}
+masterNugget_user=${masterNugget_user:-"razorback"}
+masterNugget_group=${masterNugget_group:-"razorback"}
+
+command=%%PREFIX%%/bin/masterNugget
+
+start_precmd="masterNugget_precmd"
+_piddir=/var/run/razorback
+pidfile=${_piddir}/masterNugget.pid
+
+masterNugget_precmd()
+{
+ export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin:%%PREFIX%%/bin:%%PREFIX%%/sbin
+ install -d -o $masterNugget_user -g $masterNugget_user -m 755 $_piddir
+ cd /var/lib/razorback
+ export HOME=/var/lib/razorback
+}
+
+run_rc_command "$1"
diff --git a/security/razorback-masterNugget/files/masterNugget_safed.in b/security/razorback-masterNugget/files/masterNugget_safed.in
new file mode 100644
index 000000000000..b8ad3396fcd6
--- /dev/null
+++ b/security/razorback-masterNugget/files/masterNugget_safed.in
@@ -0,0 +1,33 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: masterNugget_safed
+# REQUIRE: masterNugget
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf to enable the razorback master nugget safed:
+#
+# masterNugget_safed_enable="YES"
+
+. /etc/rc.subr
+
+name=masterNugget_safed
+rcvar=masterNugget_safed_enable
+
+load_rc_config $name
+
+masterNugget_safed_enable=${masterNugget_safed_enable:-"NO"}
+
+command="%%PREFIX%%/bin/masterNugget_safed"
+
+pidfile="/var/run/masterNugget_safed.pid"
+start_cmd=masterNugget_safed_start
+procname="/bin/sh"
+
+masterNugget_safed_start()
+{
+ /usr/sbin/daemon -cf -p ${pidfile} ${command}
+}
+
+run_rc_command "$1"
diff --git a/security/razorback-masterNugget/pkg-descr b/security/razorback-masterNugget/pkg-descr
new file mode 100644
index 000000000000..930082261c40
--- /dev/null
+++ b/security/razorback-masterNugget/pkg-descr
@@ -0,0 +1,5 @@
+Razorback is a framework for an intelligence driven security solution.
+It consists of a Dispatcher at the core of the system, surrounded by
+Nuggets of varying types.
+
+WWW: http://razorbacktm.sourceforge.net/
diff --git a/security/razorback-masterNugget/pkg-plist b/security/razorback-masterNugget/pkg-plist
new file mode 100644
index 000000000000..1a2802161acc
--- /dev/null
+++ b/security/razorback-masterNugget/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+bin/masterNugget
+bin/masterNugget_safed
+@unexec if cmp -s %D/etc/razorback/master_nugget.conf %D/etc/razorback/master_nugget.conf.sample; then rm -f %D/etc/razorback/master_nugget.conf; fi
+etc/razorback/master_nugget.conf.sample
+@exec if [ ! -f %D/etc/razorback/master_nugget.conf ]; then cp %D/%F %B/master_nugget.conf; fi
+@dirrmtry etc/razorback