aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-06-04 22:39:22 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-06-04 22:39:22 +0800
commitc42a7276a1c7d0b1e9c518d347cd61d13e327e82 (patch)
treeb8da30834597904af6a2419874b44c2e980e028a /security
parent21d8006248cdfcf480653c724ffa481dddcfcb5d (diff)
downloadfreebsd-ports-gnome-c42a7276a1c7d0b1e9c518d347cd61d13e327e82.tar.gz
freebsd-ports-gnome-c42a7276a1c7d0b1e9c518d347cd61d13e327e82.tar.zst
freebsd-ports-gnome-c42a7276a1c7d0b1e9c518d347cd61d13e327e82.zip
- Switch security/libotr3 to USES=libtool, drop .la files
- Bump dependent ports as .so version has changed Approved by: portmgr blanket
Diffstat (limited to 'security')
-rw-r--r--security/libotr3/Makefile6
-rw-r--r--security/libotr3/pkg-plist4
-rw-r--r--security/py-otr/Makefile4
3 files changed, 8 insertions, 6 deletions
diff --git a/security/libotr3/Makefile b/security/libotr3/Makefile
index ea852f26aca5..7460bcfc9548 100644
--- a/security/libotr3/Makefile
+++ b/security/libotr3/Makefile
@@ -4,7 +4,7 @@ PORTNAME= libotr
PORTVERSION= 3.2.1
# Please do not bump PORTREVISION for this port unless you have
# confirmed via testing that it is necessary
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security net-im net
MASTER_SITES= http://www.c-s.li/ports/ \
https://otr.cypherpunks.ca/
@@ -23,7 +23,9 @@ LIB_DEPENDS= libgpg-error.so:${PORTSDIR}/security/libgpg-error \
CONFLICTS= libotr-*
-USE_AUTOTOOLS= autoconf libtool
+USE_AUTOTOOLS= autoconf
+USES= libtool
+GNU_CONFIGURE= yes
USE_LDCONFIG= yes
verify: checksum
diff --git a/security/libotr3/pkg-plist b/security/libotr3/pkg-plist
index a4e3c4b23ec0..bad3b2d852e9 100644
--- a/security/libotr3/pkg-plist
+++ b/security/libotr3/pkg-plist
@@ -19,9 +19,9 @@ include/libotr/tlv.h
include/libotr/userstate.h
include/libotr/version.h
lib/libotr.a
-lib/libotr.la
lib/libotr.so
-lib/libotr.so.4
+lib/libotr.so.2
+lib/libotr.so.2.2.1
libdata/pkgconfig/libotr.pc
man/man1/otr_mackey.1.gz
man/man1/otr_modify.1.gz
diff --git a/security/py-otr/Makefile b/security/py-otr/Makefile
index 4707b2e1d26a..1c9f7dc59a46 100644
--- a/security/py-otr/Makefile
+++ b/security/py-otr/Makefile
@@ -2,7 +2,7 @@
PORTNAME= otr
PORTVERSION= 0.2.1.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security python
MASTER_SITES= http://python-otr.pentabarf.de/releases/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +13,7 @@ COMMENT= Python bindings for libotr
BUILD_DEPENDS= swig1.3:${PORTSDIR}/devel/swig13
# This should be updated to the newer version of libotr
-LIB_DEPENDS= otr.4:${PORTSDIR}/security/libotr3
+LIB_DEPENDS= libotr.so.2:${PORTSDIR}/security/libotr3
USES= pkgconfig
USE_PYTHON= yes