aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-04-24 10:04:04 +0800
committerbapt <bapt@FreeBSD.org>2011-04-24 10:04:04 +0800
commitc86e6e55147b10327125e6f14901ac9616abd181 (patch)
tree272575f034de5a5e10df9f40af87b9c2925f8748 /security
parentbf1d1a9f70da9300275175a96622ea0c336b1b46 (diff)
downloadfreebsd-ports-gnome-c86e6e55147b10327125e6f14901ac9616abd181.tar.gz
freebsd-ports-gnome-c86e6e55147b10327125e6f14901ac9616abd181.tar.zst
freebsd-ports-gnome-c86e6e55147b10327125e6f14901ac9616abd181.zip
Add the wanted version on package depends or it won't work as expected
re introduce the perl version check accidentally removed Submitted by: Géraud Continsouzas (GeJ on irc)
Diffstat (limited to 'security')
-rw-r--r--security/p5-Module-Signature/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/security/p5-Module-Signature/Makefile b/security/p5-Module-Signature/Makefile
index 46e8b35d9d5c..878f268f556d 100644
--- a/security/p5-Module-Signature/Makefile
+++ b/security/p5-Module-Signature/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Module signature file manipulation
-RUN_DEPENDS= p5-PAR-Dist:${PORTSDIR}/devel/p5-PAR-Dist \
+RUN_DEPENDS= p5-PAR-Dist>=0:${PORTSDIR}/devel/p5-PAR-Dist \
${LOCALBASE}/bin/gpgv:${PORTSDIR}/security/gnupg1
BUILD_DEPENDS= ${RUN_DEPENDS}
@@ -23,4 +23,9 @@ PERL_CONFIGURE= yes
MAN1= cpansign.1
MAN3= Module::Signature.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA  
+.endif
+.include <bsd.port.post.mk>