aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-03 03:55:48 +0800
committerbapt <bapt@FreeBSD.org>2013-09-03 03:55:48 +0800
commitcc33170943fa61617b8f7e5b3db1b43320de5379 (patch)
tree75e8ab6c627957618692c95d7dad6a3f1adee9d9 /security
parent710bc4835ca10e614f678c9ada13dd8c16981f7a (diff)
downloadfreebsd-ports-gnome-cc33170943fa61617b8f7e5b3db1b43320de5379.tar.gz
freebsd-ports-gnome-cc33170943fa61617b8f7e5b3db1b43320de5379.tar.zst
freebsd-ports-gnome-cc33170943fa61617b8f7e5b3db1b43320de5379.zip
Add an explicit dependency on pkgconf
Diffstat (limited to 'security')
-rw-r--r--security/razorback-fileInject/Makefile11
-rw-r--r--security/razorback-yaraNugget/Makefile11
2 files changed, 8 insertions, 14 deletions
diff --git a/security/razorback-fileInject/Makefile b/security/razorback-fileInject/Makefile
index 549182bcf0a1..57e9733700d8 100644
--- a/security/razorback-fileInject/Makefile
+++ b/security/razorback-fileInject/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: razorback-fileInject
-# Date created: 2011/06/8
-# Whom: Tom Judge <tom@tomjudge.com>
-#
+# Created by: Tom Judge <tom@tomjudge.com>
# $FreeBSD$
-#
PORTNAME= fileInject
PORTVERSION= 0.5.0
@@ -22,13 +18,14 @@ LIB_DEPENDS= razorback_api.2:${PORTSDIR}/security/razorback-api
OPTIONS_DEFINE= DEBUG ASSERT
-.include <bsd.port.options.mk>
-
GNU_CONFIGURE= yes
+USES= pkgconfig
USE_AUTOTOOLS= libtool
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+.include <bsd.port.options.mk>
+
.if !empty(PORT_OPTIONS:MDEBUG)
CONFIGURE_ARGS+=--enable-debug
.endif
diff --git a/security/razorback-yaraNugget/Makefile b/security/razorback-yaraNugget/Makefile
index 3c2a5cd97a6a..ab0bd0d5eafb 100644
--- a/security/razorback-yaraNugget/Makefile
+++ b/security/razorback-yaraNugget/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: razorback-yaraNugget
-# Date created: 2011/06/8
-# Whom: Tom Judge <tom@tomjudge.com>
-#
+# Created by: Tom Judge <tom@tomjudge.com>
# $FreeBSD$
-#
PORTNAME= yaraNugget
PORTVERSION= 0.5.0
@@ -27,13 +23,14 @@ RUN_DEPENDS= razorback-masterNugget>=0.5.0:${PORTSDIR}/security/razorback-master
OPTIONS_DEFINE= DEBUG ASSERT
ASSERT_DESC= Enable Asserts
-.include <bsd.port.options.mk>
-
RB_LIBDIR?= ${PREFIX}/lib/razorback
GNU_CONFIGURE= yes
+USES= pkgconfig
USE_AUTOTOOLS= libtool
USE_LDCONFIG= ${RB_LIBDIR}
+.include <bsd.port.options.mk>
+
.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+=--enable-debug
.endif