aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorfoxfair <foxfair@FreeBSD.org>2003-07-04 09:28:53 +0800
committerfoxfair <foxfair@FreeBSD.org>2003-07-04 09:28:53 +0800
commitd02eb0a25f9a6b3e62bf71606306717856628582 (patch)
tree0b38752e233890454e94502ad8f6fe556e799f25 /security
parent09754239804c44d3b51ad1be3bd94359b989d104 (diff)
downloadfreebsd-ports-gnome-d02eb0a25f9a6b3e62bf71606306717856628582.tar.gz
freebsd-ports-gnome-d02eb0a25f9a6b3e62bf71606306717856628582.tar.zst
freebsd-ports-gnome-d02eb0a25f9a6b3e62bf71606306717856628582.zip
PR:
Submitted by: Reviewed by: Approved by: Obtained from: MFC after: Add a critical patch to fix a problem with normalization, which does not cause problems in normal operation but might lead to a pagefault => crash. Submitted by: Pyun YongHyeon <yongari@kt-is.co.kr> Approved by: maintainer
Diffstat (limited to 'security')
-rw-r--r--security/pf/Makefile2
-rw-r--r--security/pf/files/patch-ae13
2 files changed, 14 insertions, 1 deletions
diff --git a/security/pf/Makefile b/security/pf/Makefile
index cea8652d3ab1..cbe8f9623a67 100644
--- a/security/pf/Makefile
+++ b/security/pf/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pf_freebsd
PORTVERSION= 1.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security ipv6
MASTER_SITES= http://pf4freebsd.love2party.net/
.if defined(WITH_ALTQ) && (${WITH_ALTQ} == "yes")
diff --git a/security/pf/files/patch-ae b/security/pf/files/patch-ae
new file mode 100644
index 000000000000..739e91417366
--- /dev/null
+++ b/security/pf/files/patch-ae
@@ -0,0 +1,13 @@
+--- pf/pf_norm.c 7 Apr 2003 15:31:41 -0000 1.2
++++ pf/pf_norm.c 3 Jul 2003 02:40:10 -0000 1.2.16.1
+@@ -747,6 +747,9 @@
+ */
+ #if defined(__FreeBSD__)
+ *m0 = m_dup(m, M_NOWAIT);
++ /* From KAME Project : We have missed this! */
++ m_adj(*m0, (h->ip_hl << 2) -
++ (*m0)->m_pkthdr.len);
+ #else
+ *m0 = m_copym2(m, 0, h->ip_hl << 2, M_NOWAIT);
+ #endif
+