aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2001-06-12 04:11:29 +0800
committerdwcjr <dwcjr@FreeBSD.org>2001-06-12 04:11:29 +0800
commitd1e194ac622014854ee1279b1fefc4ef9904f7d5 (patch)
treeddc9894509dd4a66af460f2619c9c53f31cd4850 /security
parent1f91b0ebe82dde6de480cd25591e131d5d7e52a8 (diff)
downloadfreebsd-ports-gnome-d1e194ac622014854ee1279b1fefc4ef9904f7d5.tar.gz
freebsd-ports-gnome-d1e194ac622014854ee1279b1fefc4ef9904f7d5.tar.zst
freebsd-ports-gnome-d1e194ac622014854ee1279b1fefc4ef9904f7d5.zip
Fix patches to use etc instead of etc/pam_ldap
Bump PORTREVISION
Diffstat (limited to 'security')
-rw-r--r--security/pam_ldap/Makefile4
-rw-r--r--security/pam_ldap/files/patch-ab8
-rw-r--r--security/pam_ldap/files/patch-ac11
3 files changed, 14 insertions, 9 deletions
diff --git a/security/pam_ldap/Makefile b/security/pam_ldap/Makefile
index 982765ea1726..f07fa8f0fdc0 100644
--- a/security/pam_ldap/Makefile
+++ b/security/pam_ldap/Makefile
@@ -33,8 +33,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.//g}
post-install:
@${ECHO} "================================================================================"
- @${ECHO} "Copy/move/symlink ${PREFIX}/etc/pam_ldap/ldap.conf.dist to"
- @${ECHO} "${PREFIX}/etc/pam_ldap/ldap.conf to be able to use it."
+ @${ECHO} "Copy/move/symlink ${PREFIX}/etc/ldap.conf.dist to"
+ @${ECHO} "${PREFIX}/etc/ldap.conf to be able to use it."
@${ECHO} "Add lines like the following to /etc/pam.conf"
@${ECHO} "to get things going:"
@${ECHO} ""
diff --git a/security/pam_ldap/files/patch-ab b/security/pam_ldap/files/patch-ab
index efef94926927..c5f4f7a8eabd 100644
--- a/security/pam_ldap/files/patch-ab
+++ b/security/pam_ldap/files/patch-ab
@@ -1,11 +1,11 @@
---- pam_ldap.c.orig Sat May 26 16:06:17 2001
-+++ pam_ldap.c Sat May 26 16:07:05 2001
-@@ -551,7 +551,7 @@
+--- pam_ldap.c.orig Mon Jun 11 11:44:49 2001
++++ pam_ldap.c Mon Jun 11 11:45:07 2001
+@@ -557,7 +557,7 @@
/* configuration file location is configurable; default /etc/ldap.conf */
if (configFile == NULL)
- configFile = "/etc/ldap.conf";
-+ configFile = "/usr/local/etc/pam_ldap/ldap.conf";
++ configFile = LDAP_CONF_FILE;
fp = fopen (configFile, "r");
diff --git a/security/pam_ldap/files/patch-ac b/security/pam_ldap/files/patch-ac
index a6f005309b40..a62dbfc7991a 100644
--- a/security/pam_ldap/files/patch-ac
+++ b/security/pam_ldap/files/patch-ac
@@ -1,6 +1,11 @@
---- Makefile.am.orig Sat May 26 17:13:48 2001
-+++ Makefile.am Sat May 26 17:20:03 2001
-@@ -8,20 +8,13 @@
+--- Makefile.am.orig Mon Jan 8 18:00:14 2001
++++ Makefile.am Mon Jun 11 11:44:42 2001
+@@ -4,24 +4,18 @@
+
+ pam_ldap_so_SOURCES = pam_ldap.c pam_ldap.h md5.c md5.h
+ pam_ldap_so_LDFLAGS = @pam_ldap_so_LDFLAGS@
++CFLAGS = @CFLAGS@ -DLDAP_CONF_FILE=\"$(sysconfdir)/ldap.conf\"
+
install-exec-local: pam_ldap.so
@$(NORMAL_INSTALL)