aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-05-22 13:07:49 +0800
committeraaron <aaron@FreeBSD.org>2006-05-22 13:07:49 +0800
commitdc6f52917f88de18734bc17881c1b1c4397e073b (patch)
tree14148efdc16781d95d474f595512ff2063763f67 /security
parent40caf144d610171bf052c88ff1cf5426d93992d0 (diff)
downloadfreebsd-ports-gnome-dc6f52917f88de18734bc17881c1b1c4397e073b.tar.gz
freebsd-ports-gnome-dc6f52917f88de18734bc17881c1b1c4397e073b.tar.zst
freebsd-ports-gnome-dc6f52917f88de18734bc17881c1b1c4397e073b.zip
Adding port security/p5-Authen-Simple-DBI, DBI extension for security/p5-Authen-
Simple. Approved by: tobez (implicit)
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Authen-Simple-DBI/Makefile32
-rw-r--r--security/p5-Authen-Simple-DBI/distinfo3
-rw-r--r--security/p5-Authen-Simple-DBI/pkg-descr4
-rw-r--r--security/p5-Authen-Simple-DBI/pkg-plist3
5 files changed, 43 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index a9f690a85e12..1e7ad70c1ade 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -291,6 +291,7 @@
SUBDIR += p5-Authen-SASL
SUBDIR += p5-Authen-SASL-Cyrus
SUBDIR += p5-Authen-Simple
+ SUBDIR += p5-Authen-Simple-DBI
SUBDIR += p5-Authen-Simple-LDAP
SUBDIR += p5-Authen-Smb
SUBDIR += p5-Authen-TacacsPlus
diff --git a/security/p5-Authen-Simple-DBI/Makefile b/security/p5-Authen-Simple-DBI/Makefile
new file mode 100644
index 000000000000..59323be6fcb2
--- /dev/null
+++ b/security/p5-Authen-Simple-DBI/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Authen-Simple-DBI
+# Date created: 21 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-Simple-DBI
+PORTVERSION= 0.2
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Simple DBI authentication
+
+BUILD_DEPENDS= ${SITE_PERL}/Authen/Simple.pm:${PORTSDIR}/security/p5-Authen-Simple \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Authen::Simple::DBI.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl 5.8 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Authen-Simple-DBI/distinfo b/security/p5-Authen-Simple-DBI/distinfo
new file mode 100644
index 000000000000..4314b246a39f
--- /dev/null
+++ b/security/p5-Authen-Simple-DBI/distinfo
@@ -0,0 +1,3 @@
+MD5 (Authen-Simple-DBI-0.2.tar.gz) = 8ded220760b877ba09ffb2ec24b800fc
+SHA256 (Authen-Simple-DBI-0.2.tar.gz) = 7b7e90c3349bc9f2e545f842133c4a6f9bf4aef5c29746087290a1d7c282cc60
+SIZE (Authen-Simple-DBI-0.2.tar.gz) = 4124
diff --git a/security/p5-Authen-Simple-DBI/pkg-descr b/security/p5-Authen-Simple-DBI/pkg-descr
new file mode 100644
index 000000000000..21836ee8733f
--- /dev/null
+++ b/security/p5-Authen-Simple-DBI/pkg-descr
@@ -0,0 +1,4 @@
+Authenticate using DBI.
+
+WWW: http://search.cpan.org/dist/Authen-Simple-DBI
+Author: Christian Hansen <ch@ngmedia.com>
diff --git a/security/p5-Authen-Simple-DBI/pkg-plist b/security/p5-Authen-Simple-DBI/pkg-plist
new file mode 100644
index 000000000000..701550189d16
--- /dev/null
+++ b/security/p5-Authen-Simple-DBI/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Authen/Simple/DBI.pm
+@dirrmtry %%SITE_PERL%%/Authen/Simple
+@dirrmtry %%SITE_PERL%%/Authen