aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-10-04 04:01:09 +0800
committerrm <rm@FreeBSD.org>2012-10-04 04:01:09 +0800
commitdcbd0c6d0b5899ac0f6c8d58df3587fd854aa9b5 (patch)
tree1490af06d19fa574edd7027e984f10bbfc93cc38 /security
parent213c11a5eecb0f277984bde162d1b85bcfb52796 (diff)
downloadfreebsd-ports-gnome-dcbd0c6d0b5899ac0f6c8d58df3587fd854aa9b5.tar.gz
freebsd-ports-gnome-dcbd0c6d0b5899ac0f6c8d58df3587fd854aa9b5.tar.zst
freebsd-ports-gnome-dcbd0c6d0b5899ac0f6c8d58df3587fd854aa9b5.zip
- fix runtime when devel/subversion and/or devel/pysvn is installed [1]
- bump PORTREVISION As side effect, I completely disabled --update feature. It was done for number of reasons: - subversion relationship starts not only if --update feature is requested by user, but when pysvn or svn is available - we do not installing repository metadata from the source tarball (exactly this breaks the --update option, but it is broken anyway, see below) - aforementioned repository metadata is not compatible with svn 1.7, that is in ports now - development repository moved to github from subversion hosting anyway This is accomplished with replacing the call of getRevisionNumber() with static const, that represents the svn last revision from tarball. while here: - trim Makefile header - remove indefinite article from COMMENT - convert to optionsng Reported by: Fausto Marzi <fausto.marzi at gmail dot com> (by mail) [1]
Diffstat (limited to 'security')
-rw-r--r--security/sqlmap/Makefile17
-rw-r--r--security/sqlmap/files/patch-lib_core-settings.py11
2 files changed, 19 insertions, 9 deletions
diff --git a/security/sqlmap/Makefile b/security/sqlmap/Makefile
index 1bddae9384a7..a6378dcecadf 100644
--- a/security/sqlmap/Makefile
+++ b/security/sqlmap/Makefile
@@ -1,18 +1,15 @@
-# New ports collection makefile for: sqlmap
-# Date created: 2008-05-21
-# Whom: Tomoyuki Sakurai <cherry@trombik.org>
-#
+# Created by: Tomoyuki Sakurai <cherry@trombik.org>
# $FreeBSD$
-#
PORTNAME= sqlmap
PORTVERSION= 0.9
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= https://github.com/sqlmapproject/sqlmap/downloads/ \
SF
MAINTAINER= rm@FreeBSD.org
-COMMENT= An automatic SQL injection tool
+COMMENT= Automatic SQL injection tool
LICENSE= GPLv2
@@ -23,16 +20,18 @@ SUB_FILES= ${PORTNAME}.sh
SUB_LIST= PYTHON_CMD=${PYTHON_CMD} \
PATH=${PYTHONPREFIX_SITELIBDIR}/${PORTNAME}
-OPTIONS= MSF "Enable Metasploit Framework integration" off
+OPTIONS_DEFINE= MSF
+MSF_DESC= Enable Metasploit Framework integration
.include <bsd.port.options.mk>
-.if defined(WITH_MSF)
+.if ${PORT_OPTIONS:MMSF}
RUN_DEPENDS+= ${LOCALBASE}/bin/msfcli:${PORTSDIR}/security/metasploit
.endif
post-patch:
(cd ${WRKSRC} && ${RM} -rf `${FIND} . -type d -name .svn`)
+ @${RM} -f ${WRKSRC}/lib/core/settings.py.orig
@${GREP} -lr '/usr/bin/env python' ${WRKSRC} | \
${XARGS} ${REINPLACE_CMD} -i "" \
-e "s!/usr/bin/env python!${PYTHON_CMD}!"
@@ -47,7 +46,7 @@ do-build:
.endfor
do-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for F in AUTHORS ChangeLog README.html README.pdf THANKS
${INSTALL_DATA} ${WRKDIR}/build/doc/${F} ${DOCSDIR}/
diff --git a/security/sqlmap/files/patch-lib_core-settings.py b/security/sqlmap/files/patch-lib_core-settings.py
new file mode 100644
index 000000000000..f4d2b8e3c663
--- /dev/null
+++ b/security/sqlmap/files/patch-lib_core-settings.py
@@ -0,0 +1,11 @@
+--- ./lib/core/settings.py.orig 2011-04-11 04:23:42.000000000 +0400
++++ ./lib/core/settings.py 2012-10-03 23:09:17.000000000 +0400
+@@ -18,7 +18,7 @@
+
+ # sqlmap version and site
+ VERSION = "0.9"
+-REVISION = getRevisionNumber()
++REVISION = 3630
+ VERSION_STRING = "sqlmap/%s" % VERSION
+ DESCRIPTION = "automatic SQL injection and database takeover tool"
+ SITE = "http://sqlmap.sourceforge.net"