aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoreik <eik@FreeBSD.org>2004-03-25 09:46:54 +0800
committereik <eik@FreeBSD.org>2004-03-25 09:46:54 +0800
commite3e9b999837bd6c16866224f1d4000d9d64a9e35 (patch)
treee06a050ff7812c795121d4b71bf9ab3275d5335b /security
parent025aef844a5665442d9376e586c3e115d48af710 (diff)
downloadfreebsd-ports-gnome-e3e9b999837bd6c16866224f1d4000d9d64a9e35.tar.gz
freebsd-ports-gnome-e3e9b999837bd6c16866224f1d4000d9d64a9e35.tar.zst
freebsd-ports-gnome-e3e9b999837bd6c16866224f1d4000d9d64a9e35.zip
use included libtool
Diffstat (limited to 'security')
-rw-r--r--security/clamav/Makefile5
-rw-r--r--security/clamav/files/patch-ltmain.sh39
2 files changed, 36 insertions, 8 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 59695b556c63..1ccc7bd106a1 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -29,7 +29,6 @@ USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-USE_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
PKGINSTALL= ${WRKDIR}/pkg-install
@@ -90,10 +89,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/lib/sendmail|/usr/sbin/sendmail|g' \
${WRKSRC}/clamav-milter/clamav-milter.c
-pre-configure:
- @${REINPLACE_CMD} -e '/^LIBTOOL=/s|\$$(top_builddir)/libtool|${LIBTOOL}|' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-
post-build:
@${REINPLACE_CMD} ${SED_CONF} ${BUILD_WRKSRC}/etc/clamav.conf
@${SED} ${SED_SCRIPT} ${PKGDIR}/pkg-install >${PKGINSTALL}
diff --git a/security/clamav/files/patch-ltmain.sh b/security/clamav/files/patch-ltmain.sh
index 74d32db0b279..261f3f868cad 100644
--- a/security/clamav/files/patch-ltmain.sh
+++ b/security/clamav/files/patch-ltmain.sh
@@ -1,6 +1,39 @@
---- ltmain.sh.orig Sat Sep 27 05:20:20 2003
-+++ ltmain.sh Sat Sep 27 05:24:02 2003
-@@ -4259,10 +4259,16 @@
+--- ltmain.sh.orig Sun Feb 15 12:44:09 2004
++++ ltmain.sh Thu Mar 25 02:15:25 2004
+@@ -1050,25 +1050,18 @@
+ test "X$arg" = "X-lc" && continue
+ ;;
+ esac
+- # This change is required for -lc_r under FreeBSD / Tomasz Kojm
+- #elif test "X$arg" = "X-lc_r"; then
+- # case $host in
+- #*-*-openbsd* | *-*-freebsd*)
+- # # Do not include libc_r directly, use -pthread flag.
+- # continue
+- # ;;
+- # esac
++ elif test "X$arg" = "X-lc_r"; then
++ case $host in
++ *-*-openbsd* | *-*-freebsd4*)
++ # Do not include libc_r directly, use -pthread flag.
++ continue
++ ;;
++ esac
+ fi
+ deplibs="$deplibs $arg"
+ continue
+ ;;
+
+- # We need this change for old -pthread *BSD style / Tomasz Kojm
+- -pthread)
+- deplibs="$deplibs -pthread"
+- continue
+- ;;
+-
+ -module)
+ module=yes
+ continue
+@@ -4259,10 +4252,16 @@
fi
# Install the pseudo-library for information purposes.