aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authornectar <nectar@FreeBSD.org>2003-02-22 00:18:58 +0800
committernectar <nectar@FreeBSD.org>2003-02-22 00:18:58 +0800
commite79ad8ac1207bdb4eaf7bab5f08d7f46f7b1727c (patch)
tree56ad47314eb606dc748ff81023975f98e8f342b0 /security
parent5b6a7a33b3ff27205070c1874c0e7f92576f0676 (diff)
downloadfreebsd-ports-gnome-e79ad8ac1207bdb4eaf7bab5f08d7f46f7b1727c.tar.gz
freebsd-ports-gnome-e79ad8ac1207bdb4eaf7bab5f08d7f46f7b1727c.tar.zst
freebsd-ports-gnome-e79ad8ac1207bdb4eaf7bab5f08d7f46f7b1727c.zip
-- Remove libgmp dependency. It's not used (openssl BN is used).
-- We don't have <des.h> anymore. Use <openssl/des.h>.
Diffstat (limited to 'security')
-rw-r--r--security/isakmpd/Makefile2
-rw-r--r--security/isakmpd/files/patch-Makefile.sysdep11
-rw-r--r--security/isakmpd/files/patch-crypto.h12
3 files changed, 23 insertions, 2 deletions
diff --git a/security/isakmpd/Makefile b/security/isakmpd/Makefile
index ea98b126dd45..88cbde6de2b2 100644
--- a/security/isakmpd/Makefile
+++ b/security/isakmpd/Makefile
@@ -17,8 +17,6 @@ MASTER_SITE_SUBDIR= LOCAL_PORTS
MAINTAINER= ports@FreeBSD.org
COMMENT= OpenBSD IKE daemon
-LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
-
# this is not compatible with cross build - there's no other way
.if !exists(/usr/include/netinet6/ipsec.h)
BROKEN= "requires IPsec support"
diff --git a/security/isakmpd/files/patch-Makefile.sysdep b/security/isakmpd/files/patch-Makefile.sysdep
new file mode 100644
index 000000000000..21d994fef786
--- /dev/null
+++ b/security/isakmpd/files/patch-Makefile.sysdep
@@ -0,0 +1,11 @@
+--- sysdep/freebsd/Makefile.sysdep.orig Fri Feb 21 10:14:47 2003
++++ sysdep/freebsd/Makefile.sysdep Thu Aug 29 01:39:36 2002
+@@ -42,7 +42,7 @@
+ LIBSYSDEPDIR= ${.CURDIR}/sysdep/common/libsysdep
+ .endif
+
+-LDADD+= -lgmp ${LIBSYSDEPDIR}/libsysdep.a -lipsec -L/usr/local/lib
++LDADD+= ${LIBSYSDEPDIR}/libsysdep.a -lipsec -L/usr/local/lib
+ DPADD+= ${LIBGMP} ${LIBSYSDEPDIR}/libsysdep.a
+
+ CFLAGS+= -DHAVE_GETNAMEINFO -DHAVE_GETIFADDRS \
diff --git a/security/isakmpd/files/patch-crypto.h b/security/isakmpd/files/patch-crypto.h
new file mode 100644
index 000000000000..5e72d19b6124
--- /dev/null
+++ b/security/isakmpd/files/patch-crypto.h
@@ -0,0 +1,12 @@
+--- crypto.h.orig Fri Feb 21 10:11:51 2003
++++ crypto.h Fri Feb 21 10:11:58 2003
+@@ -49,7 +49,8 @@
+
+ #else
+
+-#include <des.h>
++#define OPENSSL_DES_LIBDES_COMPATIBILITY
++#include <openssl/des.h>
+ #ifdef USE_BLOWFISH
+ #include <blf.h>
+ #endif