aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2002-10-13 04:27:59 +0800
committerdinoex <dinoex@FreeBSD.org>2002-10-13 04:27:59 +0800
commite7ff1836950901ce76744cacd43ff68d4faf98ce (patch)
tree43b04e274a8d7763a4090b286fdcfdfd97019d91 /security
parent31fdfc6f5c2d8e1ef15832724a659831695d6722 (diff)
downloadfreebsd-ports-gnome-e7ff1836950901ce76744cacd43ff68d4faf98ce.tar.gz
freebsd-ports-gnome-e7ff1836950901ce76744cacd43ff68d4faf98ce.tar.zst
freebsd-ports-gnome-e7ff1836950901ce76744cacd43ff68d4faf98ce.zip
Install openssl's man pages in standard manpath
PR: 43658
Diffstat (limited to 'security')
-rw-r--r--security/openssl-beta/Makefile4
-rw-r--r--security/openssl-beta/files/patch-ab11
-rw-r--r--security/openssl-beta/pkg-plist5
-rw-r--r--security/openssl/Makefile4
-rw-r--r--security/openssl/files/patch-ab11
-rw-r--r--security/openssl/pkg-plist5
6 files changed, 26 insertions, 14 deletions
diff --git a/security/openssl-beta/Makefile b/security/openssl-beta/Makefile
index 3459e03259bf..7b2899c4f472 100644
--- a/security/openssl-beta/Makefile
+++ b/security/openssl-beta/Makefile
@@ -40,12 +40,14 @@ PKGNAMESUFFIX= -beta-overwrite-base
PREFIX= /usr
SHLIBVER= 2
OPENSSLDIR= /etc/ssl
+MANPREFIX= ${PREFIX}/share
.else
OPENSSLDIR= ${PREFIX}/openssl
+MANPREFIX= ${PREFIX}
.endif
+MAKE_ENV+= MANPREFIX=${MANPREFIX}
NO_LATEST_LINK= yes
-MANPREFIX= ${PREFIX}/openssl
MAN1= CA.pl.1 asn1parse.1 ca.1 ciphers.1 crl.1 crl2pkcs7.1 dgst.1 \
dhparam.1 dsa.1 dsaparam.1 enc.1 gendsa.1 genrsa.1 nseq.1 \
diff --git a/security/openssl-beta/files/patch-ab b/security/openssl-beta/files/patch-ab
index 571ebd87ca56..826485fc8a82 100644
--- a/security/openssl-beta/files/patch-ab
+++ b/security/openssl-beta/files/patch-ab
@@ -1,5 +1,14 @@
--- Makefile.org.orig Thu Apr 5 13:08:02 2001
-+++ Makefile.org Mon Apr 23 01:08:26 2001
++++ Makefile.org Sat Oct 12 22:10:18 2002
+@@ -171,7 +171,7 @@
+ MAKEFILE= Makefile.ssl
+ MAKE= make -f Makefile.ssl
+
+-MANDIR=$(OPENSSLDIR)/man
++MANDIR?=$(MANPREFIX)/man
+ MAN1=1
+ MAN3=3
+ SHELL=/bin/sh
@@ -178,7 +178,7 @@
ONEDIRS=out tmp
EDIRS= times doc bugs util include certs ms shlib mt demos perl sf dep VMS
diff --git a/security/openssl-beta/pkg-plist b/security/openssl-beta/pkg-plist
index c32fb6c9aa28..79228040e287 100644
--- a/security/openssl-beta/pkg-plist
+++ b/security/openssl-beta/pkg-plist
@@ -83,11 +83,6 @@ openssl/openssl.cnf.sample
@dirrm include/openssl
@dirrm openssl/certs
@dirrm openssl/lib
-@dirrm openssl/man/man1
-@dirrm openssl/man/man3
-@dirrm openssl/man/man5
-@dirrm openssl/man/man7
-@dirrm openssl/man
@dirrm openssl/misc
@dirrm openssl/private
@dirrm openssl
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 17ab730776cb..d80dc250f296 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -43,11 +43,13 @@ PKGNAMESUFFIX= -overwrite-base
PREFIX= /usr
SHLIBVER= 2
OPENSSLDIR= /etc/ssl
+MANPREFIX= ${PREFIX}/share
.else
OPENSSLDIR= ${PREFIX}/openssl
+MANPREFIX= ${PREFIX}
.endif
-MANPREFIX= ${PREFIX}/openssl
+MAKE_ENV+= MANPREFIX=${MANPREFIX}
MAN1= CA.pl.1 asn1parse.1 ca.1 ciphers.1 crl.1 crl2pkcs7.1 dgst.1 \
dhparam.1 dsa.1 dsaparam.1 enc.1 gendsa.1 genrsa.1 nseq.1 \
diff --git a/security/openssl/files/patch-ab b/security/openssl/files/patch-ab
index 571ebd87ca56..826485fc8a82 100644
--- a/security/openssl/files/patch-ab
+++ b/security/openssl/files/patch-ab
@@ -1,5 +1,14 @@
--- Makefile.org.orig Thu Apr 5 13:08:02 2001
-+++ Makefile.org Mon Apr 23 01:08:26 2001
++++ Makefile.org Sat Oct 12 22:10:18 2002
+@@ -171,7 +171,7 @@
+ MAKEFILE= Makefile.ssl
+ MAKE= make -f Makefile.ssl
+
+-MANDIR=$(OPENSSLDIR)/man
++MANDIR?=$(MANPREFIX)/man
+ MAN1=1
+ MAN3=3
+ SHELL=/bin/sh
@@ -178,7 +178,7 @@
ONEDIRS=out tmp
EDIRS= times doc bugs util include certs ms shlib mt demos perl sf dep VMS
diff --git a/security/openssl/pkg-plist b/security/openssl/pkg-plist
index 67060bf550d4..204cde9ef3e7 100644
--- a/security/openssl/pkg-plist
+++ b/security/openssl/pkg-plist
@@ -74,11 +74,6 @@ openssl/openssl.cnf.sample
@dirrm include/openssl
@dirrm openssl/certs
@dirrm openssl/lib
-@dirrm openssl/man/man1
-@dirrm openssl/man/man3
-@dirrm openssl/man/man5
-@dirrm openssl/man/man7
-@dirrm openssl/man
@dirrm openssl/misc
@dirrm openssl/private
@dirrm openssl